Bug 1052258

Summary: [GSS] (6.3.0) segfault and other xnio issues running on IBM JDK on IBM-I
Product: [JBoss] JBoss Enterprise Application Platform 6 Reporter: Brad Maxwell <bmaxwell>
Component: RemotingAssignee: Brad Maxwell <bmaxwell>
Status: CLOSED CURRENTRELEASE QA Contact: Jitka Kozana <jkudrnac>
Severity: unspecified Docs Contact: Russell Dickenson <rdickens>
Priority: unspecified    
Version: 6.2.0CC: jkudrnac, kkhan, smumford
Target Milestone: DR3   
Target Release: EAP 6.3.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
An issue with applications running on IBM systems failing with a segmentation fault has been corrected in this release of JBoss EAP 6. The crashes were caused by NIO implementations in IBM JDKs that are optimized for usage on IBM operating systems. The I/O layer in JBoss EAP attempts to detect and utilize these implementations. However on some operating systems (like IBM-I) these implementations cause a segfault. In this release of the product, these operating systems are detected and safe fall-backs are utilized. This resolves the segmentation fault issue and the application server no longer crashes unexpectedly.
Story Points: ---
Clone Of: 1030104 Environment:
Last Closed: 2014-06-28 15:27:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1030102, 1030104