Bug 1079287

Summary: Tasks are cleared while they are still running
Product: Red Hat Enterprise Virtualization Manager Reporter: Pablo Iranzo Gómez <pablo.iranzo>
Component: ovirt-engineAssignee: Liran Zelkha <lzelkha>
Status: CLOSED ERRATA QA Contact: movciari
Severity: medium Docs Contact:
Priority: medium    
Version: 3.3.0CC: aberezin, acathrow, adahms, bazulay, eedri, emesika, iheim, lpeer, oourfali, pstehlik, Rhev-m-bugs, yeylon, zdover
Target Milestone: ---Keywords: ZStream
Target Release: 3.3.3   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: infra
Fixed In Version: org.ovirt.engine-root-3.3.0-51 Doc Type: Bug Fix
Doc Text:
Previously, jobs that took a long time to complete were removed from the task list in the Administration Portal even if they were in progress. This was caused by the logic used to clean up jobs: jobs that contained at least one step that did not include any asynchronous tasks were deleted. Now, the logic has been revised so that only jobs without steps including asynchronous tasks are deleted.
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-05-27 09:07:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Pablo Iranzo Gómez 2014-03-21 11:12:59 UTC
Description of problem:

When performing a long-running task it may get cleared while it is still running.


Version-Release number of selected component (if applicable):
rhevm-backend-3.3.1-0.48.el6ev.noarch

How reproducible:
(tested on small lab with 1Gbps interconnect and NFS storagedomains

Steps to Reproduce:
1. Move disk from one SD to another
2. Wait e task to disappear from gui
3. cat /NFSmountpoint/uuid/master/tasks/uuid/uuid.task and check status

Actual results:
Task was still running but was cleared from GUI

Expected results:
Task should still appear in the task list of RHEV-M

Comment 3 Oved Ourfali 2014-03-24 13:22:23 UTC
This issue was fixed in 3.4.0 (See Bug #1064227).
Need to backport to 3.3.Z.

Comment 6 errata-xmlrpc 2014-05-27 09:07:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0547.html