Bug 1079287 - Tasks are cleared while they are still running
Summary: Tasks are cleared while they are still running
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.3.3
Assignee: Liran Zelkha
QA Contact: movciari
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-21 11:12 UTC by Pablo Iranzo Gómez
Modified: 2019-04-28 10:02 UTC (History)
13 users (show)

Fixed In Version: org.ovirt.engine-root-3.3.0-51
Doc Type: Bug Fix
Doc Text:
Previously, jobs that took a long time to complete were removed from the task list in the Administration Portal even if they were in progress. This was caused by the logic used to clean up jobs: jobs that contained at least one step that did not include any asynchronous tasks were deleted. Now, the logic has been revised so that only jobs without steps including asynchronous tasks are deleted.
Clone Of:
Environment:
Last Closed: 2014-05-27 09:07:36 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 761743 None None None Never
Red Hat Product Errata RHBA-2014:0547 normal SHIPPED_LIVE rhevm 3.3.3 bug fix update 2014-05-27 13:07:15 UTC
oVirt gerrit 26056 None None None Never

Description Pablo Iranzo Gómez 2014-03-21 11:12:59 UTC
Description of problem:

When performing a long-running task it may get cleared while it is still running.


Version-Release number of selected component (if applicable):
rhevm-backend-3.3.1-0.48.el6ev.noarch

How reproducible:
(tested on small lab with 1Gbps interconnect and NFS storagedomains

Steps to Reproduce:
1. Move disk from one SD to another
2. Wait e task to disappear from gui
3. cat /NFSmountpoint/uuid/master/tasks/uuid/uuid.task and check status

Actual results:
Task was still running but was cleared from GUI

Expected results:
Task should still appear in the task list of RHEV-M

Comment 3 Oved Ourfali 2014-03-24 13:22:23 UTC
This issue was fixed in 3.4.0 (See Bug #1064227).
Need to backport to 3.3.Z.

Comment 6 errata-xmlrpc 2014-05-27 09:07:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0547.html


Note You need to log in before you can comment on or make changes to this bug.