Bug 1121532

Summary: Template: creating a template without any name raises same error two times
Product: Red Hat Satellite Reporter: Sachin Ghai <sghai>
Component: WebUIAssignee: Ohad Levy <ohadlevy>
Status: CLOSED UPSTREAM QA Contact: Katello QA List <katello-qa-list>
Severity: low Docs Contact:
Priority: unspecified    
Version: 6.0.4CC: bbuckingham, cwelton, daobrien, dcleal
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
URL: http://projects.theforeman.org/issues/6888
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-10 12:07:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
UI throws same error twice: "can't be blank and can't be blank" none

Description Sachin Ghai 2014-07-21 07:26:33 UTC
Created attachment 919545 [details]
UI throws same error twice: "can't be blank and can't be blank"

Description of problem:
I was trying to create a template and didn't pass any name, then UI throws following error adjacent to 'name' text box

"can't be blank and can't be blank"


Version-Release number of selected component (if applicable):
sat6 GA snap1

How reproducible:
always

Steps to Reproduce:
1. create a template without passing name
2.
3.

Actual results:
UI throws same error two times

Expected results:
one time "can't be blank is sufficient

Additional info:

production.log:

Processing by ConfigTemplatesController#create as */*
  Parameters: {"utf8"=>"✓", "search"=>"", "authenticity_token"=>"CLZgGQh3Z80gTOE6iG1eaDPvDAf4ISpF73pxHLoz0K4=", "config_template"=>{"name"=>"", "template"=>"test", "audit_comment"=>"", "snippet"=>"0", "template_kind_id"=>"1", "operatingsystem_ids"=>["", "", "", ""]}, "keybinding"=>"Default"}
Failed to save: Name can't be blank, Name can't be blank
  Rendered common/_edit_habtm.html.erb (5.1ms)

Comment 2 Dominic Cleal 2014-07-24 14:40:33 UTC
Created redmine issue http://projects.theforeman.org/issues/6769 from this bug

Comment 3 Bryan Kearney 2014-08-06 19:39:24 UTC
Connecting redmine issue http://projects.theforeman.org/issues/6888 from this bug

Comment 4 Bryan Kearney 2014-08-06 20:03:47 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6888 has been closed
-------------
Dominic Cleal
Applied in changeset commit:51b90bff2d0f965b2cf198ad520312ee2c53570d.

Comment 5 Bryan Kearney 2014-08-10 12:07:00 UTC
Upstream has resolved this bug. It will be available in a future verison of Satellite 6.

Comment 6 Dominic Cleal 2014-12-16 15:11:15 UTC
*** Bug 1174834 has been marked as a duplicate of this bug. ***