Bug 1121532 - Template: creating a template without any name raises same error two times
Summary: Template: creating a template without any name raises same error two times
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1174834 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 07:26 UTC by Sachin Ghai
Modified: 2017-02-23 21:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-10 12:07:00 UTC


Attachments (Terms of Use)
UI throws same error twice: "can't be blank and can't be blank" (44.16 KB, image/png)
2014-07-21 07:26 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6888 None None None 2016-04-22 15:59:50 UTC

Description Sachin Ghai 2014-07-21 07:26:33 UTC
Created attachment 919545 [details]
UI throws same error twice: "can't be blank and can't be blank"

Description of problem:
I was trying to create a template and didn't pass any name, then UI throws following error adjacent to 'name' text box

"can't be blank and can't be blank"


Version-Release number of selected component (if applicable):
sat6 GA snap1

How reproducible:
always

Steps to Reproduce:
1. create a template without passing name
2.
3.

Actual results:
UI throws same error two times

Expected results:
one time "can't be blank is sufficient

Additional info:

production.log:

Processing by ConfigTemplatesController#create as */*
  Parameters: {"utf8"=>"✓", "search"=>"", "authenticity_token"=>"CLZgGQh3Z80gTOE6iG1eaDPvDAf4ISpF73pxHLoz0K4=", "config_template"=>{"name"=>"", "template"=>"test", "audit_comment"=>"", "snippet"=>"0", "template_kind_id"=>"1", "operatingsystem_ids"=>["", "", "", ""]}, "keybinding"=>"Default"}
Failed to save: Name can't be blank, Name can't be blank
  Rendered common/_edit_habtm.html.erb (5.1ms)

Comment 2 Dominic Cleal 2014-07-24 14:40:33 UTC
Created redmine issue http://projects.theforeman.org/issues/6769 from this bug

Comment 3 Bryan Kearney 2014-08-06 19:39:24 UTC
Connecting redmine issue http://projects.theforeman.org/issues/6888 from this bug

Comment 4 Bryan Kearney 2014-08-06 20:03:47 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6888 has been closed
-------------
Dominic Cleal
Applied in changeset commit:51b90bff2d0f965b2cf198ad520312ee2c53570d.

Comment 5 Bryan Kearney 2014-08-10 12:07:00 UTC
Upstream has resolved this bug. It will be available in a future verison of Satellite 6.

Comment 6 Dominic Cleal 2014-12-16 15:11:15 UTC
*** Bug 1174834 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.