Bug 1125161

Summary: 'Users' object has no attribute 'get_owner' - SDK & CLI
Product: [Retired] oVirt Reporter: Nelly Credi <ncredi>
Component: ovirt-engine-sdkAssignee: Ravi Nori <rnori>
Status: CLOSED DUPLICATE QA Contact: Pavel Stehlik <pstehlik>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 3.5CC: acathrow, bugs, ecohen, gklein, iheim, omachace, oourfali, yeylon
Target Milestone: ---Keywords: AutomationBlocker, Regression, Triaged
Target Release: 3.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: Infra
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-08 01:20:19 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1073943    

Description Nelly Credi 2014-07-31 08:31:31 UTC
Description of problem:
when trying to query on users an error is raised - 'Users' object has no attribute 'get_owner'

Version-Release number of selected component (if applicable):
3.5-beta2

How reproducible:
100%

Steps to Reproduce:
1.open shell
2.list users

Actual results:
[oVirt shell (connected)]# list users
  =========================================================== UNKNOWN ERROR =========================================================
                                              'Users' object has no attribute 'get_owner'
  ===================================================================================================================================



Expected results:
list of users

Additional info:

Comment 1 Ondra Machacek 2014-08-05 09:58:20 UTC
*** Bug 1126793 has been marked as a duplicate of this bug. ***

Comment 2 Ravi Nori 2014-08-08 01:20:19 UTC

*** This bug has been marked as a duplicate of bug 1122589 ***