Bug 1073943 - Tracker: oVirt 3.5 release
Summary: Tracker: oVirt 3.5 release
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On: 1001100 1060198 1073944 1098884 1099425 1099432 1109920 1110305 1113091 1113485 1113882 1113891 1113898 1113974 1114057 1114499 1114914 1114987 1114994 1115001 1115033 1115044 1115127 1115152 1115154 1115466 1115543 1116009 1116585 1119024 1120721 1121694 1122546 1122589 1122592 1124099 1124141 1124481 1124795 1124796 1125161 1125196 1126800 1126920 1127294 1127460 1127464 1127623 1127877 1128776 1129261 1130038 1130045 1131030 1131226 1134233 1136272 1138181 1138314 1138340 1138731 1138986 1139533 1139817 1141510 1143042 1143854 1143860 1144079 1145728 1146073 1147085 1147261 1147971 1149637 1149705 1149883 1150075 1150555 1150906 1151819 1151827
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-07 14:28 UTC by Sandro Bonazzola
Modified: 2015-02-09 14:13 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:37:25 UTC
oVirt Team: ---
sbonazzo: ovirt_requires_release_note+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 33084 ovirt-engine-3.5 ABANDONED build: ovirt-engine-3.5.0 Never
oVirt gerrit 33159 ovirt-engine-3.5 MERGED build: post ovirt-engine-3.5.0 branching Never
oVirt gerrit 33398 master ABANDONED build: ovirt-engine-3.5.0 Never
oVirt gerrit 33652 ovirt-engine-3.5.0 MERGED build: ovirt-engine-3.5.0 Never
oVirt gerrit 34167 ovirt-engine-3.5.0 MERGED build: ovirt-engine-3.5.0.1 Never

Description Sandro Bonazzola 2014-03-07 14:28:08 UTC
This is a tracker bug for all bugs blocking the 3.4 release of oVirt.

Comment 1 Markus Stockhausen 2014-06-18 10:29:58 UTC
May I ask to add BZ1110305 to the blocker list?

Comment 2 Michal Skrivanek 2014-06-25 14:29:02 UTC
(In reply to Markus Stockhausen from comment #1)
weird, I'm not aware of any other setup with the same behavior. There might be something specific to your environment? is it a regression?

Comment 3 Markus Stockhausen 2014-06-25 14:39:01 UTC
I guess the problem can only be seen in environments with heavy load. In our case the VM crashed during heavy disk IO. As the documentation attached to the BZ suggests other people have noticed the same BSODs . To mitigate the error the advice is to start Windows 7/2008/... VMs with relax option (to enable enlightment in the VM). 

My understanding of this all is:

- We see a BSOD in a VM
- I open BZ1110305 for that to help to track the error down
- The advised solution is to add a qemu startup parameter
- So OVirt should set this parameter by default

What else should we do?

Comment 4 Michal Skrivanek 2014-06-26 08:13:47 UTC
(In reply to Markus Stockhausen from comment #3)
BSODs are bad. Even though it is not a regression since 3.4 it is an important stability issue

Comment 5 Michal Skrivanek 2014-06-26 08:14:24 UTC
(the other way around:)

Comment 6 Markus Stockhausen 2014-06-28 07:54:35 UTC
BZ1113503 (although not being a regression) should be tested in 3.5 and if still present get a fix. At least in my opinion this improves stability (some kind of) too.

Comment 7 Sven Kieske 2014-07-16 13:03:13 UTC
afaik BZ 1114914 should also be added as a blocker?

Comment 8 Sandro Bonazzola 2014-07-16 13:12:08 UTC
(In reply to Sven Kieske from comment #7)
> afaik BZ 1114914 should also be added as a blocker?

I agree, added.

Comment 9 Sven Kieske 2014-09-10 13:45:41 UTC
Please consider:
https://bugzilla.redhat.com/show_bug.cgi?id=1138314

as a blocker, as it is a regression which makes cloud-init unusable for custom scripts (e.g. set IPv6 configurations and everything cloud-init can't do out of the box)

Thanks

Comment 10 Stefano Stagnaro 2014-10-01 13:09:24 UTC
Would you please add BZ1105513 as blocker since there isn't any workaround for it (afaik)?

Comment 11 Sandro Bonazzola 2014-10-01 14:46:53 UTC
(In reply to Stefano Stagnaro from comment #10)
> Would you please add BZ1105513 as blocker since there isn't any workaround
> for it (afaik)?

It's in modified state since 2014-08-26 so it should be fixed.

Comment 12 Sandro Bonazzola 2014-10-17 12:37:25 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.