Bug 1126379

Summary: Add vmstate json representation files for RHEL6 releases to source tree
Product: Red Hat Enterprise Linux 8 Reporter: Amit Shah <amit.shah>
Component: qemu-kvmAssignee: Hai Huang <hhuang>
Status: CLOSED WONTFIX QA Contact: jingzhao <jinzhao>
Severity: unspecified Docs Contact:
Priority: medium    
Version: 8.1CC: chayang, hhuang, juzhang, knoel, mkenneth, qzhang, rbalakri, virt-bugs, virt-maint, xfu
Target Milestone: pre-dev-freeze   
Target Release: 8.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1126377 Environment:
Last Closed: 2019-08-16 13:08:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1125792, 1126377, 1129217    
Bug Blocks:    

Description Amit Shah 2014-08-04 09:53:33 UTC
RHEL7 qemu-kvm-rhev clone

+++ This bug was initially created as a clone of Bug #1126377 +++

RHEL7 qemu-kvm clone

+++ This bug was initially created as a clone of Bug #1125792 +++

Description of problem:

VMstate json representations of older RHEL6 releases should be added to the qemu source tree.  This will facilitate checking of migration compatibility that the static checker is capable of performing.

These files will be placed in the tests/vmstate-static-checker-data/ directory.  The nomenclature, subject to change, is:

rhel60-60.json

Which means this json was produced on a rhel6.0 build, with the 6.0 machine type.

rhel61-60.json

means this json was produced on rhel6.1 build with the 6.0 machine type.

Since we only have one machine type option on RHEL6, this naming scheme suffices.

New test cases are to be added to the QE test plan which runs the static checker python script (most likely from the upstream tree) and ensures no regressions are being added to the development version of RHEL6.

The testing can be automated, and can be added to autotest, as well as nightly scripts.  Release maintainers can do this at git tagging time as well.

These files will be placed in the RHEL7 tree as well, to facilitate RHEL6->RHEL7 testing.