Bug 1126377 - Add vmstate json representation files for RHEL6 releases to source tree
Summary: Add vmstate json representation files for RHEL6 releases to source tree
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: qemu-kvm
Version: ---
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: pre-dev-freeze
: 8.1
Assignee: Hai Huang
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1129217 (view as bug list)
Depends On: 1125792 1129217
Blocks: 1126379
TreeView+ depends on / blocked
 
Reported: 2014-08-04 09:52 UTC by Amit Shah
Modified: 2019-08-16 13:09 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1125792
: 1126379 (view as bug list)
Environment:
Last Closed: 2019-08-16 13:09:15 UTC
Type: Bug


Attachments (Terms of Use)

Description Amit Shah 2014-08-04 09:52:10 UTC
RHEL7 qemu-kvm clone

+++ This bug was initially created as a clone of Bug #1125792 +++

Description of problem:

VMstate json representations of older RHEL6 releases should be added to the qemu source tree.  This will facilitate checking of migration compatibility that the static checker is capable of performing.

These files will be placed in the tests/vmstate-static-checker-data/ directory.  The nomenclature, subject to change, is:

rhel60-60.json

Which means this json was produced on a rhel6.0 build, with the 6.0 machine type.

rhel61-60.json

means this json was produced on rhel6.1 build with the 6.0 machine type.

Since we only have one machine type option on RHEL6, this naming scheme suffices.

New test cases are to be added to the QE test plan which runs the static checker python script (most likely from the upstream tree) and ensures no regressions are being added to the development version of RHEL6.

The testing can be automated, and can be added to autotest, as well as nightly scripts.  Release maintainers can do this at git tagging time as well.

These files will be placed in the RHEL7 tree as well, to facilitate RHEL6->RHEL7 testing.

Comment 1 Amit Shah 2014-08-12 10:35:47 UTC
*** Bug 1129217 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.