Bug 1129217 - Add vmstate json representation files for RHEL6 releases to source tree
Summary: Add vmstate json representation files for RHEL6 releases to source tree
Keywords:
Status: CLOSED DUPLICATE of bug 1126377
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Amit Shah
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1125792
Blocks: 1126377 1126379
TreeView+ depends on / blocked
 
Reported: 2014-08-12 10:34 UTC by Amit Shah
Modified: 2014-08-12 10:35 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1125792
Environment:
Last Closed: 2014-08-12 10:35:47 UTC


Attachments (Terms of Use)

Description Amit Shah 2014-08-12 10:34:31 UTC
RHEL7 qemu-kvm clone

+++ This bug was initially created as a clone of Bug #1125792 +++

Description of problem:

VMstate json representations of older RHEL6 releases should be added to the qemu source tree.  This will facilitate checking of migration compatibility that the static checker is capable of performing.

These files will be placed in the tests/vmstate-static-checker-data/ directory.  The nomenclature, subject to change, is:

rhel60-60.json

Which means this json was produced on a rhel6.0 build, with the 6.0 machine type.

rhel61-60.json

means this json was produced on rhel6.1 build with the 6.0 machine type.

Since we only have one machine type option on RHEL6, this naming scheme suffices.

New test cases are to be added to the QE test plan which runs the static checker python script (most likely from the upstream tree) and ensures no regressions are being added to the development version of RHEL6.

The testing can be automated, and can be added to autotest, as well as nightly scripts.  Release maintainers can do this at git tagging time as well.

These files will be placed in the RHEL7 tree as well, to facilitate RHEL6->RHEL7 testing.

--- Additional comment from Amit Shah on 2014-08-12 16:02:34 IST ---

The patches that were posted and acked had slightly different names for the json files:

> These files will be placed in the tests/vmstate-static-checker-data/
> directory.  The nomenclature, subject to change, is:
> 
> rhel60-60.json

Instead of this, we used

rhel60,rhel6.0.0.json

> Which means this json was produced on a rhel6.0 build, with the 6.0 machine
> type.
> 
> rhel61-60.json

instead of this, we used

rhel61-rhel6.0.0.json

> means this json was produced on rhel6.1 build with the 6.0 machine type.

Comment 1 Amit Shah 2014-08-12 10:35:47 UTC

*** This bug has been marked as a duplicate of bug 1126377 ***


Note You need to log in before you can comment on or make changes to this bug.