Bug 1205320

Summary: need latest sssd-dbus package in satellite61 repository
Product: Red Hat Satellite Reporter: Kedar Bidarkar <kbidarka>
Component: PackagingAssignee: Jason Montleon <jmontleo>
Status: CLOSED ERRATA QA Contact: Kedar Bidarkar <kbidarka>
Severity: high Docs Contact:
Priority: high    
Version: 6.1.0CC: bbuckingham, bkearney, cwelton, greartes, jpazdziora, mmccune, pgervase, pmutha, rfreire
Target Milestone: UnspecifiedKeywords: Reopened, Triaged
Target Release: Unused   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1207774 1241409 (view as bug list) Environment:
Last Closed: 2016-07-27 08:49:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
katello installer none

Description Kedar Bidarkar 2015-03-24 16:41:18 UTC
Description of problem:

Currently sssd-dbus is the only package which needs to be fetched from the repo

'rhel-7-server-optional-rpms'. jmontleo suggested we get this in to sat6.repo

Let's track this issue here.

Version-Release number of selected component (if applicable):
sat6.1-Beta-snap7-compose3/Satellite-6.1.0-RHEL-7-20150320.1

How reproducible:


Steps to Reproduce:
1. Package is required while running 
2. katello-installer --foreman-ipa-authentication=true
3.

Actual results:
unable to fetch sssd-dbus and requires 'rhel-7-server-optional-rpms' repo to fetch it.

Expected results:
should be part of sat6.repo as per jason's/jmontleo suggestion.

Additional info:

Comment 3 Bryan Kearney 2015-04-21 16:33:51 UTC
*** Bug 1213616 has been marked as a duplicate of this bug. ***

Comment 4 Tazim Kolhar 2015-04-28 11:07:32 UTC
FAILEDQA:

# rpm -qa | grep foreman
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
foreman-selinux-1.7.2.13-1.el7sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.9-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.12.3-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.3-1.el7sat.noarch
foreman-debug-1.7.2.17-1.el7sat.noarch
foreman-libvirt-1.7.2.17-1.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.10-1.el7sat.noarch
foreman-compute-1.7.2.17-1.el7sat.noarch
foreman-ovirt-1.7.2.17-1.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.5-1.el7sat.noarch
foreman-postgresql-1.7.2.17-1.el7sat.noarch
qe-sat6-rhel71.usersys.redhat.com-foreman-client-1.0-1.noarch
qe-sat6-rhel71.usersys.redhat.com-foreman-proxy-1.0-1.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
foreman-1.7.2.17-1.el7sat.noarch
foreman-gce-1.7.2.17-1.el7sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.9-1.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.9-1.el7sat.noarch
foreman-vmware-1.7.2.17-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.7-1.el7sat.noarch
foreman-proxy-1.7.2.4-1.el7sat.noarch
qe-sat6-rhel71.usersys.redhat.com-foreman-proxy-client-1.0-1.noarch
ruby193-rubygem-foreman-redhat_access-0.1.0-1.el7sat.noarch

steps
 subscription-manager repos --enable rhel-7-server-optional-rpms
Repository 'rhel-7-server-optional-rpms' is enabled for this system.
 yum install -y sssd-dbus
# katello-installer --foreman-ipa-authentication=true
Preparing installation Done                                          
  Something went wrong! Check the log for ERROR-level output
  The full log is at /var/log/katello-installer/katello-installer.log

attaching katello-installer.log

Comment 5 Tazim Kolhar 2015-04-28 11:07:48 UTC
Created attachment 1019633 [details]
katello installer

Comment 6 Mike McCune 2015-05-18 17:05:57 UTC
sssd-dbus is available in the latest builds. The error in your attached logs is something different from this bug:

[ERROR 2015-04-28 07:01:13 main] Repeating errors encountered during run:
[ERROR 2015-04-28 07:01:13 main]  qe-sat6-rhel71: The system does not seem to be IPA-enrolled at /usr/share/katello-installer/modules/foreman/manifests/config.pp:55 on node qe-sat6-rhel71.usersys.redhat.com
[ERROR 2015-04-28 07:01:13 main]  qe-sat6-rhel71: The system does not seem to be IPA-enrolled at /usr/share/katello-installer/modules/foreman/manifests/config.pp:55 on node qe-sat6-rhel71.usersys.redhat.com

if sssd-dbus is installed, this bug is verified.

Comment 7 Tazim Kolhar 2015-05-19 07:48:16 UTC
VERIFIED:
# rpm -qa | grep foreman
foreman-1.7.2.21-1.el7sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.13-1.el7sat.noarch
foreman-libvirt-1.7.2.21-1.el7sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
foreman-postgresql-1.7.2.21-1.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.13-1.el7sat.noarch
dell-pem710-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-ovirt-1.7.2.21-1.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.11-1.el7sat.noarch
foreman-selinux-1.7.2.13-1.el7sat.noarch
foreman-gce-1.7.2.21-1.el7sat.noarch
ruby193-rubygem-foreman-redhat_access-0.1.0-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.12.5-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.4-1.el7sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.6-1.el7sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.12-1.el7sat.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el7sat.noarch
foreman-proxy-1.7.2.4-1.el7sat.noarch
dell-pem710-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
dell-pem710-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
foreman-vmware-1.7.2.21-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el7sat.noarch
foreman-compute-1.7.2.21-1.el7sat.noarch
foreman-debug-1.7.2.21-1.el7sat.noarch


steps:
#  subscription-manager repos --enable rhel-7-server-optional-rpms
Repository 'rhel-7-server-optional-rpms' is enabled for this system.

# yum install -y sssd-dbus
Loaded plugins: product-id, subscription-manager
Installed:
  sssd-dbus.x86_64 0:1.12.2-58.el7_1.6                                          

Dependency Installed:
  c-ares.x86_64 0:1.10.0-3.el7                                                  
  cyrus-sasl-gssapi.x86_64 0:2.1.26-17.el7                                      
  libdhash.x86_64 0:0.4.3-24.el7                                                
  libldb.x86_64 0:1.1.17-2.el7                                                  
  libsss_idmap.x86_64 0:1.12.2-58.el7_1.6                                       
  libsss_nss_idmap.x86_64 0:1.12.2-58.el7_1.6                                   
  libtdb.x86_64 0:1.3.0-1.el7                                                   
  sssd-client.x86_64 0:1.12.2-58.el7_1.6                                        
  sssd-common.x86_64 0:1.12.2-58.el7_1.6                                        
  sssd-krb5-common.x86_64 0:1.12.2-58.el7_1.6                                   

Complete!

as per the comment https://bugzilla.redhat.com/show_bug.cgi?id=1205320#c6  sssd-dbus is installed hence the bz is verified

Comment 8 Bryan Kearney 2015-08-11 13:29:11 UTC
This bug is slated to be released with Satellite 6.1.

Comment 9 Bryan Kearney 2015-08-12 13:55:39 UTC
This bug was fixed in version 6.1.1 of Satellite which was released on 12 August, 2015.

Comment 10 Jan Pazdziora 2015-08-18 18:26:06 UTC
Reopening. The comment 7 which VERIFIED this bugzilla used the optional repo which comment 0 specifically asked not to be enabled.

Comment 11 Kedar Bidarkar 2015-08-27 20:07:24 UTC
Also note https://bugzilla.redhat.com/show_bug.cgi?id=1251116#c4

Comment 12 Rodrigo A B Freire 2015-10-27 14:42:32 UTC
Bump; are we moving this issue forward?
BZ seems to be moving laterally since August (and we 're almost in November)

Comment 14 Jan Pazdziora 2015-11-23 14:42:57 UTC
With RHEL 7.2 released and bug 1180604 resolved, this is no longer needed.

It would be nice though for QE to check that katello-installer --foreman-ipa-authentication=true now passes without the Optional channel.

Comment 15 Bryan Kearney 2015-12-18 17:50:27 UTC
Moving to ON_QA to be veirfied based on commment 14.

Comment 16 Kedar Bidarkar 2016-01-18 17:59:07 UTC
1) sssd-dbus packages is now available via RHEL7 base repo and no longer via the optional repo.
2) katello-installer --foreman-ipa-authentication=true , completed successfully.


VERIFIED with Sat6.1.6 compose5.

Comment 20 errata-xmlrpc 2016-07-27 08:49:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500