Bug 1205648

Summary: RFE: csc_opencl support in xpra
Product: [Fedora] Fedora Reporter: Jonathan Underwood <jonathan.underwood>
Component: xpraAssignee: Jonathan Underwood <jonathan.underwood>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: antoine, dennis.schridde, jonathan.underwood
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: xpra-0.16.2-4.fc23 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-02-29 05:25:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1002898, 1219815, 1219819    
Bug Blocks:    

Description Jonathan Underwood 2015-03-25 12:05:46 UTC
Description of problem:

Currently the xpra package uses the Cython csc (colour space conversion) module rather than opencl which could potentially improve performance. Enabling this would require packaging pyopencl. This is a bug to track progress on that.

However, it's not immediately clear this is a win. During the xpra package review (BZ #1198312) upstream had this to say (comment #19):

Re CSC:
* you don't /really/ need pyopencl, we have the cython csc module as fallback - which is usually fast enough
* I have experienced issues with pyopencl and the AMD icd, causing hangs because of interference with the signal handlers... so we're unsure what to do with this one (and in most cases, swscale is just as fast..)

Comment 1 Jonathan Underwood 2015-08-05 11:02:54 UTC
Packaging of pyopencl is currently blocked on pytools being updated, BZ #1002898

Comment 2 Jonathan Underwood 2015-12-02 15:38:52 UTC
pyopencl has been added to the rawhide (F24) package starting with 0.15.8-1, with pyopencl being a weak dependency. Support will be added in F23 once the pyopencl package and deps get pushed there.

Comment 3 Fedora Update System 2016-02-19 13:43:38 UTC
xpra-0.16.2-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-241d30d0c5

Comment 4 Fedora Update System 2016-02-19 15:49:09 UTC
xpra-0.16.2-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-241d30d0c5

Comment 5 Fedora Update System 2016-02-21 17:59:07 UTC
xpra-0.16.2-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-241d30d0c5

Comment 6 Fedora Update System 2016-02-29 05:24:59 UTC
xpra-0.16.2-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.