Bug 1207943

Summary: Extra padding around transparent terminals in Wayland
Product: [Fedora] Fedora Reporter: Krishna <kvvnkbabu>
Component: gnome-terminalAssignee: Matthias Clasen <mclasen>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 22CC: alexvillacislasso, anton4linux, berend.de.schouwer, bodhi.zazen, debarshir, fmuellner, jason, jstpierr, mclasen, nekohayo, ofourdan, ojrajala, otaylor, pkocandr, rc556677, robert.smol, robert, rodd, sten, zali
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: gnome-terminal-3.18.2-1.fc23 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-11-23 20:56:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Padding around window frame for Gnome terminal
none
Maximized Gnome terminal under Wayland
none
Add patch fixing transparent mode under Wayland none

Description Krishna 2015-04-01 04:09:15 UTC
Created attachment 1009444 [details]
Padding around window frame for Gnome terminal

Description of problem:
Gnome Terminal under wayland session shows an unwanted padding around the window boarder when transparency is is enabled for the terminal

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Open Gnome terminal under wayland session 
2. Edit profile preferences 
3. Change the transparency 

Actual results:
Attachment for reference. 

Expected results:


Additional info:

Comment 1 Olivier Fourdan 2015-04-21 14:07:41 UTC
I think this is a bug in gnome-terminal instead, the same problem can be observed with weston as well, so this is not specific to the Wayland compositor.

Note that transparency is not upstream, this is from a patch in our package:

  gnome-terminal-restore-transparency.patch

That patch modifies update_color_scheme() from gnome-terminal/src/terminal-screen.c to do:

  toplevel = gtk_widget_get_toplevel (GTK_WIDGET (screen));
  if (toplevel != NULL && gtk_widget_is_toplevel (toplevel))
    gtk_widget_set_app_paintable (toplevel, transparent);

This is what causes the issue apparently, removing that call to gtk_widget_set_app_paintable() fixes the issue but also breaks transparency.

Meanwhile, moving to gnome-terminal for further investigation.

Comment 2 Olivier Fourdan 2015-04-21 15:56:51 UTC
To be more precise, gnome-terminal has its own terminal_window_draw() routine in src/terminal-window.c which does:

2191 static gboolean
2192 terminal_window_draw (GtkWidget *widget,
2193                       cairo_t   *cr)
2194 {
2195   if (gtk_widget_get_app_paintable (widget))
2196     {
2197       GtkStyleContext *context;
2198       int width;
2199       int height;
2200 
2201       context = gtk_widget_get_style_context (widget);
2202       width = gtk_widget_get_allocated_width (widget);
2203       height = gtk_widget_get_allocated_height (widget);
2204       gtk_render_background (context, cr, 0, 0, width, height);
2205       gtk_render_frame (context, cr, 0, 0, width, height);
2206     }
2207 
2208   return GTK_WIDGET_CLASS (terminal_window_parent_class)->draw (widget, cr);
2209 }
2210 

The call to gtk_render_background() (which is only when gtk_widget_get_app_paintable() is true, corollary of comment #1) is what causes the window borders to be repainted opaque when transparency is enabled.

i.e. gnome-terminal tries to draw its frame itself with terminal_window_draw() but is missing a lot of the logic found in  gtk's own gtk_window_draw()

Comment 3 Petr Kočandrle 2015-05-22 09:47:02 UTC
Created attachment 1028663 [details]
Maximized Gnome terminal under Wayland

I experience another drawing problem, not sure if it's the same or not. I don't use transparency but when I maximize the terminal window in Wayland session it gets transparent right and bottom border of size 7 and 6 pixels respectively. Attaching a screenshot. There is no such issue when using standard X session.

Comment 4 Olivier Fourdan 2015-06-03 08:26:12 UTC
(In reply to Petr Kočandrle from comment #3)
> Created attachment 1028663 [details]
> Maximized Gnome terminal under Wayland
> 
> I experience another drawing problem, not sure if it's the same or not. I
> don't use transparency but when I maximize the terminal window in Wayland
> session it gets transparent right and bottom border of size 7 and 6 pixels
> respectively. Attaching a screenshot. There is no such issue when using
> standard X session.

Looks like the window size is constrained by its size increments (basically the size of the characters), different issue imho.

Comment 5 Petr Kočandrle 2015-06-04 07:45:26 UTC
(In reply to Olivier Fourdan from comment #4)
> (In reply to Petr Kočandrle from comment #3)
> > Created attachment 1028663 [details]
> > Maximized Gnome terminal under Wayland
> > 
> > I experience another drawing problem, not sure if it's the same or not. I
> > don't use transparency but when I maximize the terminal window in Wayland
> > session it gets transparent right and bottom border of size 7 and 6 pixels
> > respectively. Attaching a screenshot. There is no such issue when using
> > standard X session.
> 
> Looks like the window size is constrained by its size increments (basically
> the size of the characters), different issue imho.

OK, I filed another bug #1228081 to track that.

Comment 6 Berend De Schouwer 2015-09-25 11:30:53 UTC
F23 Beta:

The padding appears gone.

Maximize isn't completely correct, see #1228081

Shadow isn't being drawn around the terminal windows.  It appears around other windows.  If the window is not transparent, there is a shadow being drawn around the window.

Comment 7 Owen Taylor 2015-10-20 18:57:51 UTC
(In reply to Berend De Schouwer from comment #6)
> F23 Beta:
> 
> The padding appears gone.

I'm puzzled by this - are you sure? There's been no changes to fix this, and I still see the problem here.

> Shadow isn't being drawn around the terminal windows.  It appears around
> other windows.  If the window is not transparent, there is a shadow being
> drawn around the window.

OK, when I put a patch in to fix the padding issue I see this - and I know why based on the GTK+ and gnome-terminal code - but puzzled why the padding is gone for you.

Comment 8 Owen Taylor 2015-10-20 20:56:36 UTC
Created attachment 1084925 [details]
Add patch fixing transparent mode under Wayland

Comment 9 Owen Taylor 2015-10-20 21:00:24 UTC
The patch above also needs the GTK+ patch in https://bugzilla.gnome.org/show_bug.cgi?id=756886 to get shadows and borders drawn correctly.

I notice some misbehavior when testing with the patch and HEAD GTK+

 - Drawing seem to be offset from clicks by a few pixels
 - Sometimes characters get dropped and not drawn when typing - leaving transparent holes underneath..

I don't see how these problems are related to the patch.

Comment 10 Olivier Fourdan 2015-10-21 07:51:55 UTC
attachment 1084925 [details] seems to be a patch for the spec file but the actual patch (gnome-terminal-wayland-transparency.patch) to apply to gnome-terminal doesn't seem to be attached though. Or am I missing something?

Comment 11 Berend De Schouwer 2015-10-21 09:21:34 UTC
(In reply to Owen Taylor from comment #7)
> (In reply to Berend De Schouwer from comment #6)
> > F23 Beta:
> > 
> > The padding appears gone.
> 
> I'm puzzled by this - are you sure? There's been no changes to fix this, and
> I still see the problem here.

There were multiple errors that may be getting confused.

One was an extra (+-  40px) black border.  This was likely due to a render bug, and may have been hardware specific.  This was a problem (for me) that disappeared in F23.  See the screenshot in comment #1.  This is black padding outside the window.

There is another problem where gnome-terminal doesn't (didn't?) doesn't quite resize correctly when maximized, specifically when maximizing sets the window to a non-integer multiple of a character.  This may appear and disappear according to screen size and font size.  If the screen is near enough an integer multiple, you won't notice it.  See the screenshot in comment #3.  This is a distinct bug.  This is transparent padding outside the window.

There's a problem with the shadow not being drawn when the terminal is transparent.  It's possible that the terminal window still reserves the extra pixels needed to draw the shadow.  (maybe also screenshot #3 ?)

There's used to be a problem that when the terminal is maximized with one tab, and another tab is opened, the terminal resizes beyond the screen, instead of reducing the number of lines.  Then you can't read the bottom (important) line in the terminal.  This could be interpreted as padding *inside* the window.

Comment 12 Owen Taylor 2015-10-21 14:07:58 UTC
(In reply to Olivier Fourdan from comment #10)
> attachment 1084925 [details] seems to be a patch for the spec file but the
> actual patch (gnome-terminal-wayland-transparency.patch) to apply to
> gnome-terminal doesn't seem to be attached though. Or am I missing something?

The patch some how breaks Bugzilla's patch viewer - if you download it, you'll see it's all there.

Comment 13 Olivier Fourdan 2015-10-21 14:38:49 UTC
(In reply to Owen Taylor from comment #12)
> The patch some how breaks Bugzilla's patch viewer - if you download it,
> you'll see it's all there.

Ahhh, yes, sorry! My bad.

Comment 14 Fedora Update System 2015-11-12 20:00:12 UTC
gnome-terminal-3.18.1-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-9251d09f70

Comment 15 Fedora Update System 2015-11-13 05:28:46 UTC
gnome-terminal-3.18.1-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gnome-terminal'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-9251d09f70

Comment 16 Fedora Update System 2015-11-13 21:42:31 UTC
swell-foop-3.18.1-1.fc23 pygobject3-3.18.2-1.fc23 orca-3.18.2-1.fc23 nautilus-3.18.2-1.fc23 mutter-3.18.2-1.fc23 libxml++-2.40.1-1.fc23 libsoup-2.52.2-1.fc23 libsigc++20-2.6.2-1.fc23 iagno-3.18.2-1.fc23 gvfs-1.26.2-1.fc23 gucharmap-3.18.2-1.fc23 gtk3-3.18.4-1.fc23 gsettings-desktop-schemas-3.18.1-1.fc23 gnome-tweak-tool-3.18.1-1.fc23 gnome-terminal-3.18.2-1.fc23 gnome-taquin-3.18.2-1.fc23 gnome-system-monitor-3.18.2-1.fc23 gnome-sound-recorder-3.18.2-1.fc23 gnome-shell-extensions-3.18.2-1.fc23 gnome-shell-3.18.2-1.fc23 gnome-settings-daemon-3.18.2-1.fc23 gnome-robots-3.18.1-1.fc23 gnome-photos-3.18.2-1.fc23 gnome-online-accounts-3.18.2.1-1.fc23 gnome-nibbles-3.18.2-1.fc23 gnome-mines-3.18.2-1.fc23 gnome-maps-3.18.2-1.fc23 gnome-klotski-3.18.2-1.fc23 gnome-keyring-3.18.3-1.fc23 gnome-getting-started-docs-3.18.2-1.fc23 gnome-documents-3.18.2-1.fc23 gnome-disk-utility-3.18.2-1.fc23 gnome-desktop3-3.18.2-1.fc23 gnome-calculator-3.18.2-1.fc23 gnome-bluetooth-3.18.1-1.fc23 gnome-2048-3.18.2-1.fc23 glib2-2.46.2-1.fc23 gedit-3.18.2-1.fc23 gdk-pixbuf2-2.32.2-1.fc23 evolution-mapi-3.18.2-1.fc23 evolution-ews-3.18.2-1.fc23 evolution-data-server-3.18.2-1.fc23 evolution-3.18.2-1.fc23 evince-3.18.2-1.fc23 eog-plugins-3.16.3-1.fc23 eog-3.18.1-1.fc23 dconf-editor-3.18.2-1.fc23 control-center-3.18.2-1.fc23 bijiben-3.18.2-1.fc23 at-spi2-core-2.18.3-1.fc23 anjuta-3.18.2-1.fc23 aisleriot-3.18.2-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-2e33c48936

Comment 17 Robert Smol 2015-11-14 20:37:17 UTC
I can confirm transparency is still the issue for me:

~ $ rpm -qi gnome-terminal
Name        : gnome-terminal
Version     : 3.18.1

Comment 18 Fedora Update System 2015-11-15 05:26:04 UTC
aisleriot-3.18.2-1.fc23, anjuta-3.18.2-1.fc23, at-spi2-core-2.18.3-1.fc23, bijiben-3.18.2-1.fc23, control-center-3.18.2-1.fc23, dconf-editor-3.18.2-1.fc23, eog-3.18.1-1.fc23, eog-plugins-3.16.3-1.fc23, evince-3.18.2-1.fc23, evolution-3.18.2-1.fc23, evolution-data-server-3.18.2-1.fc23, evolution-ews-3.18.2-1.fc23, evolution-mapi-3.18.2-1.fc23, gdk-pixbuf2-2.32.2-1.fc23, gedit-3.18.2-1.fc23, glib2-2.46.2-1.fc23, gnome-2048-3.18.2-1.fc23, gnome-bluetooth-3.18.1-1.fc23, gnome-calculator-3.18.2-1.fc23, gnome-desktop3-3.18.2-1.fc23, gnome-disk-utility-3.18.2-1.fc23, gnome-documents-3.18.2-1.fc23, gnome-getting-started-docs-3.18.2-1.fc23, gnome-keyring-3.18.3-1.fc23, gnome-klotski-3.18.2-1.fc23, gnome-maps-3.18.2-1.fc23, gnome-mines-3.18.2-1.fc23, gnome-nibbles-3.18.2-1.fc23, gnome-online-accounts-3.18.2.1-1.fc23, gnome-photos-3.18.2-1.fc23, gnome-robots-3.18.1-1.fc23, gnome-settings-daemon-3.18.2-1.fc23, gnome-shell-3.18.2-1.fc23, gnome-shell-extensions-3.18.2-1.fc23, gnome-sound-recorder-3.18.2-1.fc23, gnome-system-monitor-3.18.2-1.fc23, gnome-taquin-3.18.2-1.fc23, gnome-terminal-3.18.2-1.fc23, gnome-tweak-tool-3.18.1-1.fc23, gsettings-desktop-schemas-3.18.1-1.fc23, gtk3-3.18.4-1.fc23, gucharmap-3.18.2-1.fc23, gvfs-1.26.2-1.fc23, iagno-3.18.2-1.fc23, libsigc++20-2.6.2-1.fc23, libsoup-2.52.2-1.fc23, libxml++-2.40.1-1.fc23, mutter-3.18.2-1.fc23, nautilus-3.18.2-1.fc23, orca-3.18.2-1.fc23, pygobject3-3.18.2-1.fc23, swell-foop-3.18.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update aisleriot anjuta at-spi2-core bijiben control-center dconf-editor eog eog-plugins evince evolution evolution-data-server evolution-ews evolution-mapi gdk-pixbuf2 gedit glib2 gnome-2048 gnome-bluetooth gnome-calculator gnome-desktop3 gnome-disk-utility gnome-documents gnome-getting-started-docs gnome-keyring gnome-klotski gnome-maps gnome-mines gnome-nibbles gnome-online-accounts gnome-photos gnome-robots gnome-settings-daemon gnome-shell gnome-shell-extensions gnome-sound-recorder gnome-system-monitor gnome-taquin gnome-terminal gnome-tweak-tool gsettings-desktop-schemas gtk3 gucharmap gvfs iagno libsigc++20 libsoup libxml++ mutter nautilus orca pygobject3 swell-foop'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-2e33c48936

Comment 19 Fedora Update System 2015-11-17 20:34:18 UTC
aisleriot-3.18.2-1.fc23 anjuta-3.18.2-1.fc23 at-spi2-core-2.18.3-1.fc23 bijiben-3.18.2-1.fc23 control-center-3.18.2-1.fc23 dconf-editor-3.18.2-1.fc23 eog-3.18.1-1.fc23 eog-plugins-3.16.3-1.fc23 evince-3.18.2-1.fc23 evolution-3.18.2-1.fc23 evolution-data-server-3.18.2-1.fc23 evolution-ews-3.18.2-1.fc23 evolution-mapi-3.18.2-1.fc23 gdk-pixbuf2-2.32.2-1.fc23 gedit-3.18.2-1.fc23 glib2-2.46.2-1.fc23 gnome-2048-3.18.2-1.fc23 gnome-bluetooth-3.18.1-1.fc23 gnome-calculator-3.18.2-1.fc23 gnome-desktop3-3.18.2-1.fc23 gnome-disk-utility-3.18.2-1.fc23 gnome-documents-3.18.2-1.fc23 gnome-getting-started-docs-3.18.2-1.fc23 gnome-keyring-3.18.3-1.fc23 gnome-klotski-3.18.2-1.fc23 gnome-maps-3.18.2-1.fc23 gnome-mines-3.18.2-1.fc23 gnome-music-3.18.2-1.fc23 gnome-nibbles-3.18.2-1.fc23 gnome-online-accounts-3.18.2.1-1.fc23 gnome-photos-3.18.2-1.fc23 gnome-robots-3.18.1-1.fc23 gnome-settings-daemon-3.18.2-1.fc23 gnome-shell-3.18.2-2.fc23 gnome-shell-extensions-3.18.2-1.fc23 gnome-sound-recorder-3.18.2-1.fc23 gnome-system-monitor-3.18.2-1.fc23 gnome-taquin-3.18.2-1.fc23 gnome-terminal-3.18.2-1.fc23 gnome-tweak-tool-3.18.1-1.fc23 gsettings-desktop-schemas-3.18.1-1.fc23 gtk3-3.18.5-2.fc23 gucharmap-3.18.2-1.fc23 gvfs-1.26.2-1.fc23 iagno-3.18.2-1.fc23 libsigc++20-2.6.2-1.fc23 libsoup-2.52.2-1.fc23 libxml++-2.40.1-1.fc23 mutter-3.18.2-1.fc23 nautilus-3.18.2-1.fc23 orca-3.18.2-1.fc23 pygobject3-3.18.2-1.fc23 sound-juicer-3.18.1-1.fc23 swell-foop-3.18.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-2e33c48936

Comment 20 Fedora Update System 2015-11-19 15:27:57 UTC
aisleriot-3.18.2-1.fc23, anjuta-3.18.2-1.fc23, at-spi2-core-2.18.3-1.fc23, bijiben-3.18.2-1.fc23, control-center-3.18.2-1.fc23, dconf-editor-3.18.2-1.fc23, eog-3.18.1-1.fc23, eog-plugins-3.16.3-1.fc23, evince-3.18.2-1.fc23, evolution-3.18.2-1.fc23, evolution-data-server-3.18.2-1.fc23, evolution-ews-3.18.2-1.fc23, evolution-mapi-3.18.2-1.fc23, gdk-pixbuf2-2.32.2-1.fc23, gedit-3.18.2-1.fc23, glib2-2.46.2-1.fc23, gnome-2048-3.18.2-1.fc23, gnome-bluetooth-3.18.1-1.fc23, gnome-calculator-3.18.2-1.fc23, gnome-desktop3-3.18.2-1.fc23, gnome-disk-utility-3.18.2-1.fc23, gnome-documents-3.18.2-1.fc23, gnome-getting-started-docs-3.18.2-1.fc23, gnome-keyring-3.18.3-1.fc23, gnome-klotski-3.18.2-1.fc23, gnome-maps-3.18.2-1.fc23, gnome-mines-3.18.2-1.fc23, gnome-music-3.18.2-1.fc23, gnome-nibbles-3.18.2-1.fc23, gnome-online-accounts-3.18.2.1-1.fc23, gnome-photos-3.18.2-1.fc23, gnome-robots-3.18.1-1.fc23, gnome-settings-daemon-3.18.2-1.fc23, gnome-shell-3.18.3-1.fc23, gnome-shell-extensions-3.18.2-1.fc23, gnome-sound-recorder-3.18.2-1.fc23, gnome-system-monitor-3.18.2-1.fc23, gnome-taquin-3.18.2-1.fc23, gnome-terminal-3.18.2-1.fc23, gnome-tweak-tool-3.18.1-1.fc23, gsettings-desktop-schemas-3.18.1-1.fc23, gtk3-3.18.5-2.fc23, gucharmap-3.18.2-1.fc23, gvfs-1.26.2-1.fc23, iagno-3.18.2-1.fc23, libsigc++20-2.6.2-1.fc23, libsoup-2.52.2-1.fc23, libxml++-2.40.1-1.fc23, mutter-3.18.2-1.fc23, nautilus-3.18.2-2.fc23, orca-3.18.2-1.fc23, pygobject3-3.18.2-1.fc23, sound-juicer-3.18.1-1.fc23, swell-foop-3.18.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update aisleriot anjuta bijiben eog-plugins glib2 gnome-settings-daemon gnome-shell-extensions gnome-2048 gnome-sound-recorder gnome-system-monitor evince gnome-bluetooth gnome-taquin gnome-terminal gnome-calculator gnome-tweak-tool gsettings-desktop-schemas control-center evolution gnome-desktop3 gucharmap gvfs gnome-disk-utility iagno libsigc++20 evolution-data-server gnome-documents libsoup libxml++ gnome-getting-started-docs mutter orca at-spi2-core dconf-editor evolution-ews gnome-keyring pygobject3 swell-foop gnome-klotski nautilus gnome-shell evolution-mapi gnome-maps gtk3 gnome-music gnome-mines sound-juicer eog gdk-pixbuf2 gnome-nibbles gnome-online-accounts gedit gnome-photos gnome-robots'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-2e33c48936

Comment 21 Fedora Update System 2015-11-19 16:56:25 UTC
aisleriot-3.18.2-1.fc23, anjuta-3.18.2-1.fc23, at-spi2-core-2.18.3-1.fc23, bijiben-3.18.2-1.fc23, control-center-3.18.2-1.fc23, dconf-editor-3.18.2-1.fc23, eog-3.18.1-1.fc23, eog-plugins-3.16.3-1.fc23, evince-3.18.2-1.fc23, evolution-3.18.2-1.fc23, evolution-data-server-3.18.2-1.fc23, evolution-ews-3.18.2-1.fc23, evolution-mapi-3.18.2-1.fc23, gdk-pixbuf2-2.32.2-1.fc23, gedit-3.18.2-1.fc23, glib2-2.46.2-1.fc23, gnome-2048-3.18.2-1.fc23, gnome-bluetooth-3.18.1-1.fc23, gnome-calculator-3.18.2-1.fc23, gnome-desktop3-3.18.2-1.fc23, gnome-disk-utility-3.18.2-1.fc23, gnome-documents-3.18.2-1.fc23, gnome-getting-started-docs-3.18.2-1.fc23, gnome-keyring-3.18.3-1.fc23, gnome-klotski-3.18.2-1.fc23, gnome-maps-3.18.2-1.fc23, gnome-mines-3.18.2-1.fc23, gnome-music-3.18.2-1.fc23, gnome-nibbles-3.18.2-1.fc23, gnome-online-accounts-3.18.2.1-1.fc23, gnome-photos-3.18.2-1.fc23, gnome-robots-3.18.1-1.fc23, gnome-settings-daemon-3.18.2-1.fc23, gnome-shell-3.18.3-1.fc23, gnome-shell-extensions-3.18.2-1.fc23, gnome-sound-recorder-3.18.2-1.fc23, gnome-system-monitor-3.18.2-1.fc23, gnome-taquin-3.18.2-1.fc23, gnome-terminal-3.18.2-1.fc23, gnome-tweak-tool-3.18.1-1.fc23, gsettings-desktop-schemas-3.18.1-1.fc23, gtk3-3.18.5-2.fc23, gucharmap-3.18.2-1.fc23, gvfs-1.26.2-1.fc23, iagno-3.18.2-1.fc23, libsigc++20-2.6.2-1.fc23, libsoup-2.52.2-1.fc23, libxml++-2.40.1-1.fc23, mutter-3.18.2-1.fc23, nautilus-3.18.2-2.fc23, orca-3.18.2-1.fc23, pygobject3-3.18.2-1.fc23, sound-juicer-3.18.1-1.fc23, swell-foop-3.18.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update aisleriot anjuta bijiben eog-plugins glib2 gnome-settings-daemon gnome-shell-extensions gnome-2048 gnome-sound-recorder gnome-system-monitor evince gnome-bluetooth gnome-taquin gnome-terminal gnome-calculator gnome-tweak-tool gsettings-desktop-schemas control-center evolution gnome-desktop3 gucharmap gvfs gnome-disk-utility iagno libsigc++20 evolution-data-server gnome-documents libsoup libxml++ gnome-getting-started-docs mutter orca at-spi2-core dconf-editor evolution-ews gnome-keyring pygobject3 swell-foop gnome-klotski nautilus gnome-shell evolution-mapi gnome-maps gtk3 gnome-music gnome-mines sound-juicer eog gdk-pixbuf2 gnome-nibbles gnome-online-accounts gedit gnome-photos gnome-robots'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-2e33c48936

Comment 22 Fedora Update System 2015-11-20 18:37:26 UTC
aisleriot-3.18.2-1.fc23 anjuta-3.18.2-1.fc23 at-spi2-core-2.18.3-1.fc23 bijiben-3.18.2-1.fc23 control-center-3.18.2-1.fc23 dconf-editor-3.18.2-1.fc23 eog-3.18.1-1.fc23 eog-plugins-3.16.3-1.fc23 evince-3.18.2-1.fc23 evolution-3.18.2-1.fc23 evolution-data-server-3.18.2-1.fc23 evolution-ews-3.18.2-1.fc23 evolution-mapi-3.18.2-1.fc23 gdk-pixbuf2-2.32.2-1.fc23 gedit-3.18.2-1.fc23 glib2-2.46.2-1.fc23 gnome-2048-3.18.2-1.fc23 gnome-bluetooth-3.18.1-1.fc23 gnome-calculator-3.18.2-1.fc23 gnome-desktop3-3.18.2-1.fc23 gnome-disk-utility-3.18.2-1.fc23 gnome-documents-3.18.2-1.fc23 gnome-getting-started-docs-3.18.2-1.fc23 gnome-keyring-3.18.3-1.fc23 gnome-klotski-3.18.2-1.fc23 gnome-maps-3.18.2-1.fc23 gnome-mines-3.18.2-1.fc23 gnome-music-3.18.2-1.fc23 gnome-nibbles-3.18.2-1.fc23 gnome-online-accounts-3.18.2.1-1.fc23 gnome-photos-3.18.2-1.fc23 gnome-robots-3.18.1-1.fc23 gnome-settings-daemon-3.18.2-1.fc23 gnome-shell-3.18.3-1.fc23 gnome-shell-extensions-3.18.2-1.fc23 gnome-sound-recorder-3.18.2-1.fc23 gnome-system-monitor-3.18.2-1.fc23 gnome-taquin-3.18.2-1.fc23 gnome-terminal-3.18.2-1.fc23 gnome-tweak-tool-3.18.1-1.fc23 gsettings-desktop-schemas-3.18.1-1.fc23 gtk3-3.18.5-2.fc23 gucharmap-3.18.2-1.fc23 gvfs-1.26.2-1.fc23 iagno-3.18.2-1.fc23 libsigc++20-2.6.2-1.fc23 libsoup-2.52.2-1.fc23 libxml++-2.40.1-1.fc23 mutter-3.18.2-1.fc23 nautilus-3.18.2-2.fc23 orca-3.18.2-1.fc23 pygobject3-3.18.2-1.fc23 sound-juicer-3.18.1-1.fc23 swell-foop-3.18.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-2e33c48936

Comment 23 Fedora Update System 2015-11-22 14:26:47 UTC
aisleriot-3.18.2-1.fc23, anjuta-3.18.2-1.fc23, at-spi2-core-2.18.3-1.fc23, bijiben-3.18.2-1.fc23, control-center-3.18.2-1.fc23, dconf-editor-3.18.2-1.fc23, eog-3.18.1-1.fc23, eog-plugins-3.16.3-1.fc23, epiphany-3.18.1-1.fc23, evolution-3.18.2-1.fc23, evolution-data-server-3.18.2-1.fc23, evolution-ews-3.18.2-1.fc23, evolution-mapi-3.18.2-1.fc23, gdk-pixbuf2-2.32.2-1.fc23, gedit-3.18.2-1.fc23, glib2-2.46.2-1.fc23, glibmm24-2.46.2-1.fc23, gnome-2048-3.18.2-1.fc23, gnome-bluetooth-3.18.1-1.fc23, gnome-calculator-3.18.2-1.fc23, gnome-desktop3-3.18.2-1.fc23, gnome-disk-utility-3.18.2-1.fc23, gnome-documents-3.18.2-1.fc23, gnome-getting-started-docs-3.18.2-1.fc23, gnome-keyring-3.18.3-1.fc23, gnome-klotski-3.18.2-1.fc23, gnome-maps-3.18.2-1.fc23, gnome-mines-3.18.2-1.fc23, gnome-music-3.18.2-1.fc23, gnome-nibbles-3.18.2-1.fc23, gnome-online-accounts-3.18.2.1-1.fc23, gnome-photos-3.18.2-1.fc23, gnome-robots-3.18.1-1.fc23, gnome-settings-daemon-3.18.2-1.fc23, gnome-shell-3.18.3-1.fc23, gnome-shell-extensions-3.18.2-1.fc23, gnome-sound-recorder-3.18.2-1.fc23, gnome-system-monitor-3.18.2-1.fc23, gnome-taquin-3.18.2-1.fc23, gnome-terminal-3.18.2-1.fc23, gnome-tweak-tool-3.18.1-1.fc23, gsettings-desktop-schemas-3.18.1-1.fc23, gtk3-3.18.5-2.fc23, gucharmap-3.18.2-1.fc23, gvfs-1.26.2-1.fc23, iagno-3.18.2-1.fc23, libsigc++20-2.6.2-1.fc23, libsoup-2.52.2-1.fc23, libxml++-2.40.1-1.fc23, mutter-3.18.2-1.fc23, nautilus-3.18.2-2.fc23, orca-3.18.2-1.fc23, pygobject3-3.18.2-1.fc23, sound-juicer-3.18.1-1.fc23, swell-foop-3.18.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update aisleriot anjuta bijiben eog-plugins gnome-2048 gnome-shell-extensions gnome-sound-recorder gnome-bluetooth gnome-system-monitor gnome-taquin evolution gnome-calculator gnome-terminal gnome-tweak-tool gnome-desktop3 gsettings-desktop-schemas gucharmap control-center evolution-data-server gnome-disk-utility gvfs iagno gnome-documents libsigc++20 libsoup evolution-ews gnome-getting-started-docs libxml++ mutter gnome-keyring orca pygobject3 at-spi2-core dconf-editor evolution-mapi gnome-klotski swell-foop epiphany gnome-maps glibmm24 nautilus gdk-pixbuf2 gnome-mines gnome-shell gtk3 gnome-nibbles gnome-music sound-juicer eog gedit gnome-online-accounts gnome-photos glib2 gnome-robots gnome-settings-daemon'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-2e33c48936

Comment 24 Rob Tomsick 2015-11-22 18:31:03 UTC
*** Bug 1271455 has been marked as a duplicate of this bug. ***

Comment 25 Richard Chan 2015-11-23 12:55:50 UTC
koji gnome-terminal-3.18.2-1.fc23.x86_64 has fixed this bug for me


#rpm -q gnome-terminal
gnome-terminal-3.18.2-1.fc23.x86_64

Comment 26 Fedora Update System 2015-11-23 20:56:15 UTC
aisleriot-3.18.2-1.fc23, anjuta-3.18.2-1.fc23, at-spi2-core-2.18.3-1.fc23, bijiben-3.18.2-1.fc23, control-center-3.18.2-1.fc23, dconf-editor-3.18.2-1.fc23, eog-3.18.1-1.fc23, eog-plugins-3.16.3-1.fc23, epiphany-3.18.1-1.fc23, evolution-3.18.2-1.fc23, evolution-data-server-3.18.2-1.fc23, evolution-ews-3.18.2-1.fc23, evolution-mapi-3.18.2-1.fc23, gdk-pixbuf2-2.32.2-1.fc23, gedit-3.18.2-1.fc23, glib2-2.46.2-1.fc23, glibmm24-2.46.2-1.fc23, gnome-2048-3.18.2-1.fc23, gnome-bluetooth-3.18.1-1.fc23, gnome-calculator-3.18.2-1.fc23, gnome-desktop3-3.18.2-1.fc23, gnome-disk-utility-3.18.2-1.fc23, gnome-documents-3.18.2-1.fc23, gnome-getting-started-docs-3.18.2-1.fc23, gnome-keyring-3.18.3-1.fc23, gnome-klotski-3.18.2-1.fc23, gnome-maps-3.18.2-1.fc23, gnome-mines-3.18.2-1.fc23, gnome-music-3.18.2-1.fc23, gnome-nibbles-3.18.2-1.fc23, gnome-online-accounts-3.18.2.1-1.fc23, gnome-photos-3.18.2-1.fc23, gnome-robots-3.18.1-1.fc23, gnome-settings-daemon-3.18.2-1.fc23, gnome-shell-3.18.3-1.fc23, gnome-shell-extensions-3.18.2-1.fc23, gnome-sound-recorder-3.18.2-1.fc23, gnome-system-monitor-3.18.2-1.fc23, gnome-taquin-3.18.2-1.fc23, gnome-terminal-3.18.2-1.fc23, gnome-tweak-tool-3.18.1-1.fc23, gsettings-desktop-schemas-3.18.1-1.fc23, gtk3-3.18.5-2.fc23, gucharmap-3.18.2-1.fc23, gvfs-1.26.2-1.fc23, iagno-3.18.2-1.fc23, libsigc++20-2.6.2-1.fc23, libsoup-2.52.2-1.fc23, libxml++-2.40.1-1.fc23, mutter-3.18.2-1.fc23, nautilus-3.18.2-2.fc23, orca-3.18.2-1.fc23, pygobject3-3.18.2-1.fc23, sound-juicer-3.18.1-1.fc23, swell-foop-3.18.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 27 Debarshi Ray 2016-12-22 14:48:50 UTC
*** Bug 1272712 has been marked as a duplicate of this bug. ***

Comment 28 Debarshi Ray 2017-04-18 09:55:39 UTC
*** Bug 1266984 has been marked as a duplicate of this bug. ***

Comment 29 Debarshi Ray 2017-04-18 09:57:23 UTC
*** Bug 1281970 has been marked as a duplicate of this bug. ***

Comment 30 Debarshi Ray 2017-04-18 09:58:22 UTC
*** Bug 1280527 has been marked as a duplicate of this bug. ***