Bug 1208041

Summary: TUI hosted-engine-setup process is unexpected terminated when boot rhevm-appliance.ova because of ENOSPC in the tempdir
Product: Red Hat Enterprise Virtualization Manager Reporter: Ying Cui <ycui>
Component: ovirt-node-plugin-hosted-engineAssignee: Douglas Schilling Landgraf <dougsland>
Status: CLOSED ERRATA QA Contact: Ying Cui <ycui>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 3.5.1CC: cshao, dougsland, fdeutsch, gklein, huiwa, leiwang, nsednev, yaniwang
Target Milestone: ovirt-3.6.0-rcKeywords: ZStream
Target Release: 3.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ovirt-node-plugin-hosted-engine-0.3.0-1.el7ev Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1235343 (view as bug list) Environment:
Last Closed: 2016-03-09 14:21:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Node RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1267437    
Bug Blocks: 1193058, 1235343    
Attachments:
Description Flags
answerfile
none
varlog.tar.gz none

Comment 1 Ying Cui 2015-04-01 09:15:57 UTC
Created attachment 1009551 [details]
answerfile

Comment 2 Ying Cui 2015-04-01 09:16:29 UTC
Created attachment 1009552 [details]
varlog.tar.gz

Comment 3 Ying Cui 2015-04-01 09:19:32 UTC
After unexpected terminated, then back to rhevh TUI, I checked this as well.
# screen -r -d
There is no screen to be detached.

Comment 5 Fabian Deutsch 2015-04-01 13:23:13 UTC
We should set TEMPDIR to /data/<something> which provides enough space for the image

Comment 6 Ying Cui 2015-04-10 05:51:29 UTC
(In reply to Fabian Deutsch from comment #5)
> We should set TEMPDIR to /data/<something> which provides enough space for
> the image

for this fix solution, here is precondition when rhevh install, there need to set data partition enough space.

Comment 7 Fabian Deutsch 2015-05-07 14:29:44 UTC
(In reply to Ying Cui from comment #6)
> (In reply to Fabian Deutsch from comment #5)
> > We should set TEMPDIR to /data/<something> which provides enough space for
> > the image
> 
> for this fix solution, here is precondition when rhevh install, there need
> to set data partition enough space.

I'd think along the lines that
1. The default installer suggestion is equal to what we suggest in the docs: 256MB min data size
2. In the docs we note that the data size should be at least 50GB in case that HE wants to be used

What I wonder is: Why does our he-setup not stop when it notices that the test about the min space requirement fails. Because it should complain about the not enough space, like it does on RHEL.

Comment 8 Ying Cui 2015-05-07 15:35:48 UTC
> What I wonder is: Why does our he-setup not stop when it notices that the
> test about the min space requirement fails. Because it should complain about
> the not enough space, like it does on RHEL.

+1 I wonder that as well. 
BTW, in bug description, if _manual_ run he-setup shell in RHEV-H, the behavior is the same as RHEL, here will prompt to let user set specify path to a directory due to not enough space. This issue only happen on TUI running he-setup process, so I set expected results in bug description to avoid termination back to TUI directly. 
In rhevh we only can think /data for vm.boot_disk dir´╝îeither the user specify the dir during he-setup or rhevh specify /data/hosted_engine_temp automatically. 

So we also need to fix when /data is not enough space how to avoid TUI hosted-engine-setup process is unexpected terminated? Or we only suggest /data at least 50GB in document? Thanks.

Comment 12 Ying Cui 2015-11-06 06:23:57 UTC
This bug is fixed and verified on build rhev-hypervisor7-7.2-20151104.0.iso(ovirt-node-plugin-hosted-engine-0.3.0-2.el7ev.noarch)

Test steps:
1. Installed rhevh 7.2 for 3.6 build successful. 
2. Setup rhevh network via TUI.
3. Navigate to hosted engine TUI.
5. Click on "Setup Hosted Engine"
6. Set engine ISO/OVA URL for download
7. Setup in process one by one steps.
8. During hosted-engine setup on VM configuration, there is no unexpected termination happen.

Comment 14 errata-xmlrpc 2016-03-09 14:21:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html