Bug 1208769

Summary: dnf debuginfo-install does not accept NVRA
Product: [Fedora] Fedora Reporter: Jan Kratochvil <jan.kratochvil>
Component: dnf-plugins-coreAssignee: Packaging Maintenance Team <packaging-team-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: jan.kratochvil, jsilhan, mluscon, packaging-team-maint, pnemade, rholy, tla
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-04-11 10:52:21 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 432806    
Bug Blocks: 1208650    

Description Jan Kratochvil 2015-04-03 06:46:13 UTC
Description of problem:
debuginfo-install from yum-utils handled NVRA but dnf debuginfo-install handles only N.

Version-Release number of selected component (if applicable):
dnf-plugins-core-0.1.5-1.fc22.noarch

How reproducible:
Always.

Steps to Reproduce:
dnf debuginfo-install gdb-7.9-10.fc22.x86_64

Actual results:
Dependencies resolved.
Nothing to do.
Complete!

Expected results:
Installed debuginfo.

Additional info:
One could pass just N but then as the debuginfo repositories are usually out of sync (Bug 432806) one has to wait for hours to get the debuginfos downloaded to find out then they have been installed for a different version than the installed binaries.  NVRA prevents that.

Comment 1 Parag Nemade 2015-04-03 07:20:10 UTC
The requested bug is already fixed in rawhide in 0.1.6 upstream release which is not yet backported in F22.

Comment 2 Jan Kratochvil 2015-04-11 10:52:21 UTC

*** This bug has been marked as a duplicate of bug 1171046 ***