Bug 1208650 - gdb suggests using yum for debuginfo-install rather than dnf
Summary: gdb suggests using yum for debuginfo-install rather than dnf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Kratochvil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1171046 1208769 1208773
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-02 19:04 UTC by Omair Majid
Modified: 2015-04-21 18:33 UTC (History)
6 users (show)

Fixed In Version: gdb-7.9-11.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-21 18:33:25 UTC


Attachments (Terms of Use)

Description Omair Majid 2015-04-02 19:04:24 UTC
Description of problem:
When debuginfo is missing, gdb suggests using debuginfo-install. This command uses yum, not dnf:

# debuginfo-install gdb-7.9-10.fc22.x86_64
Yum-utils package has been deprecated, use dnf instead.

dnf is the default way to install/update programs in Fedora 22: https://fedoraproject.org/wiki/Changes/ReplaceYumWithDNF


Version-Release number of selected component (if applicable):
gdb-7.9-10.fc22.x86_64


How reproducible:
All the time


Steps to Reproduce:
1. gdb gdb


Actual results:
Missing separate debuginfos, use: debuginfo-install gdb-7.9-10.fc22.x86_64


Expected results:
Missing separate debuginfos, use: <some new dnf command>


Additional info:
dnf provides a debuginfo-install command which seems to be mostly compatible with the debuginfo-install command:
# dnf debuginfo-install gdb

Comment 1 Jan Kratochvil 2015-04-02 19:09:02 UTC
OK, 'dnf debuginfo-install' is in 'dnf-plugins-core'.

Comment 2 Fedora Update System 2015-04-02 20:10:28 UTC
gdb-7.9-11.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gdb-7.9-11.fc22

Comment 3 Omair Majid 2015-04-02 20:56:54 UTC
Thanks for the quick fix!

I am pretty sure it's dnf's fault, but there seems to be a catch in the debuginfo-install command with dnf:

# debuginfo-install gdb-7.9-10.fc22.x86_64

Yum-utils package has been deprecated, use dnf instead.
See 'man yum2dnf' for more information.
[ ... snip ... ]
---> Package gdb-debuginfo.x86_64 0:7.9-10.fc22 will be installed
[ ... snip ... ]

But dnf says:

# dnf debuginfo-install gdb-7.9-10.fc22.x86_64
Dependencies resolved.
Nothing to do.
Complete!

If I remove the rpm version, things work:

# dnf debuginfo-install gdb
[ ... snip ... ]
 gdb-debuginfo                                  x86_64               7.9-10.fc22
[ ... snip ... ]

As it is, adding the rpm versions to the command to run ("dnf debuginfo-install gdb-7.9-10.fc22.x86_64") will probably make dnf do nothing.

Comment 4 Fedora Update System 2015-04-21 18:33:25 UTC
gdb-7.9-11.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.