Bug 1171046 - dnf debuginfo-install can't install packages when given exact NVR
dnf debuginfo-install can't install packages when given exact NVR
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
:
: 1208769 (view as bug list)
Depends On:
Blocks: 1208650
  Show dependency treegraph
 
Reported: 2014-12-05 04:55 EST by Lubomir Rintel
Modified: 2015-04-21 15:26 EDT (History)
10 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.6-3.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-21 15:26:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Rintel 2014-12-05 04:55:18 EST
Description of problem:

yum works well:

[lkundrak@fedora21-1 NetworkManager]$ su
[root@fedora21-1 NetworkManager]# dnf debuginfo-install dbus-glib-0.100.2-4.fc21.x86_64 dbus-libs-1.8.6-3.fc21.x86_64 freetype-2.5.3-11.fc21.x86_64 glib2-2.42.1-1.fc21.x86_64 gvfs-1.22.2-1.fc21.x86_64 libbluray-0.6.2-1.fc21.x86_64 libgcc-4.9.2-1.fc21.x86_64 libgudev1-216-11.fc21.x86_64 libndp-1.4-2.fc21.x86_64 libnl3-3.2.25-3.fc21.x86_64 libpng-1.6.10-3.fc21.x86_64 libselinux-2.3-5.fc21.x86_64 libsoup-2.48.0-1.fc21.x86_64 libuuid-2.25.2-1.fc21.x86_64 libxml2-2.9.1-6.fc21.x86_64 nss-3.17.2-1.fc21.x86_64 nss-util-3.17.2-1.fc21.x86_64 pcre-8.35-7.fc21.x86_64 sqlite-3.8.7-1.fc21.x86_64 systemd-libs-216-11.fc21.x86_64
Fedora 21 - x86_64 - Debug                                                                                                                                                         556 kB/s |  10 MB     00:19
Dependencies resolved.
Nothing to do.
[root@fedora21-1 NetworkManager]# debuginfo-install dbus-glib-0.100.2-4.fc21.x86_64 dbus-libs-1.8.6-3.fc21.x86_64 freetype-2.5.3-11.fc21.x86_64 glib2-2.42.1-1.fc21.x86_64 gvfs-1.22.2-1.fc21.x86_64 libbluray-0.6.2-1.fc21.x86_64 libgcc-4.9.2-1.fc21.x86_64 libgudev1-216-11.fc21.x86_64 libndp-1.4-2.fc21.x86_64 libnl3-3.2.25-3.fc21.x86_64 libpng-1.6.10-3.fc21.x86_64 libselinux-2.3-5.fc21.x86_64 libsoup-2.48.0-1.fc21.x86_64 libuuid-2.25.2-1.fc21.x86_64 libxml2-2.9.1-6.fc21.x86_64 nss-3.17.2-1.fc21.x86_64 nss-util-3.17.2-1.fc21.x86_64 pcre-8.35-7.fc21.x86_64 sqlite-3.8.7-1.fc21.x86_64 systemd-libs-216-11.fc21.x86_64
Loaded plugins: auto-update-debuginfo, langpacks
enabling fedora-debuginfo
enabling updates-debuginfo
lkundrak-NetworkManager-integration                                                                                                                                                         | 3.0 kB  00:00:00
updates/21/x86_64/metalink                                                                                                                                                                  |  18 kB  00:00:00
updates-debuginfo/21/x86_64/metalink                                                                                                                                                        |  16 kB  00:00:00
lkundrak-NetworkManager-integration/21/x86_64/primary_db                                                                                                                                    | 109 kB  00:00:01
Package bzip2-debuginfo-1.0.6-14.fc21.x86_64 already installed and latest version
Package zlib-debuginfo-1.2.8-7.fc21.x86_64 already installed and latest version
Package libffi-debuginfo-3.1-6.fc21.x86_64 already installed and latest version
Package elfutils-debuginfo-0.160-1.fc21.x86_64 already installed and latest version
Could not find debuginfo for main pkg: libnl3-3.2.25-3.fc21.x86_64
Package xz-debuginfo-5.1.2-14alpha.fc21.x86_64 already installed and latest version
Package nspr-debuginfo-4.10.7-1.fc21.x86_64 already installed and latest version
Package ncurses-debuginfo-5.9-16.20140323.fc21.x86_64 already installed and latest version
...


Version-Release number of selected component (if applicable):

dnf-plugins-core-0.1.3-1.fc21.noarch
dnf-0.6.2-1.fc21.noarch
Comment 1 Petr Spacek 2014-12-06 12:41:54 EST
Fix is available on:
https://github.com/rpm-software-management/dnf-plugins-core/pull/46
Comment 2 Igor Gnatenko 2014-12-06 12:44:03 EST
(In reply to Petr Spacek from comment #1)
> Fix is available on:
> https://github.com/rpm-software-management/dnf-plugins-core/pull/46

Thanks for pull request. I'm reviewing it.
Comment 3 Fedora Update System 2015-04-09 10:41:09 EDT
dnf-plugins-core-0.1.6-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.6-3.fc22
Comment 4 Fedora Update System 2015-04-10 14:21:38 EDT
Package dnf-plugins-core-0.1.6-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.6-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5951/dnf-plugins-core-0.1.6-3.fc22
then log in and leave karma (feedback).
Comment 5 Jan Kratochvil 2015-04-11 06:52:21 EDT
*** Bug 1208769 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2015-04-21 15:26:14 EDT
dnf-plugins-core-0.1.6-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.