This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes

Bug 122274

Summary: anaconda should enable mouse button emulation on apple laptops
Product: [Fedora] Fedora Reporter: Jesse Keating <jkeating>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 10CC: barryn, bnocera, byte, dkl, harald, mike, redhat, triage
Target Milestone: ---   
Target Release: ---   
Hardware: powerpc   
OS: Linux   
Whiteboard: bzcl34nup
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-04-25 21:26:28 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 459018    
Bug Blocks: 121179, 235705    
Attachments:
Description Flags
udev rule to run enable-mouse-emulation for ADB mice
none
Script to enable mouse button emulation none

Description Jesse Keating 2004-05-02 12:30:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.6) Gecko/20040422

Description of problem:
mouse emulation is possible for apple laptops.  To make F10 be middle
click, and F11 be right click (sane defaults for g3 ibooks) this needs
to be added to /etc/sysctl.conf:

dev.mac_hid.mouse_button_emulation = 1
dev.mac_hid.mouse_button2_keycode = 68
dev.mac_hid.mouse_button3_keycode = 87

I'm really not sure how anaconda will sort out what laptop is what,
but I'm sure Jeremy can work some magic... (:  

Maybe if this isn't automatic, but a firstboot issue where the user
can be prompted to press the keys they want to use for each event...
Comment 1 Jeremy Katz 2004-05-03 14:22:59 EDT
anaconda is not in the business of changing random sysctls for random
hardware.
Comment 2 Bill Nottingham 2004-05-03 14:53:09 EDT
Yuk. Set the default in the kernel!
Comment 3 David Woodhouse 2004-05-03 17:07:31 EDT
I wonder if acme could usefully do this?
Comment 4 Jesse Keating 2004-05-03 17:13:31 EDT
I'm not familiar enough w/ acme.  Something to consider, we don't want
people logging in remotely to start a Gnome session and have their
mouse settings override the person who's at the local console (how
often does this happen w/ laptops, who knows...).

I'm cool with seeing F11 be right click, F10 be middle click.  Thats
how I use my ibook.  Any objections to this as the "sane default" ?
Comment 5 Hotmail Account 2004-05-19 11:58:30 EDT
Wrt comment #4, no objections since I have become rather used to it by
now.
Comment 6 Bill Nottingham 2004-06-07 15:48:16 EDT
*** Bug 108095 has been marked as a duplicate of this bug. ***
Comment 7 Bastien Nocera 2004-06-09 07:40:19 EDT
That would be something easy enough to add as an enhancement to the
Mouse config tool, in graphical, bypassing X to use the input layer
directly.
Comment 8 Colin Charles 2004-09-12 07:08:59 EDT
Wrt comment #4, I actually use FN+Ctrl or Fn+Alt rather than F11/F12,
so my sane default differs :)

So, are we finding a nice workaround for this in time for FC3?
Comment 9 Barry K. Nathan 2004-09-13 00:25:26 EDT
AFAIK the "Fn" key only exists on PowerBooks, not on desktop Macs
(neither my iMac at home nor the G4 I used to have at work have the
"Fn" key on their keyboards).

I think F10/F11 is what Yellow Dog tends toward (either in its
defaults or its documentation, I forget which). If anaconda defaults
to something else, I think it's going to cause confusion, unless it's
very well documented.
Comment 10 Wade Mealing 2004-10-22 22:29:48 EDT
Out of interest, what would you right click or middle click on anaconda ?

Comment 11 Colin Charles 2004-10-22 23:12:49 EDT
Wade, you don't right or middle-click ina anconda - the issue is
setting up the "correct" sysctls, and Jesse thought anaconda. Jeremy
is weary about the idea, and notting says we can opt for it in the
kernel. dwmw2 considers acme foo - what are we going to do about it
though?

Barry in comment #9, yes, F10/F11 is whats used, and you're right
about not having the Fn key on non-laptops (didn't even realise till I
got a non-laptop Mac :) ).
Comment 12 Bastien Nocera 2004-10-25 09:37:36 EDT
It would be possible to do that pretty easily in X, especially in the
multimedia-keys part of the control-center:
- add middle mouse button, and right mouse button shortcuts (entries
in the table, actions, and GConf entries)
- add actions for those buttons, generate the right or middle click
and releases with XTestFakeButtonEvent()
Comment 13 Jesse Keating 2004-10-25 12:13:18 EDT
Sure, it could be done in X, however an emulation like this is more
system level as right clicks could be used in console.  Since there is
a kernel sys entry to manage the emulation of these buttons, I had
thought that perhaps exposing this setting at a system level was more
appropriate, such as in anaconda when asking to emulate a two button
mouse as 3 buttons.
Comment 14 W. Michael Petullo 2005-07-18 13:41:06 EDT
Will this get some attention now that Fedora Core officially supports the
PowerPC architecture?  Apple laptops are pretty handicapped without this
feature.  Could someone reassign this bug to FC5 or devel?
Comment 15 Bill Nottingham 2005-09-30 16:51:15 EDT
Moving to FC5 target.

However, I think there needs to be a better way than one-off arch hacks in the
installer. Perhaps a udev rule that operates on the mac IO mouse device that
calls sysctl to set these parameters?
Comment 16 W. Michael Petullo 2006-08-27 18:05:40 EDT
Move to FC7 target.
Comment 17 W. Michael Petullo 2007-12-16 09:33:27 EST
Created attachment 289722 [details]
udev rule to run enable-mouse-emulation for ADB mice
Comment 18 W. Michael Petullo 2007-12-16 09:35:35 EST
Created attachment 289723 [details]
Script to enable mouse button emulation
Comment 19 Bill Nottingham 2007-12-17 13:25:29 EST
Out of curiousity, why does it need to be configurable key-wise?
Comment 20 Jesse Keating 2007-12-17 13:34:35 EST
sadly because apple keeps moving what keys are used for eject and such, and some
laptops have higher FXX number keys.  But 'configuration' sucks.
Comment 21 W. Michael Petullo 2007-12-18 00:12:12 EST
I decided to use default values with the option of reconfiguration. On my
laptop, there is a little "enter" key near the trackpad which I use for right
clicks. Middle click is F11. But, as Jesse states, I think different Apple
laptops may have different key layouts.
Comment 22 Bug Zapper 2008-04-03 11:33:45 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 23 W. Michael Petullo 2008-08-13 14:10:55 EDT
Is anyone using the PowerPC port anymore? Is anyone using Fedora on Apple laptops? This bug was reported, with a solution in 2004. Since then, the solution has been changed to address concerns voiced in the comments above. Until this is fixed, GNOME is difficult to use on Apple laptops without plugging in an external, multi-button mouse.
Comment 24 Bill Nottingham 2008-12-01 16:49:07 EST
Oof, apologies. This really should have been reassigned a while ago.

Assigning to udev for rule integration - the script itself obviously shouldn't be writing to /tmp, but that looks like debugging code anyway.b
Comment 25 Harald Hoyer 2008-12-02 05:12:05 EST
Hmm, why not make a separate package, which provides the tool, the rules and the config file. Certainly not every architecture needs this.
Comment 26 W. Michael Petullo 2009-04-25 21:26:28 EDT
Use xorg-x11-drv-synaptic.