Bug 108095 - Initscripts has no support for mouse-emulation
Initscripts has no support for mouse-emulation
Status: CLOSED DUPLICATE of bug 122274
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-27 12:11 EST by W. Michael Petullo
Modified: 2014-03-16 22:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Adds mouse-emulation support to initscripts (5.19 KB, patch)
2003-10-27 12:13 EST, W. Michael Petullo
no flags Details | Diff

  None (edit)
Description W. Michael Petullo 2003-10-27 12:11:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux ppc; U;) Gecko/20030130

Description of problem:
YellowDog Linux will configure the Linux kernel's mouse button emulation feature
when a system boots.  This is useful on many Macintosh computers whose mice have
only one button.  With YellowDog, one can configure various keyboard keys to act
as mouse clicks using /etc/sysconfig/mouse-emulation.

This is a very desirable feature as Red Hat begins support for Fedora because
there is a lot of discussion of porting Red Hat's Fedora project to the Macintosh.

Attached to this report you should find a patch that adds this feature to
initscripts-7.41.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Note that the system does not configure mouse button emulation.
    

Additional info:
Comment 1 W. Michael Petullo 2003-10-27 12:13:55 EST
Created attachment 95519 [details]
Adds mouse-emulation support to initscripts

This patch adds mouse-emulation support to initscripts.
Comment 2 Bill Nottingham 2003-10-27 15:04:20 EST
If we're enabling it by default on pmac, why not just put it in /etc/sysctl.conf?
Comment 3 W. Michael Petullo 2003-10-27 22:46:24 EST
Well, we could just put it in /etc/sysctl.conf too.  For some reason Yellow Dog
does it with an init script.  There already exists platform-specific sysctl.conf
files for sparc and s390, so adding a ppc version would fit right in.  I'll ask
the YellowDog folks for any comments on their design choices.  No sence in
exploring roads already taken.
Comment 4 W. Michael Petullo 2003-10-28 14:20:55 EST
Dan Burcaw from Terra Soft says:

    Being able to modify the mouse emulation 'keys' without 
    tweaking sysctl.conf.  It is much easier for users to edit 
    a 'sysconfig' file or have a GUI write a 'sysconfig' file 
    than grok sysctl, IMO.

I suppose I agree with that.  Depending on the model of keyboard and user
preferences, the Enter key, F12, F11, etc. may be used.  So keeping this easily
configurable by the user would be a good thing.

Dan also said that the Terra Soft folks have not yet tried to push any of this
upstream yet.
Comment 5 Bill Nottingham 2004-06-07 15:48:04 EDT

*** This bug has been marked as a duplicate of 122274 ***
Comment 6 Red Hat Bugzilla 2006-02-21 13:59:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.