Bug 1241983

Summary: Multiple "Listen on candlepin events" tasks
Product: Red Hat Satellite 6 Reporter: Mike McCune <mmccune>
Component: InfrastructureAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED DUPLICATE QA Contact: Katello QA List <katello-qa-list>
Severity: high Docs Contact: David O'Brien <daobrien>
Priority: unspecified    
Version: 6.1.0CC: bbuckingham, cwelton, jan.gerrit, mullens, peter.vreman, pmoravec
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-08-11 18:15:08 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1122832, 1190823    
Attachments:
Description Flags
screenshot none

Description Mike McCune 2015-07-10 14:48:11 UTC
During a debugging session I turned of foreman-tasks and left the remainder of Satellite running.

This resulted in 20+ "Listen on candlepin" events queued up in "paused:pending" state.

See attached screenshot.

The hammer bulk task resume routine won't work in this situation as it only resumes "paused:error" tasks.

Bulk resume may not be the right thing here either as you really only want one of these tasks at one time.

Need to determine why we kept getting more tasks created and how to remediate this situation.

Comment 1 Mike McCune 2015-07-10 14:49:42 UTC
Created attachment 1050712 [details]
screenshot

Comment 3 Peter Vreman 2015-07-11 14:01:12 UTC
I also see multiple "Listen on candlepin" tasks. These were created in the task list when i did a couple of graceful reboots using the standard 'reboot' command

Comment 4 Pavel Moravec 2015-07-16 09:47:49 UTC
Not related to http://projects.theforeman.org/issues/9068 ?

Comment 5 Sean Mullen 2015-08-07 16:43:32 UTC
I'm having this same issue, I have a boatload (Currently 78) of 'Listen on candlepin events {"locale" => "en"}' in either "Running:Error", "Running:Pending" or "Paused:Pending".  DynaFlow console give no options to skip / cancel, anything.

From the foreman bug in Pavel's comment:
"Katello 2.2 we have fully resolved this issue by upgrading qpid to 0.30. This requires an upgrade to Katello 2.2"

Satellite 6.1 has katello 2.2.0 and qpidd 0.30 so either the issue mentioned in that link is not fixed or this is a separate issue.


This is on RHEL7.1.  How the hell can I get rid of these?

Comment 6 Brad Buckingham 2015-08-11 18:15:08 UTC
It appears that this issue was addressed by another bugzilla as part of 6.1.1; therefore, I am going to close this one as a duplicate of bug 1243959.

*** This bug has been marked as a duplicate of bug 1243959 ***

Comment 7 Justin Sherrill 2015-08-11 18:19:47 UTC
Sean,

The following can be used to clear those out:  https://gist.github.com/jlsherrill/78884fb933e06e26b8e6

however they really should not cause any harm.  

You will continue to see new ones pop up anytime you reboot the box or run 'katello-service restart'.  This is resolved in 6.1.1

Comment 8 Jan Gerrit Kootstra 2019-03-06 16:10:34 UTC
The issue seems to get back in RH Satellite 6.4.2.
Each day I have to cleanup suspended Candlepin tasks.