Bug 1243959 - Duplicate Actions::Candlepin::ListenOnCandlepinEvents tasks
Summary: Duplicate Actions::Candlepin::ListenOnCandlepinEvents tasks
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Jitendra Yejare
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1241983 (view as bug list)
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-07-16 17:03 UTC by Mike McCune
Modified: 2017-09-19 17:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 16:04:17 UTC


Attachments (Terms of Use)
screenshot (113.97 KB, image/png)
2015-07-16 17:03 UTC, Mike McCune
no flags Details
Verified Screenshot (143.28 KB, image/png)
2015-07-23 09:51 UTC, Jitendra Yejare
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 11166 None None None 2016-04-22 15:05:01 UTC

Description Mike McCune 2015-07-16 17:03:13 UTC
In certain situations the user can end up with large lists of this task running or stuck in paused:pending state and can't be mass resumed.

See attached screenshot.

We need to ensure there is only one of these tasks running at a time and we don't spam the tasks list with multiple tasks that can't be mass resumed.

Comment 1 Mike McCune 2015-07-16 17:03:48 UTC
Created attachment 1052753 [details]
screenshot

Comment 3 Justin Sherrill 2015-07-16 17:36:00 UTC
Reproducer steps:

1.  Verify no Pending ListenOnCandlepinEvents tasks exist  under Monitor > Tasks (or if they do count the # that do)
2.  Shut down qpidd
3.  Restart foreman-tasks and wait ~60 seconds
4.  Restart foreman-tasks again and wait ~60 seconds
5.  start qpidd
6.  Restart foreman-tasks once more


Result:  

Under Monitor > Tasks you will see one or more tasks stuck in 'pending'/.

Comment 4 Justin Sherrill 2015-07-20 21:40:12 UTC
Created redmine issue http://projects.theforeman.org/issues/11166 from this bug

Comment 5 Justin Sherrill 2015-07-21 15:53:17 UTC
Downstream PR: 
https://gitlab.sat.lab.tlv.redhat.com/satellite6/katello/merge_requests/89/

Comment 6 Jitendra Yejare 2015-07-23 09:50:23 UTC
Verified this bug on latest Satellite GA Snap 14 as per the steps mentioned in comment 3. 

The bug is no more reproducible and has been fixed.

Scrrenshot attached.

Comment 7 Jitendra Yejare 2015-07-23 09:51:37 UTC
Created attachment 1055270 [details]
Verified Screenshot

Comment 8 Brad Buckingham 2015-08-11 18:15:08 UTC
*** Bug 1241983 has been marked as a duplicate of this bug. ***

Comment 9 Bryan Kearney 2015-08-12 16:04:17 UTC
This bug was fixed in Satellite 6.1.1 which was delivered on 12 August, 2015.


Note You need to log in before you can comment on or make changes to this bug.