Bug 1252253

Summary: top bar contents not rendered if background image is missing
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 23CC: anaconda-maint-list, g.kaviyarasu, jonathan, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-08-11 12:40:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Adam Williamson 2015-08-11 05:05:48 UTC
generic-logos is missing topbar-bg and sidebar-bg image files - filed that as https://bugzilla.redhat.com/show_bug.cgi?id=1252252 . It seems that when the background image is missing, though, the contents of the top bar aren't rendered properly at all. It just shows as a flat blue block - none of the intended text or buttons are visible. They are *present* - if you know where the buttons are you can click them, or you can activate them with keyboard if you know the correct number of tabs to press. But you can't *see* them.

Comment 1 David Shea 2015-08-11 12:40:57 UTC
The whole point of the Requires: system-logos is so that we get the required logos. I doubt that there's much we can do to work around gtk's failure mode and I don't think it's worth our time if we can.

*** This bug has been marked as a duplicate of bug 1252252 ***