Bug 137571

Summary: Boot hangs on startudev on FC3-rc2
Product: [Fedora] Fedora Reporter: David Sanders <david>
Component: udevAssignee: Harald Hoyer <harald>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: prigault
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-01-14 04:36:00 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
Screenshot of FC3-rc2 hanging on startudev none

Description David Sanders 2004-10-29 11:22:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020

Description of problem:
After installing FC3-rc2, and a custom kernel so it will run under
Virtual PC 2004, boot-up hangs on startudev.  Pressing cntrl-c
continues with boot and everything runs normally.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Install FC3-rc2 under Virtual PC 2004
2.  Install custom kernel (see Bug #136018)
3.  Boot up

Actual Results:  Hangs on startudev

Expected Results:  bootup normally

Additional info:

Workaround is to press cntrl-c when it hangs.
Comment 1 David Sanders 2004-10-29 11:57:48 EDT
Created attachment 105944 [details]
Screenshot of FC3-rc2 hanging on startudev
Comment 2 Harald Hoyer 2004-11-01 04:10:07 EST
change udev_log="yes" to udev_log="no" in /etc/udev/udev.conf
Comment 3 David Sanders 2004-11-01 16:57:14 EST
That didn't work.  But, rpm -i --force udev-032-8.i386.rpm did.
Comment 4 Philippe Rigault 2004-11-03 18:56:01 EST
I had the same problem with installing FC3-rc2 on a Dell Inspiron 
7000, as described in 
This happens with a plain install (not Virtual PC) and the default 
Fedora kernel (2.6.9-1.643) 
Changing udev_log="yes" to udev_log="no" in /etc/udev/udev.conf 
solved it for me. 
Comment 5 David Sanders 2004-11-03 19:28:59 EST
Philippe, Changing udev_log didn't fix it here.
Comment 6 Harald Hoyer 2004-11-04 09:24:35 EST
David, did ctrl-C work?
Could you please try:
Comment 7 David Sanders 2004-11-04 12:41:37 EST
Harald, Yes ctrl-c will work.
I installed the new udev rpm listed above in Comment #6.  It worked,

Any chance of getting that into FC3-final ?
Comment 8 Julius Thyssen 2005-01-13 15:49:29 EST
Not to burst any bubbles, but udev still hangs startup here,
it takes about 40 seconds, then it goes to the
Initializing sequence, which is very slow as well.

Might be caused by having switched off USB in BIOS entirely?
Also noticed weird udev delay after adding extra RAM.

why not compile a version with at least some echo-ing of the errors?
(and release it for yum, there are many users with this problem)
Comment 9 Julius Thyssen 2005-01-13 21:52:31 EST
OK, flashing asus BIOS solved it for me.
My apologies (you may ignore and delete Comment #8 :)