Bug 137571 - Boot hangs on startudev on FC3-rc2
Summary: Boot hangs on startudev on FC3-rc2
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-29 15:22 UTC by David Sanders
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 09:36:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of FC3-rc2 hanging on startudev (62.66 KB, image/gif)
2004-10-29 15:57 UTC, David Sanders
no flags Details

Description David Sanders 2004-10-29 15:22:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
After installing FC3-rc2, and a custom kernel so it will run under
Virtual PC 2004, boot-up hangs on startudev.  Pressing cntrl-c
continues with boot and everything runs normally.

Version-Release number of selected component (if applicable):
udev-039-6

How reproducible:
Always

Steps to Reproduce:
1.  Install FC3-rc2 under Virtual PC 2004
2.  Install custom kernel (see Bug #136018)
3.  Boot up
    

Actual Results:  Hangs on startudev

Expected Results:  bootup normally

Additional info:

Workaround is to press cntrl-c when it hangs.

Comment 1 David Sanders 2004-10-29 15:57:48 UTC
Created attachment 105944 [details]
Screenshot of FC3-rc2 hanging on startudev

Comment 2 Harald Hoyer 2004-11-01 09:10:07 UTC
change udev_log="yes" to udev_log="no" in /etc/udev/udev.conf

Comment 3 David Sanders 2004-11-01 21:57:14 UTC
That didn't work.  But, rpm -i --force udev-032-8.i386.rpm did.

Comment 4 Philippe Rigault 2004-11-03 23:56:01 UTC
I had the same problem with installing FC3-rc2 on a Dell Inspiron 
7000, as described in 
http://www.redhat.com/archives/fedora-test-list/2004-October/msg02695.html. 
 
This happens with a plain install (not Virtual PC) and the default 
Fedora kernel (2.6.9-1.643) 
 
Changing udev_log="yes" to udev_log="no" in /etc/udev/udev.conf 
solved it for me. 

Comment 5 David Sanders 2004-11-04 00:28:59 UTC
Philippe, Changing udev_log didn't fix it here.

Comment 6 Harald Hoyer 2004-11-04 14:24:35 UTC
David, did ctrl-C work?
Could you please try:
http://people.redhat.com/harald/udev-039-10.FC3.1.i386.rpm

Comment 7 David Sanders 2004-11-04 17:41:37 UTC
Harald, Yes ctrl-c will work.
I installed the new udev rpm listed above in Comment #6.  It worked,
thanks.

Any chance of getting that into FC3-final ?

Comment 8 Julius Thyssen 2005-01-13 20:49:29 UTC
Not to burst any bubbles, but udev still hangs startup here,
it takes about 40 seconds, then it goes to the
Initializing sequence, which is very slow as well.

Might be caused by having switched off USB in BIOS entirely?
Also noticed weird udev delay after adding extra RAM.

why not compile a version with at least some echo-ing of the errors?
(and release it for yum, there are many users with this problem)

Comment 9 Julius Thyssen 2005-01-14 02:52:31 UTC
OK, flashing asus BIOS solved it for me.
My apologies (you may ignore and delete Comment #8 :)


Note You need to log in before you can comment on or make changes to this bug.