Bug 136018 - Cannot run FC3T3 with included kernel on Virtual PC 2004
Cannot run FC3T3 with included kernel on Virtual PC 2004
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
: 119838 124251 131037 144023 145696 147250 158385 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-16 16:22 EDT by David Sanders
Modified: 2015-01-04 17:10 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 17:12:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of Fedora Core 3 Test 3 running under Virtual PC 2004 (104.37 KB, image/jpeg)
2004-10-25 14:25 EDT, David Sanders
no flags Details

  None (edit)
Description David Sanders 2004-10-16 16:22:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20041001 Firefox/0.10.1

Description of problem:
After installing Fedora Core 3 Test 3, when you reboot the system will
not function properly.  Most commands entered at command prompt cause
a segmentation fault.  System never proceeds to the next stage of the
graphical install where you accept the license agreement.  Replacing
the included kernel with a custom kernel allows system to work.

Something in the configuration or perhaps a non-mainline patch is
incompatible with Virtual PC.  This should be isolated and corrected.
 I would be glad to help in any way.

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.541

How reproducible:
Always

Steps to Reproduce:
1.  Install Fedora Core 3 Test 3 under Virtual PC 2004


Actual Results:  Segmentation Fault after reboot.

Expected Results:  Boot/startup normally and proceed to next stage of
graphical install.

Additional info:

The kernel on the rescue ISO works fine.
Reference Bugs #119838 and #124251.

Work-around procedure:
Fedora Core 3 Test 3 Install Instructions
1.  Download the 4 ISO images AND the rescue image.
2.  Download fedora3.zip
(http://www.sandersweb.net/david/virtualpc/fedora3.zip)
    This contains the kernel, initial ram disk, and config files.
3.  Place fedora3.zip in a shared folder (so we can get at it later
via SAMBA).
4.  Create a Virtual Machine
5.  Boot from the first ISO image.
6.  Press <ENTER> at the boot prompt for graphical install.
7.  Skip testing media (or test if you want).
8.  Select next to continue.
9.  Select "Install Anyway"
10. Select language (english)
11. Select keyboard (us)
12. Select installation type (workstation)
13. Select disk partitioning (auto)
14. Click <YES> at warning
15. Select "Remove all partitions on this system"
    and check "Review (and modify) partitions created"
16. Click <YES> at warning
17. Highlight "VolGroup00" and click delete
18. Highlight /dev/hda2 and click delete
19. click new, select mount point /, type ext3, size 15850 fixed, click OK
20. click new, select type swap, size 400 "fill to max allow size",
click OK
21. click NEXT
22. at boot loader screen click next
23. configure network device
    - configure using DHCP (or assign IP address)
    - activate on boot
    - set hostname (whatever)
24. configure firewall
    - enable
    - allow http,ftp,ssh (or whatever)
    - SELinux active
25. Set default language (english)
    Select any required additional languages
26. Select time zone (whatever)
27. Set root password
28. Select "Customize software packages to be installed"
29. Select packages (whatever, but ensure you select "Windows File Server"
    because we need samba)
30. Click next to start install then click continue
31. <formats file system>
32. <installs packages> (capture other CDs when prompted)
33. When install is complete, use the VPC menu to capture the rescue disk
    then click reboot
34. At the boot prompt press enter for rescue mode
35. choose language (english)
36. choose keyboard (us)
37. choose <YES> to "Do you want to start network...?"
38. Select configure using DHCP (or enter IP address)
39. Select continue to find install
40. Select <OK> to continue
41. You are now at a shell prompt
    Type: chroot /mnt/sysimage
42. Type: smbclient //win2ksvr/Share -U david
    but replace "win2ksvr" with the name of your host computer
    replace "Share" with the name of your shared folder
    and replace "david" with your username on the host.
43. enter password for host computer if prompted to do so
44. Type: get fedora3.zip
45. Type: quit
46. Type: unzip -o fedora3.zip
47. Release the rescue ISO from the VPC menu
48. Type: exit (twice)
49. <reboots>
50. Select 1st kernel from the grub menu
51. <startup and enter graphical setup program>
52. Click next
53. accept license agreement
54. set date and time and enable ntp (if you want)
55. Display Setup (you can leave this as is for now)
56. Establish user account
57. <additional CDs> - click next
    <finish setup> - click next
58. <Continues startup>
59. Login
60. <All is well with the world>
Comment 1 David Sanders 2004-10-25 14:25:37 EDT
Created attachment 105738 [details]
Screenshot of Fedora Core 3 Test 3 running under Virtual PC 2004
Comment 2 Stephen Renker 2004-10-29 21:04:05 EDT
Having experimented with this previously in FC3Test1, it appears that 
Virtual PC does not deal well with the 4G/4G kernel (e.g., 
CONFIG_X86_4G = Y). Could we have an alternate kernel package with 
this option turned off?
Comment 3 David Sanders 2004-10-30 11:58:34 EDT
The .i586 kernel doesn't have 4G/4G built in (while .i686 does).
Comment 4 David Sanders 2004-11-03 15:30:24 EST
I have confirmed that the 4G/4G patch is the problem.  A kernel that
is identical in every way except having 4G/4G mode disabled works.  I
will have instructions and a kernel for Fedora Core 3 when it is released.

For the future, perhaps we could have a kernel-vpc package that
doesn't have 4g4g and installs by default if inside of a virtual machine.

I'm not sure why we need a 4g4g kernel as default anyway.  I would
suggest that if the amount of memory is less than 1G, we not install a
4g4g kernel anyway.  The documentation says there is a 20% performace
hit by using it.  What do you think?
Comment 5 Dave Jones 2004-11-20 00:02:36 EST
which documentation states that ? The hit is much less than you think. SELinux
for example probably adds more overhead.
Comment 6 Barry K. Nathan 2004-11-20 02:37:14 EST
> which documentation states that?

[barryn@localhost redhat]$ rpmbuild -bp --target i686
SPECS/kernel-2.6.spec
[ snip... ]
[barryn@localhost redhat]$ cd BUILD/kernel-2.6.9/linux-2.6.9/
[barryn@localhost linux-2.6.9]$ make menuconfig
[ snip... ]
Processor type and features  --->
<Select>
[*] 4 GB kernel-space and 4 GB user-space virtual memory support
<Help>

grep shows that the documentation there is in arch/i386/Kconfig.

Here's the relevant quote -- pay particular attention to the last
sentence:

>The cost of this option is additional TLB flushes done at
>system-entry points that transition from user-mode into kernel-mode.
>I.e. system calls and page faults, and IRQs that interrupt user-mode
>code. There's also additional overhead to kernel operations that copy
>memory to/from user-space. The overhead from this is hard to tell and
>depends on the workload - it can be anything from no visible overhead
>to 20-30% overhead. A good rule of thumb is to count with a runtime
>overhead of 20%.

Comment 7 Dave Jones 2004-11-20 15:00:25 EST
Whilst you can construct a microbenchmark to show such a large degradation, in
real-world applications, the overhead is much lower.  That help-text needs updating.
Comment 8 David Sanders 2004-11-20 17:39:43 EST
You can probably identify some workloads that 4g4g significantly 
helps.  But for most uses on the desktop it is not needed.  I am just 
suggesting that the default kernel doesn't need to be 4g4g.  Or at 
least I am not aware of any reason for it to be so. 
 
Perhaps we could agree to a i686 kernel without 4g4g being 
installable from the CD as an option during installation. 
Comment 9 Dave Jones 2004-11-27 17:12:29 EST
theres actually been some internal discussion over the last week or so whether
or not to ship it as default any more. For FC4, its likely that the default
kernel wont be 4g/4g for a number of reasons.

I'm also pondering doing the same to the next FC2/FC3 kernel update.
Comment 10 Dave Jones 2004-11-27 17:13:01 EST
*** Bug 131037 has been marked as a duplicate of this bug. ***
Comment 11 Dave Jones 2004-11-27 17:13:27 EST
*** Bug 124251 has been marked as a duplicate of this bug. ***
Comment 12 Dave Jones 2004-11-27 17:13:52 EST
*** Bug 119838 has been marked as a duplicate of this bug. ***
Comment 13 Dave Jones 2005-01-03 22:54:29 EST
*** Bug 144023 has been marked as a duplicate of this bug. ***
Comment 14 Dave Jones 2005-01-20 22:07:32 EST
*** Bug 145696 has been marked as a duplicate of this bug. ***
Comment 15 Warren Togami 2005-02-04 22:31:33 EST
*** Bug 147250 has been marked as a duplicate of this bug. ***
Comment 16 Brian Harvey 2005-02-05 13:52:56 EST
Thanks, Warren, for steering me to this bug report.  I'd like to
report that the kernel in
http://www.sandersweb.net/david/virtualpc/fedora3.zip
recommended above did *not* work for me, but the kernel in the
i586 RPM did work.
Comment 17 David Sanders 2005-02-05 14:36:45 EST
Brian, the fedira3.zip is only applicable to Fedora Core 3-Test 3. 
You should not be using it on the final Core 3 code.  See
vpc.visualwin.com for instruction related to the final release.
Comment 18 Dave Jones 2005-05-22 00:53:23 EDT
*** Bug 158385 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.