Bug 1384678

Summary: Missing top-left icon (and full application name) on Wayland
Product: [Fedora] Fedora Reporter: Giulio 'juliuxpigface' <juliux.pigface>
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 25CC: anass.1430, caolanm, dtardon, erack, mstahl, sbergman
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-07 09:12:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1277927    
Attachments:
Description Flags
LibreOffice Impress on Fedora 25 (Wayland session) none

Description Giulio 'juliuxpigface' 2016-10-13 20:14:36 UTC
Created attachment 1210266 [details]
LibreOffice Impress on Fedora 25 (Wayland session)

Description of problem:
Fedora 25 on i686 laptop here.

Calc, Draw, Impress and Writer show their icon while loading. Then, the icon disappear when the application is ready to use.

The application's name (located on the top panel) shows a similar behavior. The full name is displayed while loading the application. Then, it disappears and the generic name (e.g. "soffice") is displayed instead.

Version-Release number of selected component (if applicable):
libreoffice-gtk3-5.2.2.2-3.fc25.i686
gnome-session-wayland-session-3.22.0-1.fc25.i686
gnome-shell-3.22.1-1.fc25.i686
gtk3-3.22.1-2.fc25.i686
mutter-3.22.1-2.fc25.i686


How reproducible:
Always

Steps to Reproduce:
1.Open an application of the LibreOffice suite, from the Activities Overview.
2.Wait until it's ready to use

Actual results:
Icon is blank and the generic name is displayed.

Expected results:
Icon should be the right one and the full name should be displayed

Additional info:
Attaching a screenshot showing Impress and its top-left icon

Comment 1 Giulio 'juliuxpigface' 2016-10-13 20:27:02 UTC
Confirming that this is "WaylandRelated". The issue isn't reproducible on Gnome+Xorg.

Comment 2 Anass Ahmed 2016-10-16 22:15:31 UTC
This also affects the Alt + Tab and Alt + ` combinations.

The windows of the same app (Say: writer) appears separated instead of grouped by their app thus you can't switch between them with Alt + ` breaking the consistency of this behavior across the platform.

Comment 3 Caolan McNamara 2016-12-07 09:12:12 UTC

*** This bug has been marked as a duplicate of bug 1334915 ***