Bug 1384678 - Missing top-left icon (and full application name) on Wayland
Summary: Missing top-left icon (and full application name) on Wayland
Keywords:
Status: CLOSED DUPLICATE of bug 1334915
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 25
Hardware: i686
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2016-10-13 20:14 UTC by Giulio 'juliuxpigface'
Modified: 2016-12-07 09:12 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-07 09:12:12 UTC


Attachments (Terms of Use)
LibreOffice Impress on Fedora 25 (Wayland session) (117.18 KB, image/png)
2016-10-13 20:14 UTC, Giulio 'juliuxpigface'
no flags Details

Description Giulio 'juliuxpigface' 2016-10-13 20:14:36 UTC
Created attachment 1210266 [details]
LibreOffice Impress on Fedora 25 (Wayland session)

Description of problem:
Fedora 25 on i686 laptop here.

Calc, Draw, Impress and Writer show their icon while loading. Then, the icon disappear when the application is ready to use.

The application's name (located on the top panel) shows a similar behavior. The full name is displayed while loading the application. Then, it disappears and the generic name (e.g. "soffice") is displayed instead.

Version-Release number of selected component (if applicable):
libreoffice-gtk3-5.2.2.2-3.fc25.i686
gnome-session-wayland-session-3.22.0-1.fc25.i686
gnome-shell-3.22.1-1.fc25.i686
gtk3-3.22.1-2.fc25.i686
mutter-3.22.1-2.fc25.i686


How reproducible:
Always

Steps to Reproduce:
1.Open an application of the LibreOffice suite, from the Activities Overview.
2.Wait until it's ready to use

Actual results:
Icon is blank and the generic name is displayed.

Expected results:
Icon should be the right one and the full name should be displayed

Additional info:
Attaching a screenshot showing Impress and its top-left icon

Comment 1 Giulio 'juliuxpigface' 2016-10-13 20:27:02 UTC
Confirming that this is "WaylandRelated". The issue isn't reproducible on Gnome+Xorg.

Comment 2 Anass Ahmed 2016-10-16 22:15:31 UTC
This also affects the Alt + Tab and Alt + ` combinations.

The windows of the same app (Say: writer) appears separated instead of grouped by their app thus you can't switch between them with Alt + ` breaking the consistency of this behavior across the platform.

Comment 3 Caolan McNamara 2016-12-07 09:12:12 UTC

*** This bug has been marked as a duplicate of bug 1334915 ***


Note You need to log in before you can comment on or make changes to this bug.