Bug 1334915 - Libreoffice Missing icons on dock and Alt+tab on Wayland
Summary: Libreoffice Missing icons on dock and Alt+tab on Wayland
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 25
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1384678 1408483 1434530 (view as bug list)
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2016-05-10 19:13 UTC by Gabriel
Modified: 2017-03-31 14:47 UTC (History)
26 users (show)

Fixed In Version: libreoffice-5.2.6.2-5.fc25
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-30 01:21:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Document Foundation 100158 None None None 2016-06-02 15:36:16 UTC
GNOME Bugzilla 779143 None None None 2017-02-23 17:00:17 UTC

Description Gabriel 2016-05-10 19:13:32 UTC
Description of problem:


I'm using gnome on wayland and the icons from Libreoffice (Writer, Calc, etc.)  are missing from dock and Alt+Tab. Its just a "Missing icon" with "soffice" as description.

I did a fresh install from fedora-alpha and dnf update since there.

>rpm -qa | grep libreoffice 
libreoffice-graphicfilter-5.1.3.2-2.fc24.x86_64
libreoffice-emailmerge-5.1.3.2-2.fc24.x86_64
libreoffice-opensymbol-fonts-5.1.3.2-2.fc24.noarch
libreoffice-langpack-pt-BR-5.1.3.2-2.fc24.x86_64
libreoffice-ure-5.1.3.2-2.fc24.x86_64
libreoffice-writer-5.1.3.2-2.fc24.x86_64
libreoffice-filters-5.1.3.2-2.fc24.x86_64
libreoffice-gtk3-5.1.3.2-2.fc24.x86_64
libreoffice-pyuno-5.1.3.2-2.fc24.x86_64
libreoffice-pdfimport-5.1.3.2-2.fc24.x86_64
libreofficekit-5.1.3.2-2.fc24.x86_64
libreoffice-5.1.3.2-2.fc24.x86_64
libreoffice-calc-5.1.3.2-2.fc24.x86_64
libreoffice-draw-5.1.3.2-2.fc24.x86_64
libreoffice-xsltfilter-5.1.3.2-2.fc24.x86_64
libreoffice-x11-5.1.3.2-2.fc24.x86_64
libreoffice-math-5.1.3.2-2.fc24.x86_64
libreoffice-core-5.1.3.2-2.fc24.x86_64
libreoffice-ogltrans-5.1.3.2-2.fc24.x86_64
libreoffice-data-5.1.3.2-2.fc24.noarch
libreoffice-langpack-en-5.1.3.2-2.fc24.x86_64
libreoffice-base-5.1.3.2-2.fc24.x86_64
libreoffice-impress-5.1.3.2-2.fc24.x86_64

Comment 1 Caolan McNamara 2016-05-11 08:08:23 UTC
I think this is related to the hack we have under X where one window can change from being a writer window to the empty starter window to a calc window etc. There isn't an existing desktop-independent way to achieve that.

Comment 2 Jeffrey Cutter 2016-11-22 22:36:35 UTC
This is still broken on Fedora 25 GA released today.  The Document Foundation bug doesn't seem to have any activity.  Is there anything that can be done?

Comment 3 Jan Vlug 2016-11-27 09:10:38 UTC
After upgrading to Fedora 25 I have this issue as well. In Fedora 24 I still had the icon.

Comment 4 Sorawit Kongnurat 2016-12-06 10:55:04 UTC
I also have this issue. The icons return when using the xorg session.

Comment 5 Caolan McNamara 2016-12-07 09:12:12 UTC
*** Bug 1384678 has been marked as a duplicate of this bug. ***

Comment 6 David H. Gutteridge 2016-12-20 22:24:09 UTC
Another issue of this kind is that LibreOffice icons aren't retained in the frequently used applications list under Gnome. I imagine this is related to the rest. (Hardly a critical issue for me, just another detail.)

Comment 7 Marco Driusso 2017-01-05 13:03:08 UTC
Same issue here.

$ rpm -qa | grep libreoffice
libreoffice-graphicfilter-5.2.3.3-11.fc25.x86_64
libreoffice-core-5.2.3.3-11.fc25.x86_64
libreoffice-calc-5.2.3.3-11.fc25.x86_64
libreoffice-xsltfilter-5.2.3.3-11.fc25.x86_64
libreoffice-ure-common-5.2.3.3-11.fc25.noarch
libreoffice-draw-5.2.3.3-11.fc25.x86_64
libreoffice-gtk3-5.2.3.3-11.fc25.x86_64
libreoffice-pyuno-5.2.3.3-11.fc25.x86_64
libreoffice-x11-5.2.3.3-11.fc25.x86_64
libreoffice-ogltrans-5.2.3.3-11.fc25.x86_64
libreoffice-ure-5.2.3.3-11.fc25.x86_64
libreoffice-gtk2-5.2.3.3-11.fc25.x86_64
libreoffice-pdfimport-5.2.3.3-11.fc25.x86_64
libreoffice-langpack-en-5.2.3.3-11.fc25.x86_64
libreoffice-math-5.2.3.3-11.fc25.x86_64
libreoffice-writer2latex-1.0.2-19.fc24.x86_64
libreoffice-emailmerge-5.2.3.3-11.fc25.x86_64
libreoffice-opensymbol-fonts-5.2.3.3-11.fc25.noarch
libreoffice-writer-5.2.3.3-11.fc25.x86_64
libreoffice-filters-5.2.3.3-11.fc25.x86_64
libreoffice-data-5.2.3.3-11.fc25.noarch
libreoffice-impress-5.2.3.3-11.fc25.x86_64

$ rpm -qa | grep wayland
libwayland-server-1.12.0-1.fc25.i686
xorg-x11-server-Xwayland-1.19.0-2.fc25.x86_64
libwayland-client-1.12.0-1.fc25.x86_64
libwayland-client-1.12.0-1.fc25.i686
ibus-wayland-1.5.14-3.fc25.x86_64
libwayland-server-1.12.0-1.fc25.x86_64
gnome-session-wayland-session-3.22.2-1.fc25.x86_64
libwayland-cursor-1.12.0-1.fc25.x86_64
mesa-libwayland-egl-13.0.2-2.fc25.x86_64

Comment 8 Caolan McNamara 2017-01-10 15:48:00 UTC
*** Bug 1408483 has been marked as a duplicate of this bug. ***

Comment 9 RudraB 2017-01-15 12:08:37 UTC
Okular is also having same problem.

Comment 10 David H. Gutteridge 2017-01-17 03:00:25 UTC
(In reply to RudraB from comment #9)
> Okular is also having same problem.

That should be a separate bug report, I think. I see Okular also doesn't appear under "frequently used applications" in Wayland, but the original issues noted in this bug report don't apply.

Comment 11 Mechanizoid 2017-01-21 08:52:20 UTC
I am experiencing this same bug under Wayland in Fedora 25. Also, Libreoffice icons aren't retained in Gnome's frequently used applications as David H. Gutteridge described.

I've logged into an Xorg session, and the icons appear in the Dock and alt-tab as normal. Also, Libreoffice icons appear in the frequently used applications again.

$ uname -sr
Linux 4.9.4-201.fc25.x86_64

$ rpm -qa | grep libreoffice
libreoffice-langpack-en-5.2.4.2-3.fc25.x86_64
libreoffice-writer-5.2.4.2-3.fc25.x86_64
libreoffice-opensymbol-fonts-5.2.4.2-3.fc25.noarch
libreoffice-pdfimport-5.2.4.2-3.fc25.x86_64
libreoffice-xsltfilter-5.2.4.2-3.fc25.x86_64
libreoffice-data-5.2.4.2-3.fc25.noarch
libreoffice-ure-common-5.2.4.2-3.fc25.noarch
libreoffice-graphicfilter-5.2.4.2-3.fc25.x86_64
libreoffice-filters-5.2.4.2-3.fc25.x86_64
libreoffice-core-5.2.4.2-3.fc25.x86_64
libreoffice-calc-5.2.4.2-3.fc25.x86_64
libreofficekit-5.2.4.2-3.fc25.x86_64
libreoffice-impress-5.2.4.2-3.fc25.x86_64
libreoffice-x11-5.2.4.2-3.fc25.x86_64
libreoffice-ure-5.2.4.2-3.fc25.x86_64
libreoffice-draw-5.2.4.2-3.fc25.x86_64
libreoffice-emailmerge-5.2.4.2-3.fc25.x86_64
libreoffice-math-5.2.4.2-3.fc25.x86_64
libreoffice-gtk2-5.2.4.2-3.fc25.x86_64
libreoffice-gtk3-5.2.4.2-3.fc25.x86_64
libreoffice-ogltrans-5.2.4.2-3.fc25.x86_64
libreoffice-pyuno-5.2.4.2-3.fc25.x86_64

$ rpm -qa | grep wayland
ibus-wayland-1.5.14-5.fc25.x86_64
gnome-session-wayland-session-3.22.2-3.fc25.x86_64
mesa-libwayland-egl-13.0.3-1.fc25.x86_64
libwayland-server-1.12.0-1.fc25.x86_64
libwayland-client-1.12.0-1.fc25.x86_64
xorg-x11-server-Xwayland-1.19.1-2.fc25.x86_64
libwayland-cursor-1.12.0-1.fc25.x86_64

Comment 12 Tim Hodson 2017-01-27 23:37:20 UTC
I followed some advice elsewhere to do with getting LibreOffice looking good under Wayland on F25 with a HiDPI display. In the /usr/share/applications/libreoffice-*.desktop files I changed the Exec line to set an environment variable to use gtk rather than gtk3 (env SAL_USE_VCLPLUGIN=gtk). For instance: 

Exec=env SAL_USE_VCLPLUGIN=gtk libreoffice --calc %U. 

This did help with scaling, but also brought the icons back in Gnome when alt-tabbing, thus grouping windows together. It has also allowed LibreOffice to get back into the frequently used application list. This works without having to log into an XOrg session. 

$ uname -sr
Linux 4.9.5-200.fc25.x86_64

LibreOffice and Wayland versions appear to be as above. I'm just adding this as it might help someone to track down the cause, as it is working in Wayland (or at least Xwayland) but not gtk3.

Comment 13 Gabriel 2017-02-01 01:15:39 UTC
(In reply to Tim Hodson from comment #12)
> I followed some advice elsewhere to do with getting LibreOffice looking good
> under Wayland on F25 with a HiDPI display. In the
> /usr/share/applications/libreoffice-*.desktop files I changed the Exec line
> to set an environment variable to use gtk rather than gtk3 (env
> SAL_USE_VCLPLUGIN=gtk). For instance: 
> 
> Exec=env SAL_USE_VCLPLUGIN=gtk libreoffice --calc %U. 
> 
> This did help with scaling, but also brought the icons back in Gnome when
> alt-tabbing, thus grouping windows together. It has also allowed LibreOffice
> to get back into the frequently used application list. This works without
> having to log into an XOrg session. 
> 
> $ uname -sr
> Linux 4.9.5-200.fc25.x86_64
> 
> LibreOffice and Wayland versions appear to be as above. I'm just adding this
> as it might help someone to track down the cause, as it is working in
> Wayland (or at least Xwayland) but not gtk3.

This really works!

Comment 14 Luis Villa 2017-02-02 18:18:24 UTC
For anyone who uses Writer a lot (I currently have about a half-dozen Writer windows open) this is super-irritating (and of course an irritating regression from F24). I'd suggest "medium" is a more accurate priority than low.

Comment 15 Caolan McNamara 2017-02-02 20:41:14 UTC
regression in meaningless in the sense that it has never property worked under wayland because we reuse the same window when switching from start center to random application to start center again.

Comment 16 Luis Villa 2017-02-06 23:11:00 UTC
From a user perspective, it worked in a reasonably stock F24 install and doesn't work in a reasonably stock F25 install. So I'm pretty comfortable calling it a regression.

Comment 17 Bruno Machado 2017-03-09 03:44:23 UTC
Same problem here

Comment 18 Bruno Machado 2017-03-09 03:45:21 UTC
(In reply to Bruno Machado from comment #17)
> Same problem here

I'm running a Fedora 25

Comment 19 Caolan McNamara 2017-03-22 12:24:10 UTC
*** Bug 1434530 has been marked as a duplicate of this bug. ***

Comment 20 Caolan McNamara 2017-03-23 14:32:50 UTC
Looks like I'm not going to get an api in gtk in any reasonably short term that would allow us to change windows applications ids to make this work the way it does under X, so I'll just try and bodge things to set a uniform fallback to the startcenter so at least there's some reasonable icon.

Comment 21 Fedora Update System 2017-03-28 08:23:09 UTC
libreoffice-5.2.6.2-5.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-36bc8a20e4

Comment 22 David H. Gutteridge 2017-03-28 15:52:03 UTC
libreoffice-5.2.6.2-5.fc25 is a definite improvement, thanks!

Comment 23 Fedora Update System 2017-03-29 04:23:28 UTC
libreoffice-5.2.6.2-5.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-36bc8a20e4

Comment 24 Fedora Update System 2017-03-30 01:21:03 UTC
libreoffice-5.2.6.2-5.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 Alexander Mayorov 2017-03-31 08:33:31 UTC
What is a reason to close the ticket?
I think the delivered solution is more like a workaround but could not be a final resolution because the original behavior (observed in X session) is not restored yet.

Comment 26 Caolan McNamara 2017-03-31 12:41:31 UTC
Its not possible with the apis gtk3 gives me to do it, there's a patch submitted upstream to gtk to support it without much interest in the problem. Reopening here will just lead to closed upstream,  I have to pick battles I can win.

Comment 27 Jean-François Fortin Tam 2017-03-31 13:50:46 UTC
Just out of curiosity, it would be good to link to the upstream GTK bug report (maybe in the "URL" field above?)

Comment 28 Caolan McNamara 2017-03-31 14:47:18 UTC
Its there as https://bugzilla.gnome.org/show_bug.cgi?id=779143 in "External Trackers"


Note You need to log in before you can comment on or make changes to this bug.