Bug 139682

Summary: gnome-volume-properties will not start, complains that hald is not running when it is
Product: [Fedora] Fedora Reporter: Sean Carolan <sean>
Component: gnome-volume-managerAssignee: John (J5) Palmieri <johnp>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: jkeck
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 14:07:05 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
lshal output as requested none

Description Sean Carolan 2004-11-17 09:47:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
Trying to run gnome-volume-properties returns the following error:

************
Volume Management not Supported

The "hald" service is required but not currently running. Enable the
service and rerun this applet, or contact your system administrator.
************

However the hald is running:

[root@dellnote init.d]# /sbin/service haldaemon status
hald (pid 2654) is running...


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Click red hat >> Preferences
2.  Click on "Removable Storage"
3.  View the error message
    

Actual Results:  Got an error message.

Expected Results:  Should have got a pretty box with lots of bells and
whistles.

Additional info:
Comment 1 John (J5) Palmieri 2004-11-17 10:22:16 EST
What is your setup?  Are you running a fresh install?  Have you
changed some packages or installed from source?
Comment 2 Sean Carolan 2004-11-17 10:43:32 EST
Fresh install, using a stock Dell Latitude D600 (now that I think of
it, this should have been filed under i686 instead of i386).  All the
packages are from the standard repository, nothing compiled from
source except for a few unrelated perl scripts that I use for development.
Comment 3 John (J5) Palmieri 2004-11-17 10:48:42 EST
Ok, can you post the output of lshal?

Comment 4 Sean Carolan 2004-11-17 11:12:09 EST
Created attachment 106891 [details]
lshal output as requested
Comment 5 John (J5) Palmieri 2004-11-19 14:59:21 EST
It looks like you might be having symptoms of Bug #140081.  Please run
the prelink command at the bottom of the report and tell me if it
fixes your problem.
Comment 6 Sean Carolan 2004-11-19 15:19:54 EST
Ok, I can run gnome-volume-properties now from the command line.
Comment 7 Sean Carolan 2004-11-19 15:24:08 EST
Ok, I can run gnome-volume-properties now from the command line.
Comment 8 John (J5) Palmieri 2004-11-19 15:26:31 EST

*** This bug has been marked as a duplicate of 140081 ***
Comment 9 Red Hat Bugzilla 2006-02-21 14:07:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.