Bug 140081 - gnome-volume-manager segfaults
gnome-volume-manager segfaults
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
: 139682 140103 140158 140357 140498 141166 (view as bug list)
Depends On:
Blocks: FC3Target 135876 FC4Target
  Show dependency treegraph
Reported: 2004-11-19 12:17 EST by Tim Niemueller
Modified: 2007-11-30 17:10 EST (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-01 07:36:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
strace while running gnome-volume-manager (92.28 KB, text/plain)
2004-11-19 12:21 EST, Tim Niemueller
no flags Details
tar archive of crashing /usr/lib/libdbus*so* (155.56 KB, application/x-bzip)
2004-11-19 19:31 EST, Barry K. Nathan
no flags Details

  None (edit)
Description Tim Niemueller 2004-11-19 12:17:14 EST
Description of problem:
gnome-volume-manager and gnome-volume-properties crash with a segfault.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Login to machine
2. See volume manager crash
1. Go to xterm
2. execute gnome-volume-manager
Actual results:
Crashes, gnome screen comes up informing of crash. No volume manager
is running after this.

Expected results:
gnome-volume-manager should run, gnome-volume-properties should
display settings window.

Additional info:
Will attach a strace while running the problem. This problem occured
after todays "yum update" leading to new xorg files and some other
packages that I do not remember (sorry, didn't expect that kind of
problem...). Worked fine before the update.
Comment 1 Tim Niemueller 2004-11-19 12:21:47 EST
Created attachment 107066 [details]
strace while running gnome-volume-manager
Comment 2 Barry K. Nathan 2004-11-19 12:38:16 EST
I'm seeing both gnome-volume-manager and eggcups crash after applying
the latest round of FC3 updates. I don't know what the actual cause
is, but it's not the kernel -- rebooting into the old kernel (667)
does not eliminate the problem.
Comment 3 Tim Niemueller 2004-11-19 12:54:08 EST
Oh, right, I totally forgot about eggcups. The same here. I tried
around with the session and so the eggcups only occurred once.
Comment 4 John (J5) Palmieri 2004-11-19 13:17:23 EST
Ok, I can reproduce this.  Tim can you post your /var/log/yum.log file
here.  Thanks.
Comment 5 John (J5) Palmieri 2004-11-19 14:58:11 EST
Please run 
/usr/sbin/prelink /usr/lib/libdbus*so*
and see if this fixes the problem.

Tim, I would still like your yum.log so I can track down what is
causing the dbus prelink stuff to get out of sync.  Thanks.
Comment 6 John (J5) Palmieri 2004-11-19 15:26:34 EST
*** Bug 139682 has been marked as a duplicate of this bug. ***
Comment 7 Hamilton Leeper 2004-11-19 16:15:09 EST
I'm getting similar problems after applying the latest round of
updates for FC3 (11/19) Additionally, nautilus-cd-burner seems to
crash.  Running /usr/lib/libdbus*so* gives me a segfault.  :(
Comment 8 Hamilton Leeper 2004-11-19 16:21:28 EST
here are the updates that lead to the problem:

[Fri Nov 19 12:43:18 2004] up2date installing packages:
['kernel-2.6.9-1.678_FC3', 'rhgb-0.15.1-1.FC3',
'sound-juicer-0.5.14-1.FC3.0', 'system-config-users-1.2.28-0.fc3.1',
'udev-039-10.FC3.2', 'xorg-x11-6.8.1-12.FC3.1',
'xorg-x11-devel-6.8.1-12.FC3.1', 'xorg-x11-font-utils-6.8.1-12.FC3.1',
'xorg-x11-libs-6.8.1-12.FC3.1', 'xorg-x11-tools-6.8.1-12.FC3.1',
'xorg-x11-twm-6.8.1-12.FC3.1', 'xorg-x11-xauth-6.8.1-12.FC3.1',
Comment 9 Hamilton Leeper 2004-11-19 16:28:41 EST
OK, the problems have gone away after running /etc/cron.daily/prelink

Comment 10 Barry K. Nathan 2004-11-19 16:37:52 EST
Re: comment #5

Yes, running "/usr/sbin/prelink /usr/lib/libdbus*so*" made the problem
go away. Now, I'm going to try /etc/cron.daily/prelink and see if that
makes it come back or not.
Comment 11 Barry K. Nathan 2004-11-19 17:09:18 EST
/etc/cron.daily/prelink did not make the problem reappear.

(BTW, I swear I ran /etc/cron.daily/prelink after the latest round of updates
but before rebooting. It seems weird to me that I had to run prelink a second
time in order to not have a crash...)
Comment 12 Tim Niemueller 2004-11-19 17:29:36 EST
Running /etc/cron.daily/prelink did fix the problem for me! Here is
the list of packages that yum installed:

Nov 19 14:01:56 Installed: kernel.i686 2.6.9-1.678_FC3
Nov 19 14:02:02 Updated: udev.i386 039-10.FC3.2
Nov 19 14:02:03 Updated: xorg-x11-deprecated-libs-devel.i386
Nov 19 14:02:07 Updated: system-config-users.noarch 1.2.28-0.fc3.1
Nov 19 14:02:11 Updated: xorg-x11-libs.i386 6.8.1-12.FC3.1
Nov 19 14:02:12 Updated: xorg-x11-Mesa-libGL.i386 6.8.1-12.FC3.1
Nov 19 14:02:12 Updated: xorg-x11-font-utils.i386 6.8.1-12.FC3.1
Nov 19 14:02:16 Updated: xorg-x11-Mesa-libGLU.i386 6.8.1-12.FC3.1
Nov 19 14:02:16 Updated: xorg-x11-xauth.i386 6.8.1-12.FC3.1
Nov 19 14:02:22 Updated: xorg-x11-xfs.i386 6.8.1-12.FC3.1
Nov 19 14:02:29 Updated: xorg-x11.i386 6.8.1-12.FC3.1
Nov 19 14:02:37 Updated: xorg-x11-devel.i386 6.8.1-12.FC3.1
Nov 19 14:02:41 Updated: gaim.i386 1:1.0.3-0.FC3
Nov 19 14:02:41 Updated: xorg-x11-deprecated-libs.i386 6.8.1-12.FC3.1
Nov 19 14:02:45 Updated: planner.i386 0.12.1-1.1.fc3.rf
Nov 19 14:02:46 Updated: imlib2.i386 1.1.2-2.1.fc3.rf
Nov 19 14:02:48 Updated: xorg-x11-twm.i386 6.8.1-12.FC3.1
Nov 19 14:02:50 Updated: xorg-x11-tools.i386 6.8.1-12.FC3.1
Nov 19 14:02:51 Updated: rhgb.i386 0.15.1-1.FC3
Nov 19 14:02:54 Updated: sound-juicer.i386 0.5.14-1.FC3.0

I removed a bunch of third-party RPMs that have been installed that I
think that are unrelated to the problem.
Comment 13 Barry K. Nathan 2004-11-19 17:46:23 EST
That reminds me, here's the list of packages that up2date installed
for me (before this I had no problem, but after this I had the problem):

[Thu Nov 18 15:44:14 2004] up2date installing packages:
['kernel-2.6.9-1.678_FC3', 'kernel-doc-2.6.9-1.678_FC3',
'libxml-1.8.17-12', 'libxml-devel-1.8.17-12', 'rhgb-0.15.1-1.FC3',
'sound-juicer-0.5.14-1.FC3.0', 'system-config-users-1.2.28-0.fc3.1',
'udev-039-10.FC3.2', 'xorg-x11-6.8.1-12.FC3.1',
'xorg-x11-Mesa-libGLU-6.8.1-12.FC3.1', 'xorg-x11-Xdmx-6.8.1-12.FC3.1',
'xorg-x11-Xnest-6.8.1-12.FC3.1', 'xorg-x11-Xvfb-6.8.1-12.FC3.1',
'xorg-x11-devel-6.8.1-12.FC3.1', 'xorg-x11-doc-6.8.1-12.FC3.1',
'xorg-x11-font-utils-6.8.1-12.FC3.1', 'xorg-x11-libs-6.8.1-12.FC3.1',
'xorg-x11-sdk-6.8.1-12.FC3.1', 'xorg-x11-tools-6.8.1-12.FC3.1',
'xorg-x11-twm-6.8.1-12.FC3.1', 'xorg-x11-xauth-6.8.1-12.FC3.1',
'xorg-x11-xdm-6.8.1-12.FC3.1', 'xorg-x11-xfs-6.8.1-12.FC3.1']

On this system I have been using up2date rather than yum (I don't
remember if I have a particular reason why; if I do, then I don't
remember the reason right now).
Comment 14 Barry K. Nathan 2004-11-19 19:31:46 EST
Created attachment 107108 [details]
tar archive of crashing /usr/lib/libdbus*so*

On another system, the problem happened for me again. I'm not completely sure
the package list is relevant this time -- this was in some sense an upgrade
from a late October/early November rawhide snapshot to FC3 final + updates,
although some of the updates had been applied previously.

This time, I !!KNOW!! I ran /etc/cron.daily/prelink before rebooting into the
updated system!!

In any case, here's a tar archive of the failing /usr/lib/libdbus*so* files. Is
this what is needed? If not, let me know and I'll try to provide whatever is
needed. (Like my first experience, this is gnome-volume-manager and eggcups
Comment 15 Jakub Jelinek 2004-11-20 03:38:50 EST
No, this is not sufficient.
For a program that segfaults when prelinked and doesn't when not prelinked,
I need:
1) description how to reproduce the problem (what options use, what actions to do
2) say /usr/bin/gnome-foo is failing, then I need
tar chjf gnome-foo.tar.bz2 `LD_TRACE_PRELINKING=1 LD_WARN= /usr/bin/gnome-foo | awk '{print $3}'`
tarball at the point when you CAN reproduce it.  After you tar it up, do
for i in `LD_TRACE_PRELINKING=1 LD_WARN= /usr/bin/gnome-foo |__
   awk '{print $3}'`; do prelink -u $i; done
and verify it doesn't fail.

You have packed up only some libraries, which is not useful.  Prelinking info
is used only if the binary and all its libraries are currently prelinked.
Comment 16 John (J5) Palmieri 2004-11-20 09:06:59 EST
*** Bug 140158 has been marked as a duplicate of this bug. ***
Comment 17 Marc Deslauriers 2004-11-20 09:27:48 EST
gnome-volume-manager is failing for me too after updates. Here is the
tarfile with the libraries as asked for:


Doing the "for i in..." command to prelink the libraries resolved the
problem for me.
Comment 18 Richard Irving 2004-11-21 11:13:50 EST
I found a workaround, but it is a temporary fix...

 After finding such pretties, as this in my log, with the
same problem:

Nov 21 10:49:39 smoker kernel: hald[3648]: segfault at
0000003985010f30 rip 0000003985010f30 rsp 0000007fbffff738 error 14
Nov 21 10:49:39 smoker haldaemon: haldaemon startup succeeded
Nov 21 10:49:45 smoker haldaemon: haldaemon shutdown failed
Nov 21 10:49:50 smoker kernel: hald[3664]: segfault at
0000003985010f30 rip 0000003985010f30 rsp 0000007fbffff738 error 14
Nov 21 10:49:50 smoker haldaemon: haldaemon startup succeeded
Nov 21 10:51:04 smoker kernel: gnome-vfs-daemo[3676]: segfault at
0000003985010f30 rip 0000003985010f30 rsp 0000007fbfffec68 error 14
Nov 21 10:53:29 smoker kernel: gnome-vfs-daemo[3748]: segfault at
0000003985010f30 rip 0000003985010f30 rsp 0000007fbfffec68 error 14

  I decided to do a haldaemon upgrade reversal...

And dropped a great big rpm -i --force on the following files:

dbus-0.22-10.x86_64.rpm         gnome-volume-manager-1.1.0-5.x86_64.rpm
dbus-devel-0.22-10.x86_64.rpm   hal-0.4.0-10.x86_64.rpm
dbus-glib-0.22-10.x86_64.rpm    hal-cups-utils-0.5.2-8.x86_64.rpm
dbus-python-0.22-10.x86_64.rpm  hal-devel-0.4.0-10.x86_64.rpm
dbus-x11-0.22-10.x86_64.rpm     hal-gnome-0.4.0-10.x86_64.rpm

  Yeah, I know it was atom bombing the solution, but it 
works. BTW: The platform is X_86, not i386.... at least in my case.

  Good luck finding the root cause.

Comment 19 Jakub Jelinek 2004-11-22 12:26:56 EST
Looking at the #17 tarball, this is a prelink bug.
From what I can see:
- most of the packages were prelinked on 2004-11-16
- then I guess xorg-x11-libs (not sure if something else too) got upgraded
- prelink was run again on 2004-11-20:
  - libICE.so.6 libXrender.so.1 libXrandr.so.2 libXi.so.6 libXinerama.so.1 libXft.so.2 libXext.so.6 libXcursor.so.1 libX11.so.6 libSM.so.6
  libraries were prelinked because they changed (by the xorg-x11-libs upgrade)
  - libpangoxft-1.0.so.0 libpangox-1.0.so.0 libbonoboui-2.so.0 libgdk-x11-2.0.so.0 libgnomecanvas-2.so.0 libgnomeui-2.so.0 libgtk-x11-2.0.so.0
  libraries were re-prelinked because they depend on the libraries in the first
  - now, for some not yet known reason (most probably because the layout code
  saw some library grew up and occupied some memory slot that was previously
  used by something else) prelink decided to re-prelink libdbus-1.so.0 too
  (it doesn't depend on anything that changed)
  - but libhal.so.0 that depends on libdbus-1.so.0 was not re-prelinked
  - gnome-volume-manager was re-prelinked (because several of its dependencies

I'll now try to figure out why prelink did not re-prelink libhal.so.0 and worse
the consistency checks before re-prelinking a binary did not catch that libhal.so.0 has not been re-prelinked.
Comment 20 Jakub Jelinek 2004-11-22 12:30:10 EST
*** Bug 140357 has been marked as a duplicate of this bug. ***
Comment 21 Jonathan Underwood 2004-11-22 14:52:42 EST
I too am seeing these issues with eggcups and gnome-volume-manager.
Same as everyone else, goes away when I manually prelink. But, as an
extra twist, and maybe (un)related, after the round of updates that
triggered this issue, I also see that on shutdown, the hal daemon
fails to shutdown. 
Comment 22 Dave Pawson 2004-11-22 14:55:29 EST
/etc/cron.daily/prelink cured the problem for me too.
6 day old new install, new hardware;
one set of yum updates.

then yum update of kernel2.6.9-1.681_fc3
reboot. Problem persists.

prelink, reboot, OK.
Changing from gnome to kde seems to bypass the problem.
Comment 23 Barry K. Nathan 2004-11-22 15:57:16 EST
Until prelink is fixed, I guess a change like this (commenting out
PRELINK_FULL_TIME_INTERVAL) should keep the problem from reoccurring
in the future.

--- /etc/sysconfig/prelink.previous     2004-11-22 12:54:51.165557993
+++ /etc/sysconfig/prelink      2004-11-22 12:55:07.536232188 -0800
@@ -18,4 +18,4 @@
 # $PRELINK_FULL_TIME_INTERVAL days it will be run
 # in normal mode.  Comment it out if it should be run
 # in normal mode always.
Comment 24 Jakub Jelinek 2004-11-22 17:01:13 EST
Anyone who can reproduce this, can you figure out what packages (ENVR+arch)
you had installed before the up2date that brought in xorg-x11-*, after which
another prelink run failed to prelink libhal.so.0?
If I figure out what happened just from source analysis, I'd still like to
verify, if I don't, I'd like to certainly see it under the debugger.
If I have a list of packages before, I can install them in a chroot, prelink,
update xorg-x11 (and other packages that you updated during that update) and
debug the re-prelink.

Comment 25 Marc Deslauriers 2004-11-22 18:42:26 EST
Prelinking failed again for me this morning. I sat in front of my
computer that was already logged in. Clicked on the evolution icon, I
get a segfault, I clicked on gnome-terminal, another segfault. Pretty
much everything was broke. I hit Ctrl-Alt-F1, logged in as root and
did the following:

prelink -ua
added --no-exec-shield to the /etc/sysconfig/prelink file
prelink -am --no-exec-shield
sysctl -w kernel.exec-shield-randomize=0
sysctl -w kernel.exec-shield=0

Switched back to Ctrl-Alt-F7, did a Ctrl-Backspace. Logged in again
and everything was back to normal.

Something is very wrong in prelink land :)

Comment 26 Richard Irving 2004-11-22 19:58:41 EST
  FWIW, the downgrade using the RPMs I mentioned, above,
has proven stable and reliable..... so far.
 No more Segv's... no issue's, at all.

(Actually, the system -smokes-   :)

 It would seem implied that culprit sits within that
grouping of RPM's.... and their upgrades.
Comment 27 Colin Walters 2004-11-23 00:32:48 EST
*** Bug 140498 has been marked as a duplicate of this bug. ***
Comment 28 Jakub Jelinek 2004-11-23 06:42:12 EST
Ok, can you try ftp://people.redhat.com/jakub/prelink/prelink-0.3.3-1.*.rpm ?
Would be thankful if somebody tried it as well on a FC3 box without the most
recent updates (from last 4 days or so), then up2date it and rerun
If all is fine, I'll move this to FC3 updates/testing soon.
Comment 29 Colin Walters 2004-11-23 10:18:14 EST
*** Bug 140103 has been marked as a duplicate of this bug. ***
Comment 30 John Chesley 2004-11-23 12:00:02 EST
I had the same problem after updating the kernel with yum. Removing
desktop-printing with 'yum remove desktop-printing' made it stop.
Reinstalling after logging out and back in again did not cause any
Comment 31 Jakub Jelinek 2004-11-23 12:23:26 EST
prelink-0.3.3-0.fc3 is now in updates/testing/3.
Comment 33 Khovu 2004-11-25 10:34:42 EST
I followed the step:

1.  ftp://people.redhat.com/jakub/prelink/prelink-0.3.3-1.*.rpm
2.  up2date prelink
3.  /etc/cron.daily/prelink

step 3 runs forever. It seems to run in an infinite loop.
Comment 34 Jakub Jelinek 2004-11-25 10:40:11 EST
Forever means you killed it after how long exactly?
prelink upgrade means everything is re-prelinked, that can very well take
half an hour.
Watch /var/log/prelink.log if there is any progress.
If prelink really run into an infinite loop (haven't seen that ever), as
in /var/log/prelink.log wouldn't keep moving and say /proc/`pidof prelink`/fd/
wouldn't show any progress, then I need you to install
prelink-debuginfo* (look into updates/testing/3/i386/debug/ on Fedora mirrors)
and while it is still running attach debugger to it and see what is it doing.
Comment 35 Robert Bertram 2004-11-26 05:27:34 EST
I had this problem also. First boot after running the updates I
swapped out the DVD burner in my laptop. Shutting done I noticed the
HAL daemon failing to stop. Thinking it was a UDEV problem I started
to follow the steps on the Fedora UDEV page. Ran start_udev. I got the
kernel source to have a go at run mkinitrd but accidentally started
the kernel compilation as well. Let it run thinking it would do the
job and it did.
Does a kernel compile run the prelinker?
Comment 36 Steve Romero 2004-11-27 15:17:02 EST
Same problem that others are experiencing, gnome-volume-manager and
eggcups crashing on startup.  This is a new install completed with
updates 26 Nov 04.  I did not have any issues until I configured
LM-Sensors and rebooted?  Removing the configuration changes for
LM-Sensors and running "/etc/cron.daily/prelink" and rebooting fixed
the problem.

Shuttle MK40VN
XP 1600+
512 MB (2 x 256)
Comment 37 Barry K. Nathan 2004-11-28 05:21:31 EST
I just tested the updates/testing/3 prelink package. It fixes the
problem (i.e. installing FC3, prelinking, installing updates, and
prelinking again causes crashes for me if I use FC3's prelink, but not
if I use the new prelink package).
Comment 38 Jakub Jelinek 2004-11-29 08:27:08 EST
Can I get answer for my #34 question, please?
Multiple people reported the same as #37, so I'd like to release normal updates
(not testing) RSN.
Comment 39 David Zeuthen 2004-11-29 13:53:22 EST
*** Bug 141166 has been marked as a duplicate of this bug. ***
Comment 40 marlon bastida 2004-11-29 20:06:52 EST
Well with me happen in this situation
I never switch to xfce, after enter in xfce and back to default
session happen:

reinitialize eggcups
reinitialize gnome-volume-manager 
(dialog boxes)
Comment 42 Kyriakos Sidiropoulos 2005-01-14 06:20:40 EST
I just tested prelink-0.3.3-1. Running /etc/cron.daily/prelink didn't
do the trick. Hald keeps on failing to start. Hmmmmm ...

Note You need to log in before you can comment on or make changes to this bug.