Bug 1414438

Summary: the s3 storage registry driver does not include the AWS ca-central-1 region
Product: OpenShift Container Platform Reporter: Michal Fojtik <mfojtik>
Component: Image RegistryAssignee: Michal Fojtik <mfojtik>
Status: CLOSED ERRATA QA Contact: zhou ying <yinzhou>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 3.4.0CC: aos-bugs, dyocum, miminar, tdawson, twiest, wsun
Target Milestone: ---   
Target Release: 3.3.1   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1412367 Environment:
Last Closed: 2017-02-22 18:11:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1412367, 1414439    
Bug Blocks:    

Comment 2 zhou ying 2017-02-03 06:56:50 UTC
Confirmed with the latest OCP3.3.1 , the issue has fixed:
openshift version
openshift v3.3.1.12
kubernetes v1.3.0+52492b4
etcd 2.3.0+git


[root@ip-172-18-5-234 origin]# oc get po 
NAME                       READY     STATUS    RESTARTS   AGE
docker-registry-3-5quy4    1/1       Running   0          3m
registry-console-1-2ga3s   1/1       Running   0          17m
router-1-sl4t2             1/1       Running   0          17m


[root@ip-172-18-5-234 origin]# oc exec -it docker-registry-3-5quy4 more /etc/registry/config.yml
version: 0.1
log:
  level: debug
http:
  addr: :5000
storage:
  delete:
    enabled: true
  cache:
    blobdescriptor: inmemory
  s3:
    accesskey: xxxxxx
    secretkey: yyyyyy
    region: ca-central-1
    bucket: xyxhyxxxxxxxx

Comment 4 errata-xmlrpc 2017-02-22 18:11:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0289