Bug 1412367 - the s3 storage registry driver does not include the AWS ca-central-1 region
Summary: the s3 storage registry driver does not include the AWS ca-central-1 region
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 3.3.0
Hardware: All
OS: All
urgent
urgent
Target Milestone: ---
: 3.3.1
Assignee: Michal Fojtik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks: 1414438 1414439
TreeView+ depends on / blocked
 
Reported: 2017-01-11 21:06 UTC by Dan Yocum
Modified: 2017-02-22 18:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1414438 1414439 (view as bug list)
Environment:
Last Closed: 2017-02-22 18:10:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0289 0 normal SHIPPED_LIVE OpenShift Container Platform 3.4.1.7, 3.3.1.14, and 3.2.1.26 bug fix update 2017-02-22 23:10:04 UTC

Description Dan Yocum 2017-01-11 21:06:23 UTC
Description of problem:

The https://github.com/docker/distribution/blob/master/registry/storage/driver/s3-aws/s3.go#L103

does not contain support for the ca-central-1 region, preventing us from deploying OpenShift in that AWS region.


Version-Release number of selected component (if applicable):

3.3.1.9

How reproducible:

Always.

Steps to Reproduce:
1. Attempt to deploy OSDE in ca-central-1
2. Fail
3.

Comment 2 Michal Minar 2017-01-12 07:54:17 UTC
Upstream PR: https://github.com/docker/distribution/pull/2140
Kudos to @mfojtik
Origin issue: https://github.com/openshift/origin/issues/12454

Comment 3 Michal Fojtik 2017-01-12 09:52:26 UTC
It is not enough as it seems we have to bump aws dependency (or have carry patch that adds this endpoint, but I don't really like that).

Comment 8 errata-xmlrpc 2017-02-22 18:10:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0289


Note You need to log in before you can comment on or make changes to this bug.