Bug 1414439 - the s3 storage registry driver does not include the AWS ca-central-1 region
Summary: the s3 storage registry driver does not include the AWS ca-central-1 region
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 3.4.1
Hardware: All
OS: All
urgent
urgent
Target Milestone: ---
: 3.4.z
Assignee: Michal Fojtik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1412367
Blocks: 1414438
TreeView+ depends on / blocked
 
Reported: 2017-01-18 14:01 UTC by Michal Fojtik
Modified: 2017-02-22 18:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1412367
Environment:
Last Closed: 2017-02-22 18:11:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0289 0 normal SHIPPED_LIVE OpenShift Container Platform 3.4.1.7, 3.3.1.14, and 3.2.1.26 bug fix update 2017-02-22 23:10:04 UTC

Comment 2 zhou ying 2017-02-03 07:32:47 UTC
Confirmed with the latest OCP 3.4.1.2, the issue has fixed:
openshift version
openshift v3.4.1.2
kubernetes v1.4.0+776c994
etcd 3.1.0-rc.0


[root@ip-172-18-12-94 origin]# oc get po 
NAME                       READY     STATUS    RESTARTS   AGE
docker-registry-3-qcgjd    1/1       Running   0          2m
registry-console-1-2sic9   1/1       Running   0          10m
router-1-o8xr9             1/1       Running   0          10m
[root@ip-172-18-12-94 origin]# oc exec -it docker-registry-3-qcgjd more /etc/registry/config.yml
version: 0.1
log:
  level: debug
http:
  addr: :5000
storage:
  delete:
    enabled: true
  cache:
    blobdescriptor: inmemory
  s3:
    accesskey: xxxxxxx
    secretkey: yyyyyyyyy
    region: ca-central-1
    bucket: zzzzzzzzz
    encrypt: false

Comment 4 errata-xmlrpc 2017-02-22 18:11:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0289


Note You need to log in before you can comment on or make changes to this bug.