Bug 1416408

Summary: Impossible to open a condition from a condition list
Product: Red Hat CloudForms Management Engine Reporter: Dmitry Misharov <dmisharo>
Component: UI - OPSAssignee: Nimrod Shneor <nshneor>
Status: CLOSED CURRENTRELEASE QA Contact: Einat Pacifici <epacific>
Severity: low Docs Contact:
Priority: medium    
Version: 5.7.0CC: dajohnso, fsimonce, hkataria, jhardy, mpovolny, obarenbo
Target Milestone: GAKeywords: TestOnly, ZStream
Target Release: 5.8.0   
Hardware: All   
OS: All   
Whiteboard: control:container:ui:condition
Fixed In Version: 5.8.0.0 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1417762 (view as bug list) Environment:
Last Closed: 2017-06-12 16:38:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Container Management Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1417762    

Description Dmitry Misharov 2017-01-25 12:46:31 UTC
Description of problem:
Container conditions cannot be opened from conditions list in the right screen.

Version-Release number of selected component (if applicable):
5.7.1.0.20170124142149_8a5f4d5

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Control->Explorer.
2. Expand Conditions accordion.
3. Create a Replicator Condition, Pod Condition, Container Node Condition or Container Image Condition.
4. Click on the Replicator Condition, Pod Condition, Container Node Condition or Container Image Condition node to list all available conditions for that type.
5. Click on some condition in the right screen.

Actual results:
Nothing happened.

Expected results:
A condition details should be opened.

Additional info:
Host and VM conditions are opened fine.

Comment 2 Harpreet Kataria 2017-01-25 15:43:38 UTC
Federico,

Is this issue similar to https://bugzilla.redhat.com/show_bug.cgi?id=1404469. Can you please have someone look into it.

Thanks,
~Harpreet

Comment 3 Federico Simoncelli 2017-01-26 08:49:53 UTC
Possible duplicate of bug 1404469

Comment 4 Federico Simoncelli 2017-01-27 14:07:44 UTC
https://github.com/ManageIQ/manageiq-ui-classic/pull/256

Comment 6 Einat Pacifici 2017-03-14 12:45:29 UTC
Varified. 
I added two new Pod conditions. Saved and was able to expand the list and view the newly created conditions.