Bug 1404469 - Clicking on the Policy Event link doesn't take you to the event page
Summary: Clicking on the Policy Event link doesn't take you to the event page
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.8.0
Assignee: Nimrod Shneor
QA Contact: Einat Pacifici
URL:
Whiteboard: container:control:ui
Depends On:
Blocks: 1417779
TreeView+ depends on / blocked
 
Reported: 2016-12-13 22:31 UTC by Nandini Chandra
Modified: 2018-04-17 08:27 UTC (History)
6 users (show)

Fixed In Version: 5.8.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1417779 (view as bug list)
Environment:
Last Closed: 2017-06-12 16:15:04 UTC
Category: ---
Cloudforms Team: Container Management
Target Upstream Version:


Attachments (Terms of Use)

Description Nandini Chandra 2016-12-13 22:31:49 UTC
Description of problem:
-----------------------


Version-Release number of selected component (if applicable):
--------------------------------------------------------------
5.7.0.14


How reproducible:
-----------------
Always


Steps to Reproduce:
-------------------
1.Navigate to the Control -> Explorer page.
2.From the 'Events' accordion, click any event already assigned to a Control Policy.Eg: Click the "Container Image Analysis Complete" event.Click the policy link in the 'Assigned to Policies' section.
3.On the Policy page, click the Events link


Actual results:
--------------
Clicking on the Policy Event link doesn't take you to the event page.


Expected results:
----------------
Clicking on the Policy Event link should take you to the event page.


Additional info:
---------------

Comment 2 Harpreet Kataria 2017-01-10 23:11:31 UTC
Federico,

Issue here is that the Policy node id is incorrect in the transaction when pressing link to Policy from Event Summary screen in Events accordion.

see samples of 2 transactions below, one with incorrect id and second one with the correct id and is working

Id is incorrect when link to Policy is clicked from an Event summary screen from Events accordion
[----] I, [2017-01-10T17:56:52.575600 #6954:4f14e48]  INFO -- :   Parameters: {"authenticity_token"=>"Aqxg5GsCjxVwCCEqXvKkoB3B0OtfKsnKMfEPvQ1AkN/hgCe3PQXF55zgu4hwmPMI0Vm4cLgJWYoYn7cN50sKEQ==", "accord"=>"policy", "id"=>"xx-compliance_xx-compliance-containerimage_p-10r1"}

Correct id is passed in when Policy node in the tree is selected
[----] I, [2017-01-10T17:58:33.966403 #6954:4f14f10]  INFO -- : Started POST "/miq_policy/tree_select/?id=xx-compliance_xx-compliance-containerImage_p-10r1" for ::1 at 2017-01-10 17:58:33 -0500

Notice the camelcase in both id in transactions above: xx-compliance_xx-compliance-containerimage_p-10r1 vs. xx-compliance_xx-compliance-containerImage_p-10r1

This issue is only happening for Container Image specific events and most likely also for Container Node events as well. Can someone on your team look into this.
Let me know if you have questions.

Thanks,
~Harpreet

Comment 3 Federico Simoncelli 2017-01-26 08:50:33 UTC
Please note that bug 1416408 could be a duplicate of this BZ.

Comment 4 Federico Simoncelli 2017-01-26 15:28:46 UTC
Dmitry can you add more details on why you think this is core?

Comment 5 Federico Simoncelli 2017-01-27 14:07:52 UTC
https://github.com/ManageIQ/manageiq-ui-classic/pull/256

Comment 7 Pavel Zagalsky 2017-03-07 14:54:21 UTC
Verified on 5.8


Note You need to log in before you can comment on or make changes to this bug.