Bug 1429402

Summary: Restore atime/mtime for symlinks and other non-regular files.
Product: [Community] GlusterFS Reporter: Ravishankar N <ravishankar>
Component: replicateAssignee: Ravishankar N <ravishankar>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 3.10CC: bugs
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: glusterfs-3.10.1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1429198
: 1436673 (view as bug list) Environment:
Last Closed: 2017-04-05 00:01:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1429198, 1429405    
Bug Blocks: 1414456, 1436673    

Description Ravishankar N 2017-03-06 10:08:04 UTC
+++ This bug was initially created as a clone of Bug #1429198 +++

AFR restores atime/mtime only as a part of data heal. For non-regular
    files (dirs, symlinks, char/block/socket files etc) which do not undergo
    data-heal, atime/mtime is not restored.

--- Additional comment from Worker Ant on 2017-03-05 10:26:39 EST ---

REVIEW: https://review.gluster.org/16844 (afr: restore atime/mtime for non-regular files) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Worker Ant on 2017-03-06 00:15:46 EST ---

REVIEW: https://review.gluster.org/16844 (afr: restore atime/mtime for non-regular files) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Worker Ant on 2017-03-06 05:01:52 EST ---

COMMIT: https://review.gluster.org/16844 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 804a65f07ea8e2093f781807651d0d07513b2627
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Sat Mar 4 01:04:10 2017 +0530

    afr: restore atime/mtime for non-regular files
    
    AFR restores atime/mtime only as a part of data heal. For non-regular
    files (dirs, symlinks, char/block/socket files etc) which do not undergo
    data-heal, atime/mtime is not restored.
    
    This patch restores atime/mtime as a part of metadata heal for such
    files.
    
    Change-Id: Id8da885fc93fdf65c2f4bae2af3605b146ac1f16
    BUG: 1429198
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: https://review.gluster.org/16844
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 1 Worker Ant 2017-03-06 10:10:22 UTC
REVIEW: https://review.gluster.org/16851 (afr: restore atime/mtime for non-regular files) posted (#1) for review on release-3.10 by Ravishankar N (ravishankar@redhat.com)

Comment 2 Worker Ant 2017-03-06 15:45:51 UTC
COMMIT: https://review.gluster.org/16851 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit e46cb08e9d381c46277631fa266751cd63f3823c
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Sat Mar 4 01:04:10 2017 +0530

    afr: restore atime/mtime for non-regular files
    
    AFR restores atime/mtime only as a part of data heal. For non-regular
    files (dirs, symlinks, char/block/socket files etc) which do not undergo
    data-heal, atime/mtime is not restored.
    
    This patch restores atime/mtime as a part of metadata heal for such
    files.
    
    > Reviewed-on: https://review.gluster.org/16844
    > Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    > Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    (cherry picked from commit 804a65f07ea8e2093f781807651d0d07513b2627)
    
    Change-Id: Id8da885fc93fdf65c2f4bae2af3605b146ac1f16
    BUG: 1429402
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: https://review.gluster.org/16851
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 3 Shyamsundar 2017-04-05 00:01:42 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.1, please open a new bug report.

glusterfs-3.10.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-April/030494.html
[2] https://www.gluster.org/pipermail/gluster-users/