Bug 1429405 - Restore atime/mtime for symlinks and other non-regular files.
Summary: Restore atime/mtime for symlinks and other non-regular files.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 3.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On: 1429198
Blocks: 1414456 1429402 1436673
TreeView+ depends on / blocked
 
Reported: 2017-03-06 10:12 UTC by Ravishankar N
Modified: 2017-03-28 12:21 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8.10
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1429198
Environment:
Last Closed: 2017-03-18 10:52:58 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ravishankar N 2017-03-06 10:12:19 UTC
+++ This bug was initially created as a clone of Bug #1429198 +++

AFR restores atime/mtime only as a part of data heal. For non-regular
    files (dirs, symlinks, char/block/socket files etc) which do not undergo
    data-heal, atime/mtime is not restored.

--- Additional comment from Worker Ant on 2017-03-05 10:26:39 EST ---

REVIEW: https://review.gluster.org/16844 (afr: restore atime/mtime for non-regular files) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Worker Ant on 2017-03-06 00:15:46 EST ---

REVIEW: https://review.gluster.org/16844 (afr: restore atime/mtime for non-regular files) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Worker Ant on 2017-03-06 05:01:52 EST ---

COMMIT: https://review.gluster.org/16844 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 804a65f07ea8e2093f781807651d0d07513b2627
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Sat Mar 4 01:04:10 2017 +0530

    afr: restore atime/mtime for non-regular files
    
    AFR restores atime/mtime only as a part of data heal. For non-regular
    files (dirs, symlinks, char/block/socket files etc) which do not undergo
    data-heal, atime/mtime is not restored.
    
    This patch restores atime/mtime as a part of metadata heal for such
    files.
    
    Change-Id: Id8da885fc93fdf65c2f4bae2af3605b146ac1f16
    BUG: 1429198
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: https://review.gluster.org/16844
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 1 Worker Ant 2017-03-06 10:14:40 UTC
REVIEW: https://review.gluster.org/16852 (afr: restore atime/mtime for non-regular files) posted (#1) for review on release-3.8 by Ravishankar N (ravishankar@redhat.com)

Comment 2 Worker Ant 2017-03-10 23:14:13 UTC
COMMIT: https://review.gluster.org/16852 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit a671a19d660dabad4292a2fbb190ee26a13a1532
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Sat Mar 4 01:04:10 2017 +0530

    afr: restore atime/mtime for non-regular files
    
    AFR restores atime/mtime only as a part of data heal. For non-regular
    files (dirs, symlinks, char/block/socket files etc) which do not undergo
    data-heal, atime/mtime is not restored.
    
    This patch restores atime/mtime as a part of metadata heal for such
    files.
    
    > Reviewed-on: https://review.gluster.org/16844
    > Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    > Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    (cherry picked from commit 804a65f07ea8e2093f781807651d0d07513b2627)
    
    Change-Id: Id8da885fc93fdf65c2f4bae2af3605b146ac1f16
    BUG: 1429405
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: https://review.gluster.org/16852
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 3 Niels de Vos 2017-03-18 10:52:58 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.10, please open a new bug report.

glusterfs-3.8.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-March/000068.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.