Bug 1429198 - Restore atime/mtime for symlinks and other non-regular files.
Summary: Restore atime/mtime for symlinks and other non-regular files.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1414456 1429402 1429405 1436673
TreeView+ depends on / blocked
 
Reported: 2017-03-05 15:24 UTC by Ravishankar N
Modified: 2017-05-30 18:46 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1429402 1429405 (view as bug list)
Environment:
Last Closed: 2017-05-30 18:46:48 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ravishankar N 2017-03-05 15:24:47 UTC
AFR restores atime/mtime only as a part of data heal. For non-regular
    files (dirs, symlinks, char/block/socket files etc) which do not undergo
    data-heal, atime/mtime is not restored.

Comment 1 Worker Ant 2017-03-05 15:26:39 UTC
REVIEW: https://review.gluster.org/16844 (afr: restore atime/mtime for non-regular files) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 2 Worker Ant 2017-03-06 05:15:46 UTC
REVIEW: https://review.gluster.org/16844 (afr: restore atime/mtime for non-regular files) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 3 Worker Ant 2017-03-06 10:01:52 UTC
COMMIT: https://review.gluster.org/16844 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 804a65f07ea8e2093f781807651d0d07513b2627
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Sat Mar 4 01:04:10 2017 +0530

    afr: restore atime/mtime for non-regular files
    
    AFR restores atime/mtime only as a part of data heal. For non-regular
    files (dirs, symlinks, char/block/socket files etc) which do not undergo
    data-heal, atime/mtime is not restored.
    
    This patch restores atime/mtime as a part of metadata heal for such
    files.
    
    Change-Id: Id8da885fc93fdf65c2f4bae2af3605b146ac1f16
    BUG: 1429198
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: https://review.gluster.org/16844
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 4 Shyamsundar 2017-05-30 18:46:48 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.