Bug 1435609

Summary: OSP10 -> OSP11 upgrade: instances live migration gets stuck before starting compute upgrade
Product: Red Hat OpenStack Reporter: Marius Cornea <mcornea>
Component: openstack-tripleo-heat-templatesAssignee: Sofer Athlan-Guyot <sathlang>
Status: CLOSED ERRATA QA Contact: Marius Cornea <mcornea>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 11.0 (Ocata)CC: dbecker, jcoufal, jschluet, mburns, morazi, rhel-osp-director-maint, sathlang
Target Milestone: rcKeywords: Triaged
Target Release: 11.0 (Ocata)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-6.0.0-0.10.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-17 20:13:27 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1394019    

Description Marius Cornea 2017-03-24 11:19:20 UTC
Description of problem:
OSP10 -> OSP11 upgrade: instances live migration gets stuck before starting compute upgrade. 

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.0.0-0.3.0rc2.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP10 with 3 controllers, 2 compute nodes, 3 ceph storage nodes
2. Launch Nova instances on overcloud
3. Start OSP11 upgrade procedure
4. Before upgrading 1st compute node live migrate all instances that are hosted by the node 

Actual results:
Instances gets stuck with MIGRATING status:

+--------------------------------------+-------------------------------------------------------+-----------+------------+-------------+---------------------------------------------------------------------------│
-------------------------+                                                                                                                                                                                        │
| ID                                   | Name                                                  | Status    | Task State | Power State | Networks                                                                  │
                         |                                                                                                                                                                                        │
+--------------------------------------+-------------------------------------------------------+-----------+------------+-------------+---------------------------------------------------------------------------│
-------------------------+                                                                                                                                                                                        │
| 65a9bb75-b90b-4e36-b175-941403a02aab | st--ba-instance-hdad4xr725fv-my_instance-a5ggs37nh4bu | MIGRATING | migrating  | Running     | stack-ba-tenant_net_ext_tagged-b6ttm4vqbjes-private_network-4h5khjqmzhma=1│


Expected results:
Instances get live migrated to a different host.

Additional info:
It looks that we are doing the nova placement configuration on the compute nodes before the compute nodes have been upgraded:
https://github.com/openstack/tripleo-heat-templates/blob/master/puppet/major_upgrade_steps.j2.yaml#L60-L68

Comment 1 Sofer Athlan-Guyot 2017-03-27 09:41:30 UTC
Change to ocata branch.

Comment 4 errata-xmlrpc 2017-05-17 20:13:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245