Bug 1435609 - OSP10 -> OSP11 upgrade: instances live migration gets stuck before starting compute upgrade
Summary: OSP10 -> OSP11 upgrade: instances live migration gets stuck before starting c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Sofer Athlan-Guyot
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks: 1394019
TreeView+ depends on / blocked
 
Reported: 2017-03-24 11:19 UTC by Marius Cornea
Modified: 2017-05-17 20:13 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-0.10.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:13:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 450142 None None None 2017-03-27 09:41:30 UTC
Launchpad 1675739 None None None 2017-03-24 11:45:50 UTC

Description Marius Cornea 2017-03-24 11:19:20 UTC
Description of problem:
OSP10 -> OSP11 upgrade: instances live migration gets stuck before starting compute upgrade. 

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.0.0-0.3.0rc2.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP10 with 3 controllers, 2 compute nodes, 3 ceph storage nodes
2. Launch Nova instances on overcloud
3. Start OSP11 upgrade procedure
4. Before upgrading 1st compute node live migrate all instances that are hosted by the node 

Actual results:
Instances gets stuck with MIGRATING status:

+--------------------------------------+-------------------------------------------------------+-----------+------------+-------------+---------------------------------------------------------------------------│
-------------------------+                                                                                                                                                                                        │
| ID                                   | Name                                                  | Status    | Task State | Power State | Networks                                                                  │
                         |                                                                                                                                                                                        │
+--------------------------------------+-------------------------------------------------------+-----------+------------+-------------+---------------------------------------------------------------------------│
-------------------------+                                                                                                                                                                                        │
| 65a9bb75-b90b-4e36-b175-941403a02aab | st--ba-instance-hdad4xr725fv-my_instance-a5ggs37nh4bu | MIGRATING | migrating  | Running     | stack-ba-tenant_net_ext_tagged-b6ttm4vqbjes-private_network-4h5khjqmzhma=1│


Expected results:
Instances get live migrated to a different host.

Additional info:
It looks that we are doing the nova placement configuration on the compute nodes before the compute nodes have been upgraded:
https://github.com/openstack/tripleo-heat-templates/blob/master/puppet/major_upgrade_steps.j2.yaml#L60-L68

Comment 1 Sofer Athlan-Guyot 2017-03-27 09:41:30 UTC
Change to ocata branch.

Comment 4 errata-xmlrpc 2017-05-17 20:13:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.