Bug 1394019 - [RFE] Composable upgrades
Summary: [RFE] Composable upgrades
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: Upstream M3
: 11.0 (Ocata)
Assignee: Emilien Macchi
QA Contact: Marius Cornea
URL: https://blueprints.launchpad.net/trip...
Whiteboard: upstream_milestone_ocata-rc1 upstream...
: 1337799 (view as bug list)
Depends On: 1416356 1430384 1432879 1434955 1435609 1436794
Blocks: 1337800 1426492
TreeView+ depends on / blocked
 
Reported: 2016-11-10 20:28 UTC by Jaromir Coufal
Modified: 2017-05-17 19:45 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-0.6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:45:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Jaromir Coufal 2016-11-10 20:28:02 UTC

Comment 1 Jaromir Coufal 2016-11-10 20:31:17 UTC
USER STORIES:

* As a cloud operator, I want to be able to upgrade my cloud with custom roles with minimal service/workload interruption so that I can keep my cloud up-to-date and keep my SLA.

* As a cloud operator, I want to have possibility to define what roles are going to be upgraded so that I can minimize service downtime. (understanding some limitations like "control plane services need to be upgraded at the same time")

* As a cloud operator, I want to be able to upgrade in steps and keep operational cloud in-between steps so that I can mitigate risks and minimize service downtime.

* As an OpenStack developer, I want to have full control on my service deployment & lifecycle management scripts and plug it into the framework so that I can independently maintain the code.

Comment 2 Jaromir Coufal 2016-11-10 20:31:53 UTC
*** Bug 1337799 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2017-05-17 19:45:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.