Bug 1490260

Summary: Backport JDK-8180048: Interned strings not even garbage collected with full gc using G1
Product: Red Hat Enterprise Linux 7 Reporter: Osamu Nagano <onagano>
Component: java-1.8.0-openjdkAssignee: Andrew John Hughes <ahughes>
Status: CLOSED ERRATA QA Contact: Lukáš Zachar <lzachar>
Severity: high Docs Contact:
Priority: urgent    
Version: 7.4CC: ahughes, alanm, bodavis, dbhole, fkrska, jreznik, jvanek, mkolaja, onagano, qe-baseos-apps
Target Milestone: rcKeywords: ZStream
Target Release: ---Flags: fkrska: needinfo? (dbhole)
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: java-1.8.0-openjdk-1.8.0.151-3.b12.el7 Doc Type: If docs needed, set a value
Doc Text:
Prior to this update, the Java Virtual Machine (JVM) G1 garbage collector did not collect interned strings. As a consequence, the JVM sometimes terminated unexpectedly due to running out of memory when using large heaps. With this update, the garbage collector has been fixed to collect interned strings properly. As a result, the JVM no longer crashes due to this bug.
Story Points: ---
Clone Of: 1449870
: 1515212 (view as bug list) Environment:
Last Closed: 2018-04-10 15:50:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1449870    
Bug Blocks: 1468473, 1515212    

Comment 8 errata-xmlrpc 2018-04-10 15:50:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0872