Bug 1449870 - Backport JDK-8180048: Interned strings not even garbage collected with full gc using G1
Backport JDK-8180048: Interned strings not even garbage collected with full g...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.8.0-openjdk (Show other bugs)
6.8
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Andrew John Hughes
zzambers
: ZStream
Depends On:
Blocks: 1468473 1490260
  Show dependency treegraph
 
Reported: 2017-05-10 22:47 EDT by Osamu Nagano
Modified: 2018-06-21 04:45 EDT (History)
8 users (show)

See Also:
Fixed In Version: java-1.8.0-openjdk-1.8.0.131-2.b11.el6
Doc Type: If docs needed, set a value
Doc Text:
Prior to this update, the Java Virtual Machine (JVM) G1 garbage collector did not collect interned strings. As a consequence, the JVM sometimes terminated unexpectedly due to running out of memory when using large heaps. With this update, the garbage collector has been fixed to collect interned strings properly. As a result, the JVM no longer crashes due to this bug.
Story Points: ---
Clone Of:
: 1468473 1490260 (view as bug list)
Environment:
Last Closed: 2018-06-21 04:45:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Icedtea Bugzilla 3411 None None None 2017-06-27 21:52 EDT
openjdk bug system JDK-8180048 None None None 2017-05-10 22:47 EDT

  None (edit)
Description Osamu Nagano 2017-05-10 22:47:10 EDT
A customer hit the issue of JDK-8180048, in which interned strings are not garbage collected with G1 and resulting OOME in native area. The bug is still in progress as of 2017-05-11.
Comment 2 Andrew John Hughes 2017-05-16 12:57:11 EDT
rhel-6.9 has been released so setting to rhel-6.10.0?
Comment 3 Osamu Nagano 2017-05-16 20:07:10 EDT
Right, the flag is rhel-6.10.0.
Comment 12 Andrew John Hughes 2017-07-04 22:17:45 EDT
Backport is complete and in RHEL 6.10. Waiting on approval for z-stream.
Comment 14 Osamu Nagano 2017-09-06 21:10:55 EDT
Thanks. I got the fixed package on RHEL 6, which is build by bug #1468473.

BTW, I believe this ticket is for the next minor release of RHEL 6. Is the same fix to be included in the next minor release of RHEL 7 as well?
Comment 15 Andrew John Hughes 2017-09-20 11:54:57 EDT
It needs the same bug process. I see you've opened bug 1490260 now to kick start that. I'll start chasing acks.

Note You need to log in before you can comment on or make changes to this bug.