Bug 1468473 - Backport JDK-8180048: Interned strings not even garbage collected with full gc using G1
Backport JDK-8180048: Interned strings not even garbage collected with full g...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.8.0-openjdk (Show other bugs)
6.8
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Deepak Bhole
Lukas Zachar
: ZStream
Depends On: 1449870 1490260
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-07 04:11 EDT by Oneata Mircea Teodor
Modified: 2017-12-19 09:51 EST (History)
7 users (show)

See Also:
Fixed In Version: java-1.8.0-openjdk-1.8.0.141-3.b16.el6_9
Doc Type: If docs needed, set a value
Doc Text:
Prior to this update, the Java Virtual Machine (JVM) G1 garbage collector did not collect interned strings. As a consequence, the JVM sometimes terminated unexpectedly due to running out of memory when using large heaps. With this update, the garbage collector has been fixed to collect interned strings properly. As a result, the JVM no longer crashes due to this bug.
Story Points: ---
Clone Of: 1449870
Environment:
Last Closed: 2017-08-22 13:28:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Icedtea Bugzilla 3411 None None None 2017-07-07 04:11 EDT
openjdk bug system JDK-8180048 None None None 2017-07-07 04:11 EDT

  None (edit)
Description Oneata Mircea Teodor 2017-07-07 04:11:26 EDT
This bug has been copied from bug #1449870 and has been proposed to be backported to 6.9 z-stream (EUS).
Comment 8 errata-xmlrpc 2017-08-22 13:28:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2502

Note You need to log in before you can comment on or make changes to this bug.