Bug 1553935

Summary: Installer auto-quits after Workstation live install (as no spokes are on the install hub)
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: anacondaAssignee: Martin Kolman <mkolman>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 28CC: alciregi, anaconda-maint-list, bugzilla, gmarr, jonathan, kellin, lruzicka, mcatanzaro+wrong-account-do-not-cc, mclasen, mkolman, satellitgo, sumukher, vanmeeuwen+fedora, v.podzimek+fedora, vponcova, wwoods
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: AcceptedFreezeException
Fixed In Version: anaconda-28.22.2-4.fc28 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-06 19:37:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1469205    

Description Adam Williamson 2018-03-09 22:52:48 UTC
Back in 2013, in response to https://bugzilla.redhat.com/show_bug.cgi?id=963935 , behaviour was added to anaconda such that when a hub with no spokes is 'complete', the installer will proceed without any further interaction:

    def _update_spokes(self):
        from pyanaconda.ui.communication import hubQ
        import queue

        q = hubQ.q

        if not self._spokes and self.window.get_may_continue():
            # no spokes, move on
            log.debug("no spokes available on %s, continuing automatically", self)
            gtk_call_once(self.window.emit, "continue-clicked")

This was intended for initial-setup; the idea was to make initial-setup automatically quit if it wound up being run with no spokes (because user and root passwords were already set). Now, however, five years later, that's come back to bite us a bit, because of this feature:

https://fedoraproject.org/wiki/Changes/ReduceInitialSetupRedundancy

as part of that Change, the Workstation live installer no longer has any spokes on its install progress hub - both the user creation and root password spokes are suppressed. So even though install takes a long time, when it *does* complete, anaconda just auto-continues - which means it auto-quits, as this is the last hub. Basically, as soon as install completes, anaconda goes away and you're just left at a desktop.

Martin Kolman, Michael Catanzaro and I all agree that this probably isn't the best behaviour; users are likely to be confused and may assume that something went wrong, the installer crashed, etc. We believe that in this particular case - however it's achieved - anaconda should behave just as it does when there *are* spokes; it should print the "Installation complete" message and wait for the user to click Quit before actually quitting.

I'm proposing this as a Beta freeze exception, partly because it's a user-visible installer issue we can't fix with an update, but to be honest, *mainly* because making openQA work with this behaviour is actually quite difficult - if I can't figure out a decent way to do that, all openQA Workstation live install tests will fail, and the post-install tests that run from disk images created by the install test won't run.

Comment 1 Jiri Konecny 2018-03-12 10:31:21 UTC
*** Bug 1554072 has been marked as a duplicate of this bug. ***

Comment 2 Geoffrey Marr 2018-03-12 20:48:32 UTC
Discussed during the 2018-03-12 blocker review meeting: [1]

The decision to classify this bug as an AcceptedFreezeException was made as this could clearly confuse users installing Workstation live in Fedora 28 Beta, and as it can't be fixed with an update, we deem it worthy of an FE.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-03-12/f28-blocker-review.2018-03-12-16.01.txt

Comment 3 Chris Murphy 2018-03-13 22:53:08 UTC
The decision has already been made but I think because of the testing impact this is legitimately a blocker.

Comment 4 sumantro 2018-03-14 08:51:34 UTC
This can be reproduced on Fedora 28 Branched 20180310

Comment 5 Alessio 2018-03-15 05:29:32 UTC
This can be reproduced on Fedora 28 Branched 20180314.n.2

Comment 6 Martin Kolman 2018-03-15 16:46:20 UTC
PR: https://github.com/rhinstaller/anaconda/pull/1395

Comment 7 Fedora Update System 2018-03-15 18:48:11 UTC
anaconda-28.22.2-4.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5a9e9a1142

Comment 8 Fedora Update System 2018-03-16 14:46:24 UTC
anaconda-28.22.2-4.fc28, initial-setup-0.3.55-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5a9e9a1142

Comment 9 Fedora Update System 2018-03-20 04:42:38 UTC
anaconda-28.22.2-4.fc28, initial-setup-0.3.55-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Martin Kolman 2018-03-20 11:41:06 UTC
*** Bug 1558513 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2018-04-05 16:23:07 UTC
anaconda-28.22.3-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9fd9270cd5

Comment 12 Fedora Update System 2018-04-06 18:55:13 UTC
anaconda-28.22.3-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9fd9270cd5

Comment 13 Adam Williamson 2018-04-06 19:37:42 UTC
gah, stoppit, Bodhi.