Bug 1564826

Summary: NetworkManager can't establish L2TP connection
Product: [Fedora] Fedora Reporter: Erik Indresovde <erikindre>
Component: pppAssignee: Jaroslav Škarvada <jskarvad>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 28CC: alexl, bgalvani, dcbw, fgiudici, jaskalnik, john.j5live, jskarvad, jsynacek, lkundrak, mclasen, msekleta, rhughes, rstrode, sandmann, thaller, thozza
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-09 12:41:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Erik Indresovde 2018-04-08 03:58:00 UTC
Description of problem:
Network Manager can't establish L2TP connection, unable to load plugin pppol2tp.so. Any attempt to connect fails

april 07 23:46:32 fedora28-localdomain NetworkManager[935]: <info>  [1523159192.6188] vpn-connection[0x55613e472320,07b95c39-e801-4a88-927e-bed8633a43ba,"VPN 1",0]: VPN plugin: state changed: starting (3)
april 07 23:46:32 fedora28-localdomain NetworkManager[935]: xl2tpd[8677]: Not looking for kernel SAref support.
april 07 23:46:32 fedora28-localdomain NetworkManager[935]: xl2tpd[8677]: Using l2tp kernel support.
april 07 23:46:32 fedora28-localdomain NetworkManager[935]: xl2tpd[8677]: xl2tpd version xl2tpd-1.3.8 started on fedora28-localdomain PID:8677
april 07 23:46:32 fedora28-localdomain NetworkManager[935]: xl2tpd[8677]: Written by Mark Spencer, Copyright (C) 1998, Adtran, Inc.
april 07 23:46:32 fedora28-localdomain NetworkManager[935]: xl2tpd[8677]: Forked by Scott Balmos and David Stipp, (C) 2001
april 07 23:46:32 fedora28-localdomain NetworkManager[935]: xl2tpd[8677]: Inherited by Jeff McAdams, (C) 2002
april 07 23:46:32 fedora28-localdomain NetworkManager[935]: xl2tpd[8677]: Forked again by Xelerance (www.xelerance.com) (C) 2006-2016
april 07 23:46:32 fedora28-localdomain NetworkManager[935]: xl2tpd[8677]: Listening on IP address 0.0.0.0, port 1701
april 07 23:46:32 fedora28-localdomain NetworkManager[935]: xl2tpd[8677]: Connecting to host 185.101.32.32, port 1701
april 07 23:46:32 fedora28-localdomain NetworkManager[935]: xl2tpd[8677]: Connection established to 185.101.32.32, 1701.  Local: 49531, Remote: 47850 (ref=0/0).
april 07 23:46:32 fedora28-localdomain NetworkManager[935]: xl2tpd[8677]: Calling on tunnel 49531
april 07 23:46:33 fedora28-localdomain NetworkManager[935]: xl2tpd[8677]: Call established with 185.101.32.32, Local: 27668, Remote: 62681, Serial: 1 (ref=0/0)
april 07 23:46:33 fedora28-localdomain NetworkManager[935]: /usr/sbin/pppd: /usr/lib/../lib64/pppd/2.4.7/pppol2tp.so: undefined symbol: ip_up_notifier
april 07 23:46:33 fedora28-localdomain NetworkManager[935]: /usr/sbin/pppd: Couldn't load plugin pppol2tp.so
april 07 23:46:33 fedora28-localdomain pppd[8678]: /usr/lib/../lib64/pppd/2.4.7/pppol2tp.so: undefined symbol: ip_up_notifier
april 07 23:46:33 fedora28-localdomain pppd[8678]: Couldn't load plugin pppol2tp.so
april 07 23:46:33 fedora28-localdomain NetworkManager[935]: xl2tpd[8677]: child_handler : pppd exited for call 62681 with code 2
april 07 23:46:33 fedora28-localdomain NetworkManager[935]: xl2tpd[8677]: call_close: Call 27668 to 185.101.32.32 disconnected
april 07 23:46:33 fedora28-localdomain NetworkManager[935]: xl2tpd[8677]: get_call: can't find call 27668 in tunnel 49531
april 07 23:46:33 fedora28-localdomain NetworkManager[935]:  (ref=0/0)xl2tpd[8677]: get_call: can't find call 27668 in tunnel 49531
april 07 23:46:36 fedora28-localdomain NetworkManager[935]:  (ref=0/0)xl2tpd[8677]: get_call: can't find call 27668 in tunnel 49531
april 07 23:46:46 fedora28-localdomain NetworkManager[935]:  (ref=0/0)xl2tpd[8677]: death_handler: Fatal signal 15 received
april 07 23:46:46 fedora28-localdomain NetworkManager[935]: xl2tpd[8677]: Connection 47850 closed to 185.101.32.32, port 1701 (Server closing)

Comment 2 Jaroslav Škarvada 2018-04-09 12:41:13 UTC

*** This bug has been marked as a duplicate of bug 1564459 ***