Bug 1564459 - VPN connection fails. Journalctl is showing:pppd[13208]: /usr/lib64/pppd/2.4.7/nm-pptp-pppd-plugin.so: undefined symbol: ip_up_notifier
Summary: VPN connection fails. Journalctl is showing:pppd[13208]: /usr/lib64/pppd/2.4....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ppp
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1564655 1564656 1564826 1564904 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-06 10:53 UTC by Daniel
Modified: 2018-04-10 22:58 UTC (History)
12 users (show)

Fixed In Version: ppp-2.4.7-21 ppp-2.4.7-21.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 22:58:46 UTC
Type: Bug


Attachments (Terms of Use)

Description Daniel 2018-04-06 10:53:04 UTC
Description of problem:
pppd[13208]: Couldn't load plugin /usr/lib64/pppd/2.4.7/nm-pptp-pppd-plugin.so
Apr 06 13:41:56 pavitra-t570 pppd[13208]: /usr/lib64/pppd/2.4.7/nm-pptp-pppd-plugin.so: undefined symbol: ip_up_notifier


Version-Release number of selected component (if applicable):


How reproducible:
Boot to F28 and create a VPN pptp connection.

Steps to Reproduce:
1. Boot to F28
2. Install NetworkManager pptp plugins
3. Try to connect to VPN 

Actual results:
Fail immediately. 

Expected results:
To connect to VPN server

Additional info:
Saw it after upgrade from F27 to F28 Beta. Reproduced with boot to livecd iso.

Comment 1 Daniel 2018-04-06 10:56:03 UTC
pptp-1.10.0-3.fc28.x86_64
NetworkManager-pptp-1.2.6-1.fc28.x86_64
NetworkManager-pptp-gnome-1.2.6-1.fc28.x86_64
pptp-1.10.0-3.fc28.x86_64

Comment 2 Daniel 2018-04-06 10:56:33 UTC
ppp-2.4.7-19.fc28.x86_64

Comment 3 Thomas Haller 2018-04-06 11:13:30 UTC
maybe this is related to email "-z defs linker flag activated in Fedora rawhide"?

https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/JQQ66XJSIT2FGTK2YQY7AXMEH5IXMPUX/

Comment 4 Thomas Haller 2018-04-06 19:12:26 UTC
Probably related: https://bugzilla.redhat.com/show_bug.cgi?id=1563157#c7

Comment 5 Thomas Haller 2018-04-06 19:37:41 UTC
*** Bug 1564656 has been marked as a duplicate of this bug. ***

Comment 6 Jaroslav Škarvada 2018-04-09 12:33:28 UTC
*** Bug 1564655 has been marked as a duplicate of this bug. ***

Comment 7 Jaroslav Škarvada 2018-04-09 12:39:36 UTC
*** Bug 1564904 has been marked as a duplicate of this bug. ***

Comment 8 Jaroslav Škarvada 2018-04-09 12:41:13 UTC
*** Bug 1564826 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2018-04-09 13:14:03 UTC
ppp-2.4.7-21.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-d5ee177b23

Comment 10 Daniel 2018-04-09 13:21:52 UTC
ppp-2.4.7-21.fc28 fixing it for me. Successfully connected to VPN server.

Comment 11 Fedora Update System 2018-04-09 21:56:10 UTC
ppp-2.4.7-21.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-d5ee177b23

Comment 12 Erik Indresovde 2018-04-09 22:50:16 UTC
Not working for me. New error "Given FD for PPPoL2TP socket invalid"

april 09 18:46:17 fedora28 pppd[4915]: Plugin pppol2tp.so loaded.
april 09 18:46:17 fedora28 pppd[4915]: Given FD for PPPoL2TP socket invalid (Socket operation on non-socket)
april 09 18:46:17 fedora28 NetworkManager[945]: xl2tpd[4914]: child_handler : pppd exited for call 37794 with code 1
april 09 18:46:17 fedora28 NetworkManager[945]: xl2tpd[4914]: call_close: Call 18324 to 217.170.203.128 disconnected
april 09 18:46:17 fedora28 pppd[4915]: Exit.
april 09 18:46:17 fedora28 NetworkManager[945]: xl2tpd[4914]: get_call: can't find call 18324 in tunnel 28266
april 09 18:46:17 fedora28 NetworkManager[945]:  (ref=0/0)xl2tpd[4914]: get_call: can't find call 18324 in tunnel 28266
april 09 18:46:20 fedora28 NetworkManager[945]:  (ref=0/0)xl2tpd[4914]: get_call: can't find call 18324 in tunnel 28266
april 09 18:46:30 fedora28 NetworkManager[945]:  (ref=0/0)xl2tpd[4914]: death_handler: Fatal signal 15 received
april 09 18:46:30 fedora28 NetworkManager[945]: xl2tpd[4914]: Connection 21741 closed to 217.170.203.128, port 1701 (Server closing)

Comment 13 Erik Indresovde 2018-04-09 23:17:36 UTC
Setting SELINUX to permissive gets rid of the error and connection can be established. 

Found the following in ausearch:

type=AVC msg=audit(1523314447.297:358): avc:  denied  { getattr } for  pid=6450 comm="pppd" scontext=system_u:system_r:pppd_t:s0 tcontext=system_u:system_r:l2tpd_t:s0 tclass=pppox_socket permissive=1
type=AVC msg=audit(1523314447.297:359): avc:  denied  { getopt } for  pid=6450 comm="pppd" scontext=system_u:system_r:pppd_t:s0 tcontext=system_u:system_r:l2tpd_t:s0 tclass=pppox_socket permissive=1
type=AVC msg=audit(1523314447.318:360): avc:  denied  { ioctl } for  pid=6450 comm="pppd" path="socket:[77543]" dev="sockfs" ino=77543 ioctlcmd=0x7437 scontext=system_u:system_r:pppd_t:s0 tcontext=system_u:system_r:l2tpd_t:s0 tclass=pppox_socket permissive=1

Attempted adding a local policy, but unable to make it work

Comment 14 Fedora Update System 2018-04-10 22:58:46 UTC
ppp-2.4.7-21.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.