Bug 1563157 - ppp: Partial Fedora build flags injection
Summary: ppp: Partial Fedora build flags injection
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ppp
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1564598 (view as bug list)
Depends On:
Blocks: Fedora28BuildFlags
TreeView+ depends on / blocked
 
Reported: 2018-04-03 09:45 UTC by Florian Weimer
Modified: 2018-07-25 19:02 UTC (History)
8 users (show)

Fixed In Version: ppp-2.4.7-19.fc28 ppp-2.4.7-21.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 22:58:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Florian Weimer 2018-04-03 09:45:46 UTC
The binaries in ppp-2.4.7-18.fc28.x86_64 (/usr/sbin/chat, /usr/sbin/pppdump, …, /usr/lib64/pppd/2.4.7/minconn.so, …, /usr/lib64/pppd/2.4.7/winbind.so) have not been linked with the standard Fedora linker flags (LDFLAGS) from redhat-rpm-config.

Looking at the build log, there is no LDFLAGS processing at all in the makefile:

cc -o pppdump pppdump.o bsd-comp.o deflate.o zlib.o

See https://src.fedoraproject.org/rpms/redhat-rpm-config/blob/master/f/buildflags.md for information on RPM macros and environment variables provided by the build environment.

Comment 1 Fedora Update System 2018-04-04 09:52:55 UTC
ppp-2.4.7-19.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1c76f6986b

Comment 2 Fedora Update System 2018-04-04 18:36:39 UTC
ppp-2.4.7-19.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1c76f6986b

Comment 3 Florian Weimer 2018-04-05 08:00:09 UTC
Sorry, but in ppp-2.4.7-19.fc28.x86_64, LDFLAGS are still missing from the invocation of the linker for the plug-ins, for example:

cc -o rp-pppoe.so -shared plugin.o discovery.o if.o common.o

Comment 4 Fedora Update System 2018-04-06 11:09:30 UTC
ppp-2.4.7-19.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Jaroslav Škarvada 2018-04-06 12:14:01 UTC
(In reply to Florian Weimer from comment #3)
> Sorry, but in ppp-2.4.7-19.fc28.x86_64, LDFLAGS are still missing from the
> invocation of the linker for the plug-ins, for example:
> 
> cc -o rp-pppoe.so -shared plugin.o discovery.o if.o common.o

Thanks for testing, new version ppp-2.4.7-20 should fix it.

Comment 6 Fedora Update System 2018-04-06 12:31:03 UTC
ppp-2.4.7-20.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-bee1f20ab4

Comment 7 Thomas Haller 2018-04-06 19:10:39 UTC
Now:


$ LD_DEBUG=all LD_BIND_NOW=1 LD_PRELOAD=/usr/lib64/pppd/2.4.7/nm-pptp-pppd-plugin.so /usr/sbin/pppd --help
...
    4609:     relocation processing: /usr/lib64/pppd/2.4.7/nm-pptp-pppd-plugin.so
    4609:     symbol=ip_up_notifier;  lookup in file=/usr/sbin/pppd [0]
    4609:     symbol=ip_up_notifier;  lookup in file=/usr/lib64/pppd/2.4.7/nm-pptp-pppd-plugin.so [0]
    4609:     symbol=ip_up_notifier;  lookup in file=/lib64/libudev.so.1 [0]
...
    4609:     symbol=ip_up_notifier;  lookup in file=/lib64/libpcre2-8.so.0 [0]
    4609:     /usr/lib64/pppd/2.4.7/nm-pptp-pppd-plugin.so: error: symbol lookup error: undefined symbol: ip_up_notifier (fatal)
/usr/sbin/pppd: symbol lookup error: /usr/lib64/pppd/2.4.7/nm-pptp-pppd-plugin.so: undefined symbol: ip_up_notifier



with NetworkManager-pptp-1.2.6-1.fc28.x86_64.
It works against ppp-2.4.7-18.fc28.x86_64, but fails against -19 and -20.



See
- https://bugzilla.redhat.com/show_bug.cgi?id=1564459
- https://bugzilla.redhat.com/show_bug.cgi?id=1564598


Florian, do you know what's the problem?

Comment 8 Florian Weimer 2018-04-07 15:52:09 UTC
The daemon program is no longer linked with -Wl,-E for some reason, which prevents exports of the symbols used by the plug-ins.  The Fedora build flags are compatbible with -Wl,-E, it's just that the ppp makefile no longer passes the flag.

Comment 9 Fedora Update System 2018-04-08 00:02:55 UTC
ppp-2.4.7-20.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-bee1f20ab4

Comment 10 Fedora Update System 2018-04-09 13:14:15 UTC
ppp-2.4.7-21.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-d5ee177b23

Comment 11 Fedora Update System 2018-04-09 21:56:17 UTC
ppp-2.4.7-21.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-d5ee177b23

Comment 12 Fedora Update System 2018-04-10 22:58:53 UTC
ppp-2.4.7-21.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Eduardo Garcia 2018-07-25 19:02:11 UTC
*** Bug 1564598 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.