Bug 1566200

Summary: Candlepin fails install with postgresql 9.6
Product: [Community] Candlepin Reporter: John Mitsch <jomitsch>
Component: candlepinAssignee: candlepin-bugs
Status: CLOSED CURRENTRELEASE QA Contact: Katello QA List <katello-qa-list>
Severity: high Docs Contact:
Priority: high    
Version: 2.1CC: bcourt, egolov, khowell, mstead, redakkan, skallesh
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-20 14:43:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1547424, 1572682    
Bug Blocks:    

Description John Mitsch 2018-04-11 18:37:57 UTC
Description of problem:
related to Katello issue http://projects.theforeman.org/issues/23192

Candlepin is not installing correctly on a system with postgresql 9.6.

According to our irc chat, candlepin would need to upgrade liquibase 2.5.3 or better to support postgres 9.6

Version-Release number of selected component (if applicable):

candlepin-2.1.14-1.el7.noarch
foreman-1.18.0-0.develop.201804061848git210e295.el7.noarch
katello-3.7.0-1.nightly.el7.noarch


How reproducible:
Always

Steps to Reproduce:
1.Install candlepin with postgres 9.6
2.
3.

Actual results:
Install fails

Expected results:
Install succeeds with 9.6

Additional info:

Comment 1 Evgeni Golov 2018-04-13 06:39:08 UTC
According to my own tests, getting a fresh enough postgresql-jdbc would be enough, and I had opened https://bugzilla.redhat.com/show_bug.cgi?id=1547424 in RHEL for that.

Comment 2 Evgeni Golov 2018-05-17 07:55:45 UTC
FYI, https://bugzilla.redhat.com/show_bug.cgi?id=1547424 will be fixed in 7.6 (and also available in 7.5.z via https://bugzilla.redhat.com/show_bug.cgi?id=1572682), so I'd expect candlepin to work with PostgreSQL 9.6 now.

Comment 4 Barnaby Court 2019-09-20 14:43:32 UTC
Due to lack of response for comment 2 I am closing this BZ. Please re-open if it is still a concern.

Comment 5 Evgeni Golov 2019-11-11 07:40:12 UTC
This seems to have fixed it btw, sorry that I forgot to reply here.