Bug 1547424 - postgresql-jdbc not compatible with PostgreSQL 9.6
Summary: postgresql-jdbc not compatible with PostgreSQL 9.6
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: postgresql-jdbc
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Raiskup
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 1566200 1572682
TreeView+ depends on / blocked
 
Reported: 2018-02-21 10:30 UTC by Evgeni Golov
Modified: 2018-10-30 15:44 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the postgresql-jdbc connector did not work correctly with PostgreSQL servers of versions 9.6 or later. This update fixes the problem, and the connector now works as expected even with more recent PostgreSQL servers.
Clone Of:
: 1572682 (view as bug list)
Environment:
Last Closed: 2018-10-30 15:44:15 UTC
Target Upstream Version:
toneata: needinfo-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHPAM-740 0 Critical Verified Kie server with PostgreSQL 9.6 fails when its pod is restarted 2020-07-23 13:37:59 UTC

Internal Links: 1687598

Description Evgeni Golov 2018-02-21 10:30:07 UTC
Description of problem:
The currently packaged version of PostgreSQL JDBC in RHEL7 is not compatible with PostgreSQL 9.6 and later servers, resulting in errors like "column am.amcanorder does not exist".

The upstream fix is at https://github.com/pgjdbc/pgjdbc/pull/560 and https://github.com/pgjdbc/pgjdbc/pull/569

PostgreSQL 9.6 is available from RHSCL


Version-Release number of selected component (if applicable):
postgresql-jdbc-9.2.1002-5.el7

How reproducible:
100%


Steps to Reproduce:
1. use an app that needs/creates indexes with ASC/DESC sorting

Actual results:
ERROR: column am.amcanorder does not exist

Expected results:
query succeeds

Additional info:
please update to 9.4.1209 or later (Fedora has 9.4.1209, upstream is at 42.2.1)

Comment 2 Pavel Raiskup 2018-02-21 12:47:48 UTC
New version of the pgjdbc project has new dependencies, update
to the 42.2.1 would risky and too heavy weight.

Comment 3 Evgeni Golov 2018-02-21 12:55:27 UTC
(In reply to Pavel Raiskup from comment #2)
> New version of the pgjdbc project has new dependencies, update
> to the 42.2.1 would risky and too heavy weight.

How about an older version, like the one currently in Fedora? Anything newer than 9.4.1209 *should* be good (untested, tho).

Comment 4 Pavel Raiskup 2018-02-21 13:43:27 UTC
Backport for important fixes is always preferred in RHEL.  Any update has
some risks (and anything higher than 9.4.1206 brings complex packaging
changes).

Comment 5 David Ward 2018-04-19 17:38:45 UTC
What can be done to get a new postgres-jdbc rpm to address https://issues.jboss.org/browse/RHPAM-740 ? 

These are the repositories we build our openshift images with:
http://pulp.dist.prod.ext.phx2.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os/
http://pulp.dist.prod.ext.phx2.redhat.com/content/dist/rhel/server/7/7Server/x86_64/ose/3.6/os/
http://pulp.dist.prod.ext.phx2.redhat.com/content/dist/rhel/server/7/7Server/x86_64/rhscl/1/os/
http://download.lab.bos.redhat.com/rcm-guest/puddles/RHOM/1.0/latest/x86_64/os

If the rpm could be created included the 9.6 fix noted above (which is less risky and doesn't have the new dependencies that 42.x does), perhaps it could be added to that last repo? "rcm-guest/puddles/RHOM/1.0/latest"?


Note You need to log in before you can comment on or make changes to this bug.